Wireless problems, please help if you can

I am using openSUSE 11 on a Dell Inspiron 1525

Having read the sticky, I’ve got the following info:

0b:00.0 Network controller: Broadcom Corporation BCM4310 USB Controller (rev01)
0b:00.0 0280: 14e4:4315 (rev 01)

I can find nothing on firmware.

I tried Ndiswrapper…
Downloaded the driver ok
Ndiswrapper installed driver ok
When I try ndiswrapper -l I get:
bcmwl5 : driver installed

However, I still have no wireless.

Can this be fixed? If not, is there a good usb wireless I can buy that will work with openSUSE without problems?

Many thanks in advance

PS. I tried iwconfig and got

lo no wireless extensions.

eth0 no wireless extensions.

go here Ralink Technology: Linux

download the RT2501 firmware, unzip the file and copy (as root) the
rt*.bin files to /lib/firmware. After you do that, your device should
work. wen i say as root login as root from the start menu

Sorry this may sound stupid, but which version of the file do i need to download?

Firmware RT2501(RT2561/RT2661)

Firmware RT2501USB(RT2571W/RT2671)

I extracted both sets of .bin files, still no wifi!

if you read the stickies you would have noted there are 2 ways to get the firmware for your device. as it is Broadcom Corporation BCM4310, if you have a wired connection type

sudo /usr/sbin/install_bcm43xx_firmware 

if you don’t have a wired connection, do this

Using any method that you have to access the Internet, download this

Then copy it into your home directory. Once you have it there, you should enter the following:

tar xjf broadcom-wl-
sudo mkdir -p /lib/firmware
sudo b43-fwcutter -w /lib/firmware \ broadcom-wl-


I have no idea why someone suggested that you use RaLink firmware when
you have a Broadcom device. Of course, advice is worth what you pay
for it!

In your case, your BCM4310 USB device, which isn’t really a USB unit,
with a PCI ID of 4315 is not yet handled by the b43 driver. As noted
here many times, the reverse engineering is in progress, and this
device will be the next one supported; however, I can make no
promises. For now, you can either try the Broadcom hybrid driver or
ndiswrapper using the Windows driver. Neither option is particularly
attractive as both involve using closed-source binary that can and
will crash your computer.



Problem has been solved!!!

The sudo /usr/sbin/install_bcm43xx_firmware did not work for my bcm4310, but I went back to the Ndiswrapper fix, and realised what I had done wrong.

I had previously just downloaded the inf file it needed, without the other files. I didn’t realise that although you only ask Ndiswrapper to install the inf file, it also needs to call on various other files which come with the driver.

Anyway, thanks for your answers, I am glad to say all is well.:slight_smile: