Wireless problems on an Acer Aspire V3-772

Hello,

I have recently bought an Acer Aspire V3-772 with an AR9462 Wireless Network Adapter by Qualcomm Atheros. However, I am unable to get the
wireless card working under SuSE 13.1 with the ath9k
driver. The wireless appears to be connecting, but
then disconnecting after seconds. Does anybody know
what to do?

Welcome to the forums. There is already a thread about his problem at http://forums.opensuse.org/showthread.php/496038-Wireless-breakages-with-AR9462. This is a known problem in other distributions. So, if you don’t get an answer that helps you here, you may get one elsewhere.

Thank you, John! I see that the other thread at least contains some hints. Can you be more specific where this problem is discussed in the forums of other distributions?
Best regards, Yorck

I have solved my problem; here is what worked for me:

  1. In the directory /etc/modprobe.d, I created a text file called “ath9k.conf”.

  2. In this file, I wrote the single line “options ath9k btcoex_enable=1”.

That did it. “btcoex” stands for “bluetooth coexistence”. The kernel
developers in fact mention that this is necessary, namely on this page

http://wireless.kernel.org/en/users/Drivers/ath9k/btcoex

which I overlooked. As John mentioned, the problem is discussed on many
other pages, for example on

http://askubuntu.com/questions/301442/atheros-ar9462-wifi-very-unstable-package-loss

However, the options “nohwcrypt” and “blink” described there did not play a role in my case.
The developers comment on “nohwcrypt” on this page:

http://wireless.kernel.org/en/users/Drivers/ath9k/bugs

As this was mentioned on other pages, I disabled IPv6 on boot. I do not know whether
this was relevant, but I do not think so.

Thanks for sharing your discoveries.

This just got my wifi working on an Acer Aspire V3-572-5217. The Atheros drivers were already there, so I didn’t have to go find them elsewhere, as other threads suggested.
I have to say that judging by the first 5 minutes, the internet seems really slow on this machine compared to other ones on the same wifi network. Just glad to have it working at ll, thanks Ysommerh!

For anyone else who comes across this thread: My wifi continued to act strangely after getting it (minimally) working as described above. It seemed slow, I was constantly having to re-authenticate, every so often I couldn’t load web pages in spite of supposedly being connected, and had to restart.
I updated to the latest stable kernel (3.16 in my case)

sudo zypper ar http://download.opensuse.org/repositories/Kernel:/stable/standard     Kernel:stable
zypper in --from Kernel:stable kernel-desktop

its been almost 48 hours and all seems well with the wifi (page loads do seem to be slow, but a speed test indicates no problem, so maybe the issue lies elsewhere).