Wireless problem

Hi,

i installed suse (KDE) on my old notebook and now I’m trying to get the wlan to connect to our router and can’t figure out how to get it to work. I hope you guys can help me.

My card seems to work, the network manager even finds the router, but i just cant get a connection.

I followed the steps of the “Getting Your Wireless to Work” thread and these are the results:

What device do you have?
Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection
Kernel Driver: ipw2200
UDI: /org/freedesktop/Hal/devices/pci_8086_4220

Do you need to install external firmware?
Don’t think so. Here are all lines associated with my wlan-card in the the boot.msg

7.824565] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kdmprq
7.824569] ipw2200: Copyright(c) 2003-2006 Intel Corporation
8.067085] ipw2200 0000:06:03.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
8.068041] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
8.068102] ipw2200 0000:06:03.0: firmware: requesting ipw2200-bss.fw
8.205554] ipw2200: Radio Frequency Kill Switch is On:
8.206461] ipw2200: Detected geography ZZM (11 802.11bg channels, 0 802.11a channels)

NOTE: yes, it does say that it is turned of, which it was at startup, but of course i turned it on afterwards.

Making a connection
This is what the “/usr/sbin/iwlist scan” command returned.
eth1 Scan completed :
Cell 01 - Address: 00:1E:69:9C:24:93
ESSID:“UPC011570”
Protocol:IEEE 802.11bg
Mode:Master
Frequency:2.447 GHz (Channel 8)
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=20/100 Signal level=-86 dBm
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
Extra: Last beacon: 3732ms ago

Association and authentication
This is the result from the “/usr/sbin/iwconfig” command:
eth1 IEEE 802.11g ESSID:“UPC011570”
Mode:Managed Frequency:2.447 GHz Access Point: 00:1E:69:9C:24:93
Bit Rate:54 Mb/s Tx-Power=20 dBm Sensitivity=8/0
Retry limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=35/100 Signal level=-79 dBm Noise level=-84 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:39

NOTE: most of the time when i see this info it reads something like “not associated” in the first line.

Testing
So i tried to find out the IP and here is the first thing that i can see to be wrong /strange:
It does not show an ip, but does show an ip6 (which i thought i had deactivated, and which is not checked in the network konfiguration).
eth1 Link encap:Ethernet HWaddr 00:12:F0:3B:AF:7A
inet6 addr: fe80::212:f0ff:fe3b:af7a/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:30 errors:0 dropped:0 overruns:0 frame:0
TX packets:33 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4540 (4.4 Kb) TX bytes:4405 (4.3 Kb)
Interrupt:17 Base address:0x6000 Memory:c8218000-c8218fff

Well, that is all i know for now. Can anybody help me here?

Looking forward to any solutions/tips/ideas.
Thanks! :slight_smile:

PS:
Important notes:

  • i’m totally new to linux, so it might be something totally simple that i missed or just don’t know.
  • i messed around a bit with the network settings and might have cluelessly broken something (or broken it more)
  • i tried a usb-wlan-card as an alternative, which didn’t work either, but could possibly have messed things up even more.

Nobody? :frowning:

Did i ask the wrong question? Provide the wrong or not enough information?

Try this on the Options line: ipv6_disable=1 at boot. Use the Networkmanager to try create a connection. If this works, get back here with reply and we’ll help you to make this persistent.

And a warm welcome here.

Thanks for the welcome and the tip. Unfortunately it didn’t work with this setting either.
I still have a ipv6 (and only that) for the wireless card when checking ifconfig. (although I’m not that certain anymore if this actually means anything…)
When I try to connect to the accesspoint/router (I’m not entirely certain of the difference here) it says “activating” and the mouseover reads “obtaining network address” and that’s how far it goes.

Have you checked the “Getting Wireless to Work” sticky? This is a step-by-step about how to get it up and working. Most times, firmware and drivers are needed to get this up and running. The question is do you have it and if so, is it for the model of your wireless LAN card? Depending on the brand of wireless LAN card, this can be as simple as a firmware install. Check that sticky and it may be of more help to you. You can also look on opensuse.org at this link about wireless problems. Perhaps your answers lie there as well.

Tracking down wireless problems - openSUSE

j-dub: when you ask

Have you checked the “Getting Wireless to Work” sticky?

to be fair to Floh_B, he does says in third line of his post

I followed the steps of the “Getting Your Wireless to Work” thread and these are the results:

and I think he did a really good job of detailing what he had done; I am not sure if Axel would feel that Framp’s script would add further to the details already supplied:

Floh_B: if you think of running this diagnostic script, to see if it furnishes any more information:

collectNWData Überblick / Overview | collectNWData.sh

I just tried the “ipv6_disable=1” entry again, only this time i put it in front of the boot options line (instead of behind the line about vga that is there by default) and it worked! :slight_smile:
Well, at least partly, i can connect and ping my router - but i can’t ping anything outside the network.

I also ran the script, it returns with the errors:
CND0110E: For the selected connection type there was no active network interface found on your system
CND0240E: knetworkmanager for network configuration enabled but a YAST network card configuration for eth1 exist.

Correction, it does work!! :slight_smile: :slight_smile:

Thanks a lot!!