wireless only works for first session

hi all

today I have installed 12.1 a couple of times due to a dual boot issue which is now resolved. I noticed the wireless manager found and connected to wireless networks straight after a fresh install but wouldnt see networks after the pc was rebooted.

Currently the xfce wireless manager is either not displaying any networks or a message saying ‘device not ready’.

The wireless card is not hard blocked: fn + f5 disables/enables the wireless.

the card is an atheros, can’t remember how to check exactly which one.

I know the driver is ath5k

im running 12.1 with xfce

2 possible causes are a windows xp installation and an upgrade from 512 ram to 1.5gb

cheers for any help

Right click on the network icon, and select “edit connection”.

Select the connection that you have setup for editing.

Make sure that the settings for this connection say that the connection is shared - I think that’s a check box near the bottom left.
Also make sure that the connect is set to “connect automatically”.

You will probably be asked for the root password to check those settings.

If those were already set as suggested, then I am not sure what is going wrong. If they were not already set, then after making the changes see if it connects after a reboot.

It shouldn’t be as hard as that. But this version of NetworkManager has caused problems for some people.

By the way, I do have a system with an atheros card, and that has connected pretty reliably for me. However, I do find that I need to have the connection shared with all users (called a “system connection” for KDE). Privately defined connections just don’t work very well with the current NetworkManager version.

Addition comment (added in edit): Make sure that wireless is working in XP, just before you reboot to linux.