wireless on opensuse leap 42.2 kde wasnt working

for some reason wireless didnt want to install on leap 42.2 kde I tried everything to no go.out of frustration I installed gnome voilla it worked and connected ok ,so I am not sure if there is a bug in kde or what the problem was
regards grumpy


I had this issue, when I did upgrade one of my machines. However, because I did not want to upgrade the machine while installing (I had some work to on it), I did not setup the WiFi connection on install, but wanted to do that later on, after the first boot, so that I could keep using the system while updating.

What I did, was a simple re-install of the system, this time setting the WLAN card up in the installer at install time. It updated all the packages and then booted. WLAN was working just fine then. I guessed that it was because of that, but it could also be a bug.

Hi there, I might not be helpful to your problems, and just here to remind you that there are several sticky posts in this board, such as “Getting your wireless to work”(https://forums.opensuse.org/showthread.php/410319-Getting-Your-Wireless-to-Work), could be very helpful for debugging your problems. Have you read and tried the tricks? And what the results?

And these sticky threads also inform you about what information others need to be able to even start to help you. Just saying that something unknown doesn’t work is not very informative.

I also have 2 fresh openSUSE Leap 42.2 installs that were made with a network cable connected, so here we go: == I. Why is Wireless a Problem? == This sections talks about why providing drivers is difficult. However, that’s not the problem here as my 2 affected laptops have widely used and sufficiently old (3-5 years) Intel wireless that worked fine with vanilla openSUSE 13.1 and 13.2. == II. What device do you have? == Both laptops report under YaST => Hardware => Hardware Information that they have Centrino Advanced-N 6205 AGN and use Kernel Driver: iwlwifi. == III. Do you need to install external firmware? == “dmesg” shows that iwlwifi firmware was loaded successfully. (Note that the reporting instructions need to be updated: YaST => Miscellaneous => System Logs no longer offers “boot.msg”.) The radio kill switch is not activated. In addition, “dmsg” reports for iwlwifi: * can’t disable ASPM; OS doesn’t have ASPM control * CONFIG_IWLWIFI_DEBUG enabled, CONFIG_IWLWIFI_DEBUGFS enabled and CONFIG_IWLWIFI_DEVICE_TRACING disabled * Detected Intel Centrino… * L1 Enabled - LTR Disabled (A google search suggests that the latter is related to how the radio channel is shared.) == IV. Making a connection == “/usr/sbin/iwlist scan” says “wlan0 Interface doesn’t support scanning : Network is down” Expected to find * 1 network with excellent signal (nearest AP) * 4 networks with good signal (2nd and 3rd nearest router with 2 SSIDs each) * 5 networks with fair signal (SSIDs following patterns such as “UPS+number”, “TP-LINK_+hexcode” and “SKY+hexcode” suggest that these are on 5 different routers) * 6 networks with poor signal (SSIDs suggests that these are at least 4 different routers) == V. to IX assume that a network can be found. == Additional useful information: * cabled network works fine * YaST > Network Settings reports network “handled by NetworkManager or completely disabled” * YaST > Network Settings > Overview lists the wireless adapter with “IP address not configured” * KDE tray icon allows to deactivate and re-activate the cabled connection * KDE tray icon shows wireless and flight mode symbols in red; flight mode can be toggled but not the wireless. – If this issue is confirmed more widely and if the workaround to install without cabled connection works in most cases, it would be good to put advise to install without cabled connection on openSUSE:Most annoying bugs 42.2 - openSUSE Wiki . JJ

While installing 42.2 again on one laptop, this time with the network cable disconnected, wireless on the other laptop started working. I’ve no idea why. I installed no new updates since the observation of the issue. There were just a few reboots, falling to sleep while idle (no power connected) and waking up. I might have entered YaST to check network settings but did not make any changes. I compared /etc of both installations with diff -r -U 5 and “kompare” and don’t see anything relevant. The udev rules for the iwlwifi device seem to have been written at different stages of the installation. (The new system repeats some comments. The rule itself is the same, except for the “address” attribute.) If somebody else observes this issue, my suggestion would be to make a backup of /etc straight away for later comparison, to document relevant events (for example reboots, updates, starting of YaST modules and any sleep cycles) and to check frequently via the “Networks” tray icon whether the wireless suddenly works.

Please, please, please. Try to create readable posts. The posts you have now are one indigestible mass of characters. Different paragraphs for different steps will help enormous.

And when you want to post computer text (which is something we love above much talking), please use CODE tags around that copied/pasted computer text. It is the # button in the rool bar of the post editor.

Sorry, it’s my first 2 days using NoScript (and uBlock Origin) and I didn’t realise at the time that I need to allow scripts as the forum otherwise seemed to work fine.

I did a 3rd fresh install, this time with network cable connected as in the 1st install and not re-using /home of the previous install. This did not replicated the issue. Only visible difference to the system that was installed without the cable plugged in is that the tray icon is the symbol for wired connections rather than the wireless symbol.