Wireless not working with network -- traditional method with ifup

  1. I installed suse 11.4 on a desktop machine
  2. Installed a USB wireless card with driver Athreos
  3. This machine is going to be used as a router with squid
  4. Wired network card is working fine with ifup
  5. This wireless is not working. It has statically assigned ip address.
  6. The ip has been set…i can see it in ifconfig
  7. The wireless LED indicator on wireless router is on, also the LED on the USB wireless card is also on… which means the connection is established
  8. But i cannot ping to router ip. ping returns not reachable
  9. If im connecting using network manager… everything works perfectly fine…
  10. But since this is an intranet router server … always its not possible to login to the system …
  11. This problem exists in my laptop too … im using knetworkmanager to connect wirelessly …since its laptop its fine …
  12. Please give me a solution for this problem …

You seem to be saying that it connects ok when using network manager but not with ifup?

You don’t mention whether you’ve tried setting things up on ifup using yast or commands, but there are two ‘stickies’ at the top of the wireless section of the forum which deal with both, don’t know if you’ve already worked through them but the info they have on getting your wireless working is pretty excellent

This one is a walkthrough on how to set up wireless: Getting Your Wireless to Work

This one is basically things to try if the first one fails: My wireless doesn’t work - a primer on what I should do next

Your post doesn’t really give the kind of info people need to help diagnosing the issue and a lot of it you obtain if you follow those threads so they’re definitely worth looking at if you haven’t already

I have gone thru the above forum and did not find it success…
The following are the details of my wireless adapter

Terminator:/home/babu # lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 9710:7830 MosChip Semiconductor MCS7830 10/100 Mbps Ethernet adapter
Bus 003 Device 002: ID 04ca:0022 Lite-On Technology Corp.
Bus 001 Device 004: ID 0cf3:9271 Atheros Communications, Inc. AR9271 802.11n

Terminator:/home/babu # iwlist scan
lo Interface doesn’t support scanning.

eth2 Interface doesn’t support scanning.

eth1 Interface doesn’t support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:22:75:6E : D7:CE
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=62/70 Signal level=-48 dBm
Encryption key : on
ESSID:“Matrix”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
18 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=00000000ed84b13c
Extra: Last beacon: 439ms ago
IE: Unknown: 00064D6174726978
IE: Unknown: 010882848B961224486C
IE: Unknown: 030101
IE: Unknown: 2A0104
IE: Unknown: 32040C183060
IE: Unknown: 2D1AEE1113FF000000010000000000000000000000000C0000000000
IE: Unknown: 3D1601050400000000000000000000000000000000000000
IE: Unknown: 3E0100
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
IE: Unknown: 7F0101
IE: Unknown: DD07000C4307000000
IE: Unknown: DD1E00904C33EE1113FF000000010000000000000000000000000C0000000000
IE: Unknown: DD1A00904C3401050400000000000000000000000000000000000000
IE: Unknown: DDB70050F204104A0001101044000102103B00010310470010775B6680BFDE11D38D2F0022756ED7CE1021001442656C6B696E20496E7465726E6174696F6E616C10230018456E68616E63656420576972656C65737320526F757465721024000C463644343233302D342076311042000E32303931393432333032323635381054000800060050F20400011011001F42656C6B696E20456E68616E63656420576972656C65737320526F75746572100800020084103C000101

dsl0 Interface doesn’t support scanning.

Terminator:/home/babu # iwconfig
lo no wireless extensions.

eth2 no wireless extensions.

eth1 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:“Matrix”
Mode:Managed Frequency:2.412 GHz Access Point: 00:22:75:6E: D 7:CE
Bit Rate=1 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr : off Fragment thr : off
Encryption key:A8F9-A3P9-E7F8-BD88-2A83-8940-A7
Power Management : off
Link Quality=63/70 Signal level=-47 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

dsl0 no wireless extensions.

Terminator:/home/babu # ifconfig
dsl0 Link encap : Point-to-Point Protocol
inet addr:117.207.239.117 P-t-P:117.207.232.1 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1460 Metric:1
RX packets:5484 errors:0 dropped:0 overruns:0 frame:0
TX packets:4374 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:5161024 (4.9 Mb) TX bytes:576248 (562.7 Kb)

eth1 Link encap:Ethernet HWaddr 00:A1:B0:70:00:C2
inet addr:192.168.2.2 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::2a1:b0ff:fe70:c2/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:20 errors:0 dropped:0 overruns:0 frame:0
TX packets:164 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:5027 (4.9 Kb) TX bytes:26497 (25.8 Kb)

eth2 Link encap:Ethernet HWaddr 00:80:48:6F:ED:6C
inet6 addr: fe80::280:48ff:fe6f:ed6c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:6346 errors:0 dropped:29 overruns:0 frame:0
TX packets:5042 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:5651064 (5.3 Mb) TX bytes:794638 (776.0 Kb)
Interrupt:20

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:171 errors:0 dropped:0 overruns:0 frame:0
TX packets:171 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:13880 (13.5 Kb) TX bytes:13880 (13.5 Kb)

wlan0 Link encap:Ethernet HWaddr 00:1E:A6:06:11:F3
inet addr:192.168.2.5 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::21e:a6ff:fe06:11f3/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:408 errors:0 dropped:0 overruns:0 frame:0
TX packets:23 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000

Terminator:/home/babu # cat /etc/sysconfig/network/ifcfg-wlan0
BOOTPROTO=‘static’
BROADCAST=’’
ETHTOOL_OPTIONS=’’
IPADDR=‘192.168.2.5/24’
MTU=’’
NAME=’’
NETWORK=’’
REMOTE_IPADDR=’’
STARTMODE=‘auto’
USERCONTROL=‘no’
WIRELESS_AP=‘Matrix’
WIRELESS_AP_SCANMODE=‘1’
WIRELESS_AUTH_MODE=‘psk’
WIRELESS_BITRATE=‘auto’
WIRELESS_CA_CERT=’’
WIRELESS_CHANNEL=’’
WIRELESS_CLIENT_CERT=’’
WIRELESS_CLIENT_KEY=’’
WIRELESS_CLIENT_KEY_PASSWORD=’’
WIRELESS_DEFAULT_KEY=‘0’
WIRELESS_EAP_AUTH=’’
WIRELESS_EAP_MODE=’’
WIRELESS_ESSID=‘Matrix’
WIRELESS_FREQUENCY=’’
WIRELESS_KEY=’’
WIRELESS_KEY_0=’’
WIRELESS_KEY_1=’’
WIRELESS_KEY_2=’’
WIRELESS_KEY_3=’’
WIRELESS_KEY_LENGTH=‘128’
WIRELESS_MODE=‘Managed’
WIRELESS_NICK=’’
WIRELESS_NWID=’’
WIRELESS_PEAP_VERSION=’’
WIRELESS_POWER=‘yes’
WIRELESS_WPA_ANONID=’’
WIRELESS_WPA_IDENTITY=’’
WIRELESS_WPA_PASSWORD=’’
WIRELESS_WPA_PSK=‘1234567890WhatIsyournameMan’

Terminator:/home/babu # ping -c 5 192.168.2.1
PING 192.168.2.1 (192.168.2.1) 56(84) bytes of data.
From 192.168.2.2 icmp_seq=2 Destination Host Unreachable
From 192.168.2.2 icmp_seq=3 Destination Host Unreachable
From 192.168.2.2 icmp_seq=4 Destination Host Unreachable
From 192.168.2.2 icmp_seq=5 Destination Host Unreachable

— 192.168.2.1 ping statistics —
5 packets transmitted, 0 received, +4 errors, 100% packet loss, time 4000ms
pipe 3

please tell me what im doing wrong… when connected via network manager… every thing is fine … i can connect to the router and also any machine connected to this network … But via ifup … evrything failed

Your machine is associated and authenticated. I think you have a routing
problem. What does ‘/sbin/route -n’ show. If that has the proper global routing
set, then check /etc/resolv.conf.

Setting up a network with ifup is a lot harder that with NM. There are meny
details that you have to get right.