Wireless not working with Dell Studio 1737

Hi guys,

I have a laptop that I upgraded from 11.4 to 12.1 using the Tumbleweed service. Wireless stopped working once the upgrade was complete. I am able to connect via ethernet.

lspci gives me:

04:00.0 Network controller: Intel Corporation WiFi Link 5100

Here’s the output from “dmesg | grep iwlagn”:

   15.347286] iwlagn 0000:04:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
   15.347296] iwlagn 0000:04:00.0: setting latency timer to 64
   15.347327] iwlagn 0000:04:00.0: pci_resource_len = 0x00002000
   15.347330] iwlagn 0000:04:00.0: pci_resource_base = ffffc9001109c000
   15.347332] iwlagn 0000:04:00.0: HW Revision ID = 0x0
   15.347421] iwlagn 0000:04:00.0: irq 46 for MSI/MSI-X
   15.347476] iwlagn 0000:04:00.0: Detected Intel(R) WiFi Link 5100 AGN, REV=0x54
   15.347542] iwlagn 0000:04:00.0: L1 Enabled; Disabling L0S
   15.539143] iwlagn 0000:04:00.0: device EEPROM VER=0x11f, CALIB=0x4
   15.539147] iwlagn 0000:04:00.0: Device SKU: 0Xf0
   15.539161] iwlagn 0000:04:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
   15.620584] iwlagn 0000:04:00.0: loaded firmware version build 33692
   25.155075] iwlagn 0000:04:00.0: L1 Enabled; Disabling L0S
   25.158695] iwlagn 0000:04:00.0: Radio type=0x1-0x2-0x0
   25.314520] iwlagn 0000:04:00.0: L1 Enabled; Disabling L0S
   25.317716] iwlagn 0000:04:00.0: Radio type=0x1-0x2-0x0
  171.835360] iwlagn 0000:04:00.0: Tx aggregation enabled on ra = 00:23:69:ff:b2:42 tid = 0
 1735.343185] iwlagn 0000:04:00.0: Tx aggregation enabled on ra = 00:23:69:ff:b2:42 tid = 6
 4492.362914] iwlagn 0000:04:00.0: Stopping AGG while state not ON or starting
 4492.363038] iwlagn 0000:04:00.0: Stopping AGG while state not ON or starting
 4519.271576] iwlagn 0000:04:00.0: Tx aggregation enabled on ra = 00:23:69:ff:b2:42 tid = 0
 6228.071527] iwlagn 0000:04:00.0: Tx aggregation enabled on ra = 00:23:69:ff:b2:42 tid = 6
 6543.722193] iwlagn 0000:04:00.0: Stopping AGG while state not ON or starting
 6543.722294] iwlagn 0000:04:00.0: Stopping AGG while state not ON or starting

Here’s the output from “/usr/sbin/iwconfig”:

wlan0     IEEE 802.11abgn  ESSID:"linksys"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:23:69:FF:B2:42   
          Bit Rate=52 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-35 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:11   Missed beacon:0

“/usr/sbin/iwlist scan” finds all the wireless networks in the neighborhood.

Both YaST2 and networkmanager tell me that the device is connected to the wireless router and to the internet. However, I’m not able to ping the router, or any web pages.

I’ve tried deleting the device in YaST2 and rebooting, which got it to finally connect to the router, but not to the internet. I’ve tried it with and without IPv6 - doesn’t seem to make a difference.

If you see anything or have any ideas, please let me know your thoughts. According to Intel® Wireless WiFi Link drivers for Linux*, “The iwlwifi driver has been merged into mainline kernel since 2.6.24” - so the firmware is already be on board.

Any thoughts would be greatly appreciated.
Andy Prough

I do not know enough to help with the specifics of your problem, and hopefully one of our Wireless guru’s will step in and help. I can say that I have a Dell Studio 1537 (similar model to your 1737 but with 15" instead of 17" display) with an Intel Corporation WiFi Link 5300 (similar to the 5100 on your Dell but purportedly with higher speed). A week ago I installed a 64-bit openSUSE-12.1 KDE4 (replacing 11.3 with a clean install) , keeping my /home directory. Wireless worked for me only after setting up a new user account (and not on the old account - but my update in /home from 11.3 to 12.1 is larger than your tumbleweed update). Since then I have used the laptop once at home (powered for 24 hours connected to our home Speedport W 920 V router) and once during a business meeting (powered for 6 hours connected with an office router) and the wireless connection was solid on 12.1. In addition in a separate brief 15 minute test, with a different router (a portable 3G router (Edimax)) where I could not get a solid wireless connection with 11.3, I happily note that I can get a solid connection with 12.1 . So given the similarity with my Dell (and wireless) to your Dell (and wireless), I’m hopeful this is solvable for you, and hopefully the Guru’s on our forum may be able to help.

Thanks for the advice oldcpu - what do you mean by “Wireless worked for me only after setting up a new user account”?? Do you mean you set up a new KDE login account, or some new account on your wireless network? Maybe this is the key to getting it working?

Andy Prough

I don’t know if what I did was a key, but I do know my knowledge of the details of where and how KDE keeps its configuration files is from poor to pathetic. But it appeared there was some configuration information in my /home/oldcpu directory (from openSUSE-11.3) that was messing up my network configuration with the KDE NetworkManager in openSUSE-12.1. So I created a new GNU/Linux user on my PC (called ‘tom’) and I logged in to GNU/Linux and KDE4 as user ‘tom’ and much to my surprise, user ‘tom’ had wireless access, while user oldcpu did NOT have access. :frowning:

So I checked to ensure I had all of /home/oldcpu backed up (including my .thunderbird, and bookmarks, and .VirtualBox and some other ‘hidden directories’) and then when logged in as user ‘tom’ I completely removed user oldcpu, including deleting /home/oldcpu. I then recreated user oldcpu, and I logged back on as user oldcpu, and wireless worked for ‘oldcpu’. Then I restored most (but not all) of the content of the old /home/oldcpu from backup to the new /home/oldcpu.

It took a while (to restore from backup) but in the end I had a nice solid access.

But its possible your problem is different … Still, given our devices are not ‘that’ different, I think it should be possible for one of our network guru’s to give you the advice needed to get this working.

Hi oldcpu,

Ahhh - thanks for the advice on that one. Yes, I had a similar problem - when I first upgraded with Tumbleweed I couldn’t get networkmanager to work to save my life. One of the other threads mentioned simply renaming the .kde4 profile in the home directory, so that on the next login KDE would create a new profile. I did that, and it brought networkmanager up. Your solution sounds more thorough, but probably quite a bit more work!

However - good news is that I’ve resolved this problem with the Dell 1737 - turns out the router was going bad. Today I couldn’t get any of the computers in the office to connect to the internet, and I finally realized I must have had a router that was going bad. The router was a 3 year old Linksys that had been through some power outages recently, and wasn’t near as cheerful as it had once been, so it was time for a changeout. Got the new one going tonight, and all the computers are happy again.

Thanks for bearing with me on this one!
Andy Prough
Kyle, Texas, USA

Glad to read you found the problem.