Wireless not working - have read stickies!

1 ) make and model of wireless device.
Here’s some hardware info:

26: PCI 605.0: 0282 WLAN controller
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_8086_4220
  Unique ID: H185.gy1ZasUC0k5
  Parent ID: 6NW+.pbi2aV6ikBD
  SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:06:05.0
  SysFS BusID: 0000:06:05.0
  Hardware Class: network
  Model: "Intel PRO/Wireless 2200BG [Calexico2] Network Connection"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x4220 "PRO/Wireless 2200BG [Calexico2] Network Connection"
  SubVendor: pci 0x8086 "Intel Corporation"
  SubDevice: pci 0x2702 
  Revision: 0x05
  Features: WLAN
  Memory Range: 0xb8006000-0xb8006fff (rw,non-prefetchable)
  IRQ: 10 (no events)
  Requires: ipw-firmware
  Module Alias: "pci:v00008086d00004220sv00008086sd00002702bc02sc80i00"
  Driver Info #0:
    Driver Status: ipw2200 is not active
    Driver Activation Cmd: "modprobe ipw2200"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #21 (PCI bridge)

2 ) driver version in use
3 ) any error message.
wireless just doesn’t show up

4 ) what you have tried to rectify the problem.
research, over my head

5 ) any trouble-shooting guide you have tried to follow.
My wireless doesn’t work - a primer on what I should do next
Welcome (from wireless forum)

6 ) openSUSE version
OS: Linux i686
System: openSUSE 11.1 (i586)
KDE: 4.1.3 (KDE 4.1.3) “release 4.9”

7 ) type /sbin/lspci -v

06:05.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
        Subsystem: Intel Corporation Device 2702                                                         
        Flags: medium devsel, IRQ 10                                                                     
        Memory at b8006000 (32-bit, non-prefetchable) [size=4]                                          
        Capabilities: <access denied>                                                                    
        Kernel modules: ipw2200  

I have also tried some checks from the primer stickie:

06:05.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)

/sbin/lspci -n
06:05.0 0280: 8086:4220 (rev 05)

dmesg | less
PCI: 0000:06:05.0 reg 10 32bit mmio: [b8006000, b8006fff]
pci 0000:06:05.0: PME# supported from D0 D3hot D3cold
pci 0000:06:05.0: PME# disabled

lo        no wireless extensions.

eth1      no wireless extensions.

I thought the problem might be driver or firmware. I don’t know anything about drivers and i looked in /lib/firmwar and ipw2200 fimware appears to be there (ipw2200-bss.fw, ipw2200-ibss.fw, ipw2200-sniffer.fw)

Thanks in advance and sorry for still not having the hang of this. What can i do next?[/size]

  Driver Info #0:
    Driver Status: **ipw2200 is not active**
    Driver Activation Cmd: "**modprobe ipw2200**"

Really? That easy? I am ashamed.
Thank you very much, it works now!

Not quite that easy for persistent use.

Normally this module should be loaded automatically (which it always has on my older laptop with the same card since SuSE 9.2), but if it doesn’t:

## Type:                string
## ServiceRestart:      boot.loadmodules
# This variable contains the list of modules to be loaded
# once the main filesystem is active
# You will find a few default modules for hardware which
# can not be detected automatically.

add the module ipw2200 here (file is /etc/sysconfig/kernel).