Wireless not working for Compaq Presario

I just finished putting openSUSE 11.4 on my Compaq Presario V5000.
I have been trying for hours to find the answer of how to get my wireless card to work. I can’t connect to my router wirelessly and the on/off button for the wireless mode does not light up when pressed.
As far as I can tell from what I have already tried, I have a broadcoamm wireless card. It is a bm4318.
I have b43-fwcutter installed and I have tried updating my firmware through the terminal.
I have also used ‘sudo /usr/sbin/install_bcm43xx_firmware’. It appeared successful, but the laptop still cannot make a wireless connection.
Any help would be appreciated

Please follow the sticky posts and output the ID of your network card.

Do you see any networks available, or is the wireless even on at all?
If I’m not mistaken you can’t use both b43-cutter and bcm43xx. The driver and firmware are both integrated into one package if my recollection is correct.

Also, there’s a very common problem with broadcoms and rfkill, post the output of

rfkill list

Your device is supported by the b43 driver.
Read through all the information on this page, it will help clear things up for you. b43 - Linux Wireless

Thanks for your reply.
While waiting, I noticed that the system had many updates it wanted to do. I let it make the updates and then my wireless card was recognized.
I am not sure which thing I did previously helped, or maybe none of them helped and all it needed was the update.

It was most likely the kernel update.
I’m glad you got it working.

Ok, so it is once again not working. I hit the wireless button to make sure it could be toggled on and off. It turns out it couldn’t be, and I can’t get it working again.
Any thoughts?

Final update: I went through YAST and changed the control to ifup and then back again to network manager. This must have reset the wlan settings. After a reboot, it is working again. I am NEVER touching that wireless button again.
Thank you.