wireless not working- broadcom 4311

I will start off by saying I am new to Linux so I am not even sure what information I should be providing but here is my issue…

I have installed opensuse 11 with KDE 3.5 on my HP dv6226us laptop with Broadcom 4311 wireless. I also tried KDE 4.0 and had the exact same results.

I have gotten the firmware for the 4311 installed using these commands from the sticky thread (I only have a wireless connection):

tar xjf broadcom-wl-
sudo mkdir -p /lib/firmware
sudo b43-fwcutter -w /lib/firmware \ broadcom-wl-

After that, I could see the wireless network but usually cannot connect to it (I just see the spinning of the wheels on the Knetworkmanager and after 30 seconds it goes back to gray). The weird part is that once in a great while I do get connected (I cannot figure out the pattern here) but the connection is spotty and goes away after a few minutes.

I do dual boot with Windows Vista and I have done a complete shutdown (even went as far as to unplug the machine and take out the battery) with no better results.

Well, I thank whomever in advance for any help


What do you see with a ‘sudo iwlist scan’ command?

What does ‘dmesg | grep b43’ show?

Do you shutdown Windows, or do you suspend it?

The BCM4311 devices work very well with b43 as the driver. Yours should too.


Hi Larry,

Thanks for the response!

Good to know the card should work… which probably means I am running circles around the obvious. Oh well, I guess that is the fun of computers.

Anyways, per your suggestions:

“dmesg | grep b43” command shows…
b43-phy0: Broadcom 4311 WLAN found
input: b43-phy0 as /devices/virtual/input/input10
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Registered led device: b43-phy0::tx
Registered led device: b43-phy0::rx
Registered led device: b43-phy0::radio

“sudo iwlist scan” shows…
sudo: iwlist: command not found

I checked spelling on this one and tried it a few time… still gave me command not found

I use “shutdown” on windows.

Also, just for giggles, I checked the BIOS to see if anything there controls the network card (found this in another thread)… and found nothing.


I have HP dv6200 and the Broadcom 4311.
This is how I got wireless working.
This is my wireless experence. I am using openSuSE 11.0 and KDE 3.5. I have a HP dv6200 CTO laptop with a Broadcom “4311” built-in wireless card.
I first installed, if they were not installed, the following files: “ndiswrapper”,“ndiswrapper-kmp-default”, “ndiswrapper-kmp-pae” and “knetworkmanager-kde”.
Next I needed to extract the following files from the driver provided by HP on their website: “bcmwl5.inf” and “bcmwl5.sys”. Note: that is a small case “L” between the “w” and “5” in the file names and not the number one. I used Windows XP and WinRAR to extract the files. I transfered the 2 files to my /home/bob/ folder in openSuSE 11.0.
Next I opened a terminal with root privilages. Then typed “cd /home/bob/”.
Then typed “ndiswrapper -i bcmel5.inf”.
Then I typed “modprob ndiswrapper”.
To verify the file and hardware are recognized I typed: 'ndiswrapper -l".
Then I typed “ndiswrapper -m”.
Then I typed “EXIT” and closed the terminal program.
Now I opened YAST and clicked on the left: “Network Devices”.
Then on the right side I clicked on “Network Settings”.
At this point I found my mini-PCI card but never got it to work on an earlier attempt(s) so at the bottom I clicked on: “delete”.
Then I clicked “Add”.
In the “Device Type” I pressed the dropdown arrow and chose 'wireless".
On the right side under “Configuration Name” I typed in:“wlan0” (that is wlan then a zero).
A little lower undeer 'Module Name" I typed in “ndiswrapper”.
Then I clicked “next” and then “finish”.
Now I rebooted and my wireless light came on. (Hurrray)
On the far right side of the panell there should now be an icon for :KnetworkManager".
I right clicked on the icon and selected “edit connections”.
All I had to do was type in the name of my wireless router connection which was Linksys so I typed in “linksys” and pressed “save”.
I then right clicked on the icon and my internet connection was listed just below “wlan0” and it also showed the signal strength.
So I clicked on the connection name and then opened up Firefox 3.0 and now I’m enjoying my wireless and it works great. If you choose to follow what I have done to get my wireless working make sure you substitute your correct driver files.

cbelinsky wrote:
> Hi Larry,
> Thanks for the response!
> Good to know the card should work… which probably means I am running
> circles around the obvious. Oh well, I guess that is the fun of
> computers.
> Anyways, per your suggestions:
> “dmesg | grep b43” command shows…
> b43-phy0: Broadcom 4311 WLAN found
> input: b43-phy0 as /devices/virtual/input/input10
> b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
> Registered led device: b43-phy0::tx
> Registered led device: b43-phy0::rx
> Registered led device: b43-phy0::radio
> “sudo iwlist scan” shows…
> sudo: iwlist: command not found

The command is /usr/sbin/iwlist. Sorry I didn’t give you the complete path.

The dmesg output looks clean. Nothing there shows any problems.


Alright, “sudo /usr/sbin/iwlist scan” gives:

lo Interface doesn’t support scanning.
eth0 Interface doesn’t support scanning.
wmaster0 Interface doesn’t support scanning.
wlan0 Scan completed :
Cell 01 - Address: 00:1C:F0:68:BC:E0
ESSID:“marys network”
Frequency:2.462 GHz (Channel 11)
Quality:81/100 Signal Level=-48 dBm Noise Level=-64 dBm
Encryption key: off
Bit Rates: 1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s; 12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s; 48 Mb/s; 54 Mb/s;

Even to my novice eyes this looks good which does not help me. The ndiswrapper approach looks a little more intimidating- but it would be worth a try it I cannot get this to work. Although I am wondering now if there is a hardware issue (but it does work in Vista)

Those numbers should be OK. On my BCM4312, which is similar to the 4311, I can
easily connect and authenticate with the following signal:

Cell 02 - Address: 00:1A:70:46:BA:B1
Frequency:2.412 GHz (Channel 1)
Quality=80/100 Signal level:-49 dBm Noise level=-70 dBm
Encryption key:on
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra: Last beacon: 576ms ago

How did you configure this interface? Are you using NetworkManager or the
traditional ifup? Because the network is unencrypted, that makes it easier. When
it fails, look at the tail end of the dmesg output and post the parts that
concern wlan0: associate, etc.

I doubt that ndiswrapper would make much difference with this problem, and you
would run the risk of having the Windows driver crash your computer.


I have bcm4312 and the couple of weeks before I’d the same problem with KNetworkManager as well. (Can see networks but cannot connect). However, I have no problem connecting to those wireless networks under Windows and I suspect it’s the problem with Knetwork manager. Therefore today I remove “networkmanager-kde” package in Yast and installed “networkmanager-gnome” instead and I’m connecting without problem again!

You need to start NetworkManager-gnome manually after the installation. Just type

*nm-applet & *

in the terminal.

Alternatively you can make a symbolic link to /home/{your username}/.kde4/Autostart directory.

Hope it helps.

Alright, still no luck with anything…

I use the network manager. I tried the ifup and got nowhere with that. I have also tried both Gnome and Kde with the exact same results.

The dmesg output is always the same whenever I type it- same with the iwlist scan.

There is a second wireless signal around here which I have tried to use with the same results.

Just to summarize my problem… the wireless works just fine in Vista but in opensuse I can see it but can rarely connect to it. Even when I do connect it is really slow and only last for a few webpages. If I connect and walk away from my computer for a while, the connection will last until I view a few pages (I have no idea if that means anything but I spinning wheels here).

wahoospa… did you have similar problems to me and that’s why you went with the ndiswrapper?

Anyways, I appreciate all the assistance so far- looks like I could still use some more.


Cbelinsky, we have virtually the same machines. Mine is a dv6200 CTO.
What I may have omitted in my post was to do this in terminal: “ndiswrapper -e ‘driver name’” to uninstall an older driver and start clean.
I have never used anything but ndiswrapper as it is not confusing to me and has worked for me since SuSE 9.0 without problems. My machine is a dual boot, SuSE 11.0/XP Pro. I have not lost any connections and it does connect to my router every time in about 9-10 seconds.

I tried the ndiswrapper and had no luck- could not ever get the wireless to turn on.

I went through all the steps in Wahoopsa’s post and here is a summary- maybe somebody can find something to fix here…

“ndiswrapper -l” displays:
bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: ssb)

On “Saving Network Configuration” in YaST
warnings says:
cannot install installation check whether server is accessible
Index of /update/11.0
Obviously it is trying to go online and cannot because the wireless is not working

YaST Network Settings overview tab- Wireless Network Card
Wireless Network Card (Not connected)
MAC : 00:1a:73:19:c6:0d
• Device Name: wlan0
• Started automatically at boot
• IP address assigned using DHCP

“sudo /usr/sbin/iwlist scan” displays:
wlan0 Interface doesn’t support scanning : Network is down

Everytime I restart SUSE and go into YaST it gives me the message that
ndiswrapper was detected but not modprobed- do I want to modprobe it now?

I did modprobe it to begin with but I say OK and it does the same thing next time I restart

Well, I am near the give up point on this but I do appreciate all the help.


First of all, forget ndiswrapper. When you use it, you are exposing your kernel
to Windows driver code with very few checks. Think the Linux equivalent of “Blue
Screens of Death”. In addition, your setup could break everytime the kernel is
updated. On the BCM4311, the native driver b43 works very well, and is updated
along with the kernel.

Do you have Internet access when running Linux using a wired connection? If so,
open a terminal and enter the following command:

sudo /usr/sbin/install_bcm43xx_firmware

This fixes most systems. The main problems have been due to typos. Please
copy-and-paste if you can. If you do not have access while in Linux, the
“Additional Wireless Bits” sticky at the start of this forum has a workaround.

If you have blacklisted anything like b43 or ssb, you should undo that now.

After you reboot, you should use YaST to configure the wireless. If you use
NetworkManager to control it, you will also have to use the “Edit Connections”
button on the KNM applet and add a connection for your AP. That is where you
enter the ESSID and encryption secrets. With the traditional “ifup”, that
configuration is done with YaST.


you beat me to it. I just got wireless going on HP laptop using same command as previous poster. Works very well. Unlike other distros that i tried that do require you to use ndiswrapper.

You are very close. The first part is correct. The second part: “Saving Network Configuration” is telling you that you must connect your laptop to your modem thru the ethernet connection on the side of your machine. SuSE needs to download from their repositories some files associated with the installation. You may need to setup the SuSE repositories in YAST if you get more errors. If you have the repositories set up the rest should be a snap to get it going.

Woohoo- it finally works!

And to think all along my main problem was I did not have a wired connection. So I had to go to a friend’s who did and, voila, a working wireless using ndiswrapper. The wireless does take about 30 seconds to connect but that’s livable.

Larry, I do see see your point about using the actual Linux driver. In the end I would like to get that working- for now I am just happy to have something.

Anyways, I owe both you and wahoospa a beer for your help! Assuming you are both old enough- if not a big thick milkshake.

Believe me, I’m old enough.

Now that you have a working connection, you should open a terminal and enter the

sudo /usr/sbin/install_bcm43xx_firmware

command. That will install the firmware. If you really want to be prepared, you
should tar the /lib/firmware directory and save that on a thumb drive for when
you do your next upgrade, or if you want to try another distro.

I really do (still) recommend the open-source (b43) driver.