Wireless not working after new Leap 15.1 install

I found that my wireless would not start on boot or after a hibernate/resume on an ACER V5-571 laptop and rfkill shows a soft block on it. I then found on google a reference to blacklisting acer_wmi which I did and now it starts the wireless on boot and after resume just fine. One issue though is that I cannot alter screen brightness using the Fn+Right Arrow key although Fn+ Up arrow does alter sound level.

So why do I need this blacklist? Why can I not alter the screen brightness now having the blacklist?

Stuart

Hi
I would un-blacklist and then figure out the soft-block issue, soft-block usually means a Fn Key press(presses) combination required…

If you unblock with the rfkill command, do things start working as expected?


rfkill list
rfkill unblock <number of wireless card>

I did the rfkill unblock with the number but it did not remove the soft block. How do I find out what is doing the blocking?

Stuart

Post:

rfkill list all
/sbin/lspci -nnk | grep -iA3 net

So two outputs are:-


rfkill list all
0: acer-wireless: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
2: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

and


lspci -nnk | grep -iA3 net
03:00.2 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0a)
        Subsystem: Acer Incorporated [ALI] Device [1025:0724]
        Kernel driver in use: r8169
        Kernel modules: r8169
04:00.0 Network controller [0280]: Qualcomm Atheros AR9462 Wireless Network Adapter [168c:0034] (rev 01)
        Subsystem: Foxconn International, Inc. Device [105b:e052]
        Kernel driver in use: ath9k
        Kernel modules: ath9k


now when I boot the wireless does not start and when I open the NM widget from systray the tick is not there against the wireless symbol and as soon as I check it wireless starts and connects. This always comes up like this on a boot up or resume. Before I check the wireless I tried Fn+F3 which is the h/w wireless switch on the laptop but to no avail.

Even without the blocklist the Fn+Right arrow still does not work to change screen brightness.

Stuart

Hi
What about just the F3 key?

If you run the command;


rfkill unblock 0
rfkill list all

Does this change?

Can you try adding the following to your grub kernel boot options;


acpi_osi=\"!Windows 2012\"

When I first had the problem I did an rfkill unblock all and unblock 0 but nothing changed the soft block. I very much doubt the F3 alone will do anything but will try later. I’ll also try the acpi stuff suggested later.

Stuart

To confirm the acpi_osi option does nothing to fix it. F3 or Fn+F3 does NOT remove the soft block neither does rfkill unblock 0 or unblock all. If I check the wireless option in the Network Manager widget then wireless turns on and works. This is all tested without the block for acer_wmi. The only way so far to get wireless to start on boot or resume without manual intervention is a block on acer_wmi!

I don’t remember any of this failing on Leap 15.

Stuart

PS. Just did a modprobe -r acer_wmi and now an rfkill only shows the phy0 Wireless lan and hci0 bluetooth, the acre-wireless does not show up at all.

Hi
Your going to have to create a bug report against the kernel, also add to the bug the output from the command;


dmidecode

openSUSE:Submitting bug reports - openSUSE

Also, post back the bug report number :wink:

Bug 1136874 opened in bugzilla today.

Stuart