wireless not functioning in OpenSuse 11.1

Folks :
Abstract: My wireless connection fails to start in 11.1

I am new to Linux, so excuse my verbose posting.

I have a HP Pavilion ZD7000 laptop, dual booting XP and
OpenSuse 11.1. This is a 32-bit machine with 2GB memory.

My wireless card is a PCMCIA D-Link DWL-G650. Previously I had
Suse 10.0 installed here which worked perfectly with this card.
The XP also works fine with this card, but when I installed
OpenSuse 11.1, it wasn’t working.

After reading several posts, I decided to follow the
steps described in :
Atheros madwifi - openSUSE
Here, I used one of the methods advocated there, namely,
“Compiling it yourself using the resources”,
which basically says :
download drivers from MadWiFi, unpack, make, make install
and modprobe ath_pci.

After this, the card seemed to work, I was able to hop on to the
internet. But, after a reboot, the card was not working again.

After several experiments, this is what I do now :
start YaST -> NetworkDevices -> NetworkSettings and step
through the ‘edit’ pages of the wireless card. I don’t edit
anything but just press the ‘Next’ button and finally
the ‘OK’ button. YaST goes through its motions and when it is
done, I have the Internet connection again.

So, my question is : Is there anything that I can set in any
config file so that I don’t have to go through this
routine every time I boot.

I would appreciate any guidance on this. Thanks

When configuring, did you set the device to activate at boot time ?


It was set as ‘On Cable Connection’; changed to ‘At Boot Time’
as suggested by you, but it made no difference; I still have to
go through the network card ‘Edit’ operations to activate it.
Any other suggestions ?

You could add ath_pci or whichever you use to modules_loaded_on_boot


I did that (confirmed by lsmod) but didn’t seem to help.
Will keep experimenting.

I had something similar once, just had to load the network settings screen though. Didn’t need to press Ok, just had to load it and then I could do whatever, even abort or just close it.

Asked the same thing back then, went unanswered… hope it goes better for you, for now you could try limiting your action to just loading the screen. Saves a few clicks at least.

The PC I am writing this on runs opensuse 10.3 and uses a Netgear wireless PCI card that has an Atheros chipset, so I use madwifi to make it work. My card never works on booting the system, but running this command as root sorts it out:

/etc/init.d/network restart

Thanks for giving me another way to get my wireless card start working again. I tried what you suggested and it works great.

I have the DWL-650+ and open suse 11.1 (gnome)

And according to the network configuration I need the firmware loaded.

I’m a complete novice when it comes to Linux so any help would be appreciated.

Go to the wireless subforum and read the stickies. That will tell you
how to determine what kind of hardware, and how to diagnose the problem.

I think your device is a BCM43XX, and that you need to install the