Wireless not found

I have a Toshiba C75D-B Satellite with Windows 10 and Open Suse 13.2 installed, wireless system works normal on Windows, but OpenSuse 13.2 does not recognize wireless system. I have a Broadcom 802.11n Network Adapter shown when I run “IPCONFIG -ALL” in windows…shows physical address as :64-5A-04-5A-22-F9". I have read almost all the posts here but have had no luck getting it up and running…I downloaded broadcom-wl-kmp-default-6.30.223.248_k3.16.7_24-5.3.x86_64.rpm and broadcom-wl-kmp-desktop-6.30.223.248_k3.16.7_24-5.3.x86_64.rpm and put them on a thumb drive and tried to install them on the new machine but got errors saying nothing provided for installing???

I am at a loss what to do, as I don’t have any internet access from the machine, have to download files on another machine…any help appreciated:’(…

Start by providing the following information

/usr/sbin/hwinfo --wlan

deano_ferrari: I am not sure if you wanted the entire readout from file or not, so am just including stuff on the “Broadcom” card, if you wanted it all let me know and I will redo…

This is what I found when I ran a search for the card:

============ start debug info ============
libhd version 21.6 (x86-64) [7688]
using /var/lib/hardware
kernel version is 3.16
----- /proc/cmdline -----
BOOT_IMAGE=/boot/vmlinuz-3.16.6-2-desktop root=UUID=7132fa42-3bd5-484f-8d37-80ca79f2e7ec ro resume=/dev/sda7 splash=silent quiet showopts
----- /proc/cmdline end -----
debug = 0xff7ffff7
probe = 0x15938fcdaa17fcf9fffe (+memory +pci +isapnp +net +floppy +misc +misc.serial +misc.par +misc.floppy +serial +cpu +bios +monitor +mouse +scsi +usb -usb.mods +modem +modem.usb +parallel +parallel.lp +parallel.zip -isa -isa.isdn +isdn +kbd +prom +sbus +int +braille +braille.alva +braille.fhp +braille.ht -ignx11 +sys -bios.vbe -isapnp.old -isapnp.new -isapnp.mod +braille.baum -manual +fb +pppoe -scan +pcmcia +fork -parallel.imm +s390 +cpuemu -sysfs -s390disks +udev +block +block.cdrom +block.part +edd +edd.mod -bios.ddc -bios.fb -bios.mode +input +block.mods +bios.vesa -cpuemu.debug -scsi.noserial +wlan -bios.crc -hal +bios.vram +bios.acpi -bios.ddc.ports=0 +modules.pata -net.eeprom +x86emu=dump -max -lxrc)
shm: attached segment 3080213 at 0x7f87af42e000
>> hal.1: read hal data
>> floppy.1: get nvram
----- /proc/nvram -----
Checksum status: valid

floppies : 0

Floppy 0 type : none
Floppy 1 type : none
HD 0 type : none
HD 1 type : none
HD type 48 data: 0/0/0 C/H/S, precomp 0, lz 0
HD type 49 data: 7/20/75 C/H/S, precomp 587, lz 262
DOS base memory: 640 kB
Extended memory: 64512 kB (configured), 64512 kB (tested)
Gfx adapter : EGA, VGA, … (with BIOS)
FPU : installed
----- /proc/nvram end -----

P: /devices/pci0000:00/0000:00:02.3/0000:05:00.0
E: DEVPATH=/devices/pci0000:00/0000:00:02.3/0000:05:00.0
E: DRIVER=bcma-pci-bridge
E: ID_MODEL_FROM_DATABASE=BCM43142 802.11b/g/n
E: ID_PCI_CLASS_FROM_DATABASE=Network controller
E: ID_PCI_SUBCLASS_FROM_DATABASE=Network controller
E: ID_VENDOR_FROM_DATABASE=Broadcom Corporation
E: MODALIAS=pci:v000014E4d00004365sv00001B9Asd00003002bc02sc80i00
E: PCI_CLASS=28000
E: PCI_ID=14E4:4365
E: PCI_SLOT_NAME=0000:05:00.0
E: PCI_SUBSYS_ID=1B9A:3002
E: SUBSYSTEM=pci
E: USEC_INITIALIZED=48538
36: PCI 500.0: 0280 Network controller
[Created at pci.328]
Unique ID: Ddhb._9+MmJOLVv0
Parent ID: aYFK.K19TcKID4lF
SysFS ID: /devices/pci0000:00/0000:00:02.3/0000:05:00.0
SysFS BusID: 0000:05:00.0
Hardware Class: network
Model: “Broadcom BCM43142 802.11b/g/n”
Vendor: pci 0x14e4 “Broadcom”
Device: pci 0x4365 “BCM43142 802.11b/g/n”
SubVendor: pci 0x1b9a “XAVi Technologies Corp.”
SubDevice: pci 0x3002
Revision: 0x01
Driver: “bcma-pci-bridge”
Driver Modules: “bcma”
Memory Range: 0xf2b00000-0xf2b07fff (rw,non-prefetchable)
IRQ: 32 (no events)
Module Alias: “pci:v000014E4d00004365sv00001B9Asd00003002bc02sc80i00”
Driver Info #0:
Driver Status: bcma is active
Driver Activation Cmd: “modprobe bcma”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #19 (PCI bridge)

I also ran “ifconfig -a” and got the following: nitewalker@linux-70n0:~> sudo ifconfig -a
root’s password:

enp1s0 Link encap:Ethernet HWaddr 00:8C:FA:81:F2:9D
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:252 errors:0 dropped:0 overruns:0 frame:0
TX packets:252 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:19564 (19.1 Kb) TX bytes:19564 (19.1 Kb)

I also ran “iwconfig” and got following: nitewalker@linux-70n0:~> sudo iwconfig
root’s password:

lo no wireless extensions.

enp1s0 no wireless extensions.

nitewalker@linux-70n0:~>

Thanks again for any help you might share to get me up and runing…JSM

The hwinfo output shows that the bcma driver is loaded, but no wireless network interface is reported by ifconfig. It may be that no broadcom firmware loaded yet.

Refer to the information in this guide about installing it

http://opensuse-guide.org/wlan.php

It can be done offline if necessary. There are threads discussing that if one searches.

Even though the bcma driver is supposed to support this chipset, I don’t have direct experience with using it…

modinfo bcma
filename:       /lib/modules/3.11.10-29-desktop/kernel/drivers/bcma/bcma.ko
license:        GPL
description:    Broadcom's specific AMBA driver
srcversion:     67ADEA6E309FDB9FC19CBCF
alias:          pci:v000014E4d00004727sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004365sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004359sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004358sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004357sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004353sv*sd*bc*sc*i*
alias:          pci:v000014E4d00004331sv*sd*bc*sc*i*
alias:          pci:v000014E4d0000A8D8sv*sd*bc*sc*i*
alias:          pci:v000014E4d00000576sv*sd*bc*sc*i*
depends:        
intree:         Y
vermagic:       3.11.10-29-desktop SMP preempt mod_unload modversions 

If you do want to pursue using the wl driver, then the following thread may be helpful

https://forums.opensuse.org/showthread.php/502973-Problem-with-Lenovo-g505-Broadcom-BCM43142

The problem is that those packages are built for and require Kernel 3.16.7-24, while you only have 3.16.6.
You’d need to update the kernel first.

You might try to tell zypper to ignore the conflict, the kernels should be compatible, but I cannot guarantee you that it works.

And you don’t need both broadcom-wl-kmp-default and broadcom-wl-kmp-desktop, you only need one matching your Kernel. If you have kernel-desktop installed (the default) you need broadcom-wl-kmp-desktop, for kernel-default you need broadcom-wl-kmp-default.
In any case you additionally need the package broadcom-wl, otherwise the driver will not work at all.

PS: According to https://wireless.wiki.kernel.org/en/users/drivers/b43 that device is only supported by broadcom-wl, not the open source drivers.