Wireless not avail on boot

Okay, I’ve followed all the tutorials and forum posts to get Atheros cards working, which I did manage to do all by myself… and I got myself a cookie for it. Then when my computer reboots I lose wireless connectivity. If I load Yast2 via the GUI or the command line, and open the network manager, it works fine after that. Is there something I’m missing? Maybe a script I need to run at startup? It’s pulling a static IP address. I could post some info if you guys need it, but I’m at work right now and not on my machine.

Any help would be appreciated.

You should be using networkmanager in preference to ifup
Then configure networkmanager in the tray, There is an option to connect auto.

This happens to me unless I run the hated kwallet. But, then again, I’m running the NM plasmoid. So, my experience may not apply.