Wireless/Netopia USB adapter doesnt work : OpenSuse 11.2

Hi,
I have a Netopia Wireless USB adapter which used to work perfectly with OpenSuse 11.1. I have recently upgraded to 11.2 and the wireless refuses to work. I can see that the wireless adapter connects to my router (green light is on), but for some reason the dhcp doesn’t seem to assign the IP address. I keep getting “network unreachable” when I try to ping to the router gateway. I do get the IP address assigned and the internet works fine when I connect to the router with a cable.
I would greatly appreciate any help to resolve this problem.
Thanks,
RupaKolli

On 12/25/2009 01:36 PM, rupakolli wrote:
>
> Hi,
> I have a Netopia Wireless USB adapter which used to work perfectly with
> OpenSuse 11.1. I have recently upgraded to 11.2 and the wireless
> refuses to work. I can see that the wireless adapter connects to my
> router (green light is on), but for some reason the dhcp doesn’t seem to
> assign the IP address. I keep getting “network unreachable” when I try
> to ping to the router gateway. I do get the IP address assigned and the
> internet works fine when I connect to the router with a cable.
> I would greatly appreciate any help to resolve this problem.

First of all, you should use the command

sudo zypper up

to update the system. Once you have done this, deleting the wireless connection
and entering it as a new one usually fixes the problem.

If you got an IP, then you have connected. You probably have the “route”
problem. You can check that by entering the command ‘/sbin/route -n’. If you
have an entry for your wireless with the UG flags set, then you do not have this
problem. If you do not, then enter the command

sudo /sbin/route add default gw XXX.XXX.XXX.XXX

where the X’s are replaced with the IP of you router.

If you had the UG flags set correctly, then you have a name server problem. This
is usually fixed by deleting the file /etc/resolv.conf and remaking the connection.

I tried this approach, but the problem remains the same. The key issue here is that I don’t get the IP address from my router. I am not sure why the DHCP4 client remains perpetually waiting for data.

Here is the dialog with my system:

kolli-linux:~ # sudo zypper up
Loading repository data…
Reading installed packages…

Nothing to do.
kolli-linux:~ # ifstatus wlan1
wlan1 name: 802.11g WiFi
DHCP4 client (dhcpcd) is running
. . . but is still waiting for data
DHCP6 client (dhcp6c) is running
. . . but is still waiting for data
wlan1 is up
5: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
link/ether 00:d0:41:a6:b7:08 brd ff:ff:ff:ff:ff:ff
inet6 fe80::2d0:41ff:fea6:b708/64 scope link
valid_lft forever preferred_lft forever

Active IPv6 routes for interface wlan1:
fe80::/64 proto kernel metric 256 mtu 1500 advmss 1440 hoplimit 4294967295
bssid=00:0f:cc:b7:dc:b4
ssid=260687
id=0
pairwise_cipher=CCMP
group_cipher=TKIP
key_mgmt=WPA2-PSK
wpa_state=COMPLETED
kolli-linux:~ # /sbin/route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
kolli-linux:~ #

On 12/26/2009 02:26 PM, rupakolli wrote:
>
> I tried this approach, but the problem remains the same. The key issue
> here is that I don’t get the IP address from my router. I am not sure
> why the DHCP4 client remains perpetually waiting for data.
>
> Here is the dialog with my system:
>
> kolli-linux:~ # sudo zypper up
> Loading repository data…
> Reading installed packages…
>
> Nothing to do.
> kolli-linux:~ # ifstatus wlan1
> wlan1 name: 802.11g WiFi
> DHCP4 client (dhcpcd) is running
> . . . but is still waiting for data
> DHCP6 client (dhcp6c) is running
> . . . but is still waiting for data
> wlan1 is up
> 5: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast
> state UP qlen 1000
> link/ether 00:d0:41:a6:b7:08 brd ff:ff:ff:ff:ff:ff
> inet6 fe80::2d0:41ff:fea6:b708/64 scope link
> valid_lft forever preferred_lft forever
>
> Active IPv6 routes for interface wlan1:
> fe80::/64 proto kernel metric 256 mtu 1500 advmss 1440 hoplimit
> 4294967295
> bssid=00:0f:cc:b7:dc:b4
> ssid=260687
> id=0
> pairwise_cipher=CCMP
> group_cipher=TKIP
> key_mgmt=WPA2-PSK
> wpa_state=COMPLETED
> kolli-linux:~ # /sbin/route -n
> Kernel IP routing table
> Destination Gateway Genmask Flags Metric Ref Use
> Iface
> 127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0
> lo
> kolli-linux:~ #

You certainly have no routing, but you would not until you got an IP. I’m not
convinced that you have made a connection. Please post the output of

sudo /usr/sbin/iwlist scan
/usr/sbin/iwconfig

Thanks a lot for the quick response.
Here are the details you asked for:

kolli-linux:~ # iwlist scan
lo Interface doesn’t support scanning.

eth1 Interface doesn’t support scanning.

wmaster0 Interface doesn’t support scanning.

wlan1 Scan completed :
Cell 01 - Address: 00:1A:70:95:E3:62
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=29/70 Signal level=-81 dBm
Encryption key:on
ESSID:“eer5Oige”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=000000099a6b8561
Extra: Last beacon: 1188ms ago
IE: Unknown: 0008656572354F696765
IE: Unknown: 010482848B96
IE: Unknown: 030101
IE: Unknown: 2A0106
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: 32088C129824B048606C
Cell 02 - Address: 00:24:37:1A:CC:10
Channel:4
Frequency:2.427 GHz (Channel 4)
Quality=45/70 Signal level=-65 dBm
Encryption key:on
ESSID:“lnj-16450”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=0000004f82335b2c
Extra: Last beacon: 996ms ago
IE: Unknown: 00096C6E6A2D3136343530
IE: Unknown: 010582848B962C
IE: Unknown: 030104
IE: Unknown: 2A0104
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: 32080C1218243048606C
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Cell 03 - Address: 00:02:CF:EA:CF:74
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=31/70 Signal level=-79 dBm
Encryption key:on
ESSID:“DFierro”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
18 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=00000286828345f2
Extra: Last beacon: 868ms ago
IE: Unknown: 00074446696572726F
IE: Unknown: 010882848B961224486C
IE: Unknown: 030106
IE: Unknown: 2A0104
IE: Unknown: 32040C183060
IE: Unknown: 2D1A6E1017FFFF0000010000000000000000000000000C0000000000
IE: Unknown: 3D1606070000000000000000000000000000000000000000
IE: Unknown: 3E0100
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
IE: Unknown: 7F0101
IE: Unknown: DD07000C4304000000
IE: Unknown: 0706434820010E10
IE: Unknown: DD1E00904C336E1017FFFF0000010000000000000000000000000C0000000000
IE: Unknown: DD1A00904C3406070000000000000000000000000000000000000000
Cell 04 - Address: 00:00:C5:B2:1A:39
Channel:7
Frequency:2.442 GHz (Channel 7)
Quality=57/70 Signal level=-53 dBm
Encryption key:on
ESSID:“Doglia”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
Mode:Master
Extra:tsf=00000197367a8f11
Extra: Last beacon: 804ms ago
IE: Unknown: 0006446F676C6961
IE: Unknown: 010482848B96
IE: Unknown: 030107
Cell 05 - Address: 00:0F:CC:DA:EC:00
Channel:7
Frequency:2.442 GHz (Channel 7)
Quality=61/70 Signal level=-49 dBm
Encryption key:on
ESSID:“fanfan”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=000001aec2fd13e1
Extra: Last beacon: 804ms ago
IE: Unknown: 000666616E66616E
IE: Unknown: 010582848B962C
IE: Unknown: 030107
IE: Unknown: 2A0107
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: 32080C1218243048606C
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Cell 06 - Address: 00:0F:CC:B7:DC:B4
Channel:11
Frequency:2.462 GHz (Channel 11)
Quality=66/70 Signal level=-44 dBm
Encryption key:on
ESSID:“260687”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=00000001b347419f
Extra: Last beacon: 540ms ago
IE: Unknown: 0006323630363837
IE: Unknown: 010582848B962C
IE: Unknown: 03010B
IE: Unknown: 2A0104
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: 32080C1218243048606C
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Cell 07 - Address: 00:21:1E:6D:F6:50
Channel:13
Frequency:2.472 GHz (Channel 13)
Quality=36/70 Signal level=-74 dBm
Encryption key:on
ESSID:“MATTERHORN”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=000000011d2e592f
Extra: Last beacon: 276ms ago
IE: Unknown: 000A4D4154544552484F524E
IE: Unknown: 010582848B962C
IE: Unknown: 03010D
IE: Unknown: 2A0104
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
IE: Unknown: 32080C1218243048606C
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK

eth0 Interface doesn’t support scanning.

kolli-linux:~ # iwconfig
lo no wireless extensions.

eth1 no wireless extensions.

wmaster0 no wireless extensions.

wlan1 IEEE 802.11bg ESSID:“260687”
Mode:Managed Frequency:2.462 GHz Access Point: 00:0F:CC:B7:DC:B4
Bit Rate=54 Mb/s Tx-Power=19 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:XXXXX-STRIPPED-XXXXX [3]
Power Management:on
Link Quality=63/70 Signal level=-47 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

kolli-linux:~ # ifconfig
eth1 Link encap:Ethernet HWaddr 00:13:D4:E1:C8:46
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:18 errors:0 dropped:0 overruns:0 frame:0
TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1060 (1.0 Kb) TX bytes:1060 (1.0 Kb)

wlan1 Link encap:Ethernet HWaddr 00:D0:41:A6:B7:08
inet6 addr: fe80::2d0:41ff:fea6:b708/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:548 errors:0 dropped:0 overruns:0 frame:0
TX packets:287 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:42075 (41.0 Kb) TX bytes:98414 (96.1 Kb)

wmaster0 Link encap:UNSPEC HWaddr 00-D0-41-A6-B7-08-00-00-00-00-00-00-00-00-00-00
UP RUNNING MTU:0 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

kolli-linux:~ #

On 12/26/2009 03:06 PM, rupakolli wrote:

> kolli-linux:~ # iwconfig
> lo no wireless extensions.
>
> eth1 no wireless extensions.
>
> wmaster0 no wireless extensions.
>
> wlan1 IEEE 802.11bg ESSID:“260687”
> Mode:Managed Frequency:2.462 GHz Access Point:
> 00:0F:CC:B7:DC:B4
> Bit Rate=54 Mb/s Tx-Power=19 dBm
> Retry long limit:7 RTS thr:off Fragment thr:off
> Encryption key:XXXXX-STRIPPED-XXXXX [3]
> Power Management:on
> Link Quality=63/70 Signal level=-47 dBm
> Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
> Tx excessive retries:0 Invalid misc:0 Missed beacon:0
>
> eth0 no wireless extensions.

The iwconfig output indicates that your wireless has authenticated and
associated with your access point. Thus the problem has to be with dhclient or
dhcpcd. Which is your system trying to use? The command ‘ps ax’ will list all
processes, one of which will be listed above.

Whichever is being used, try to use the other manually for testing. The man
command will help you set up a configuration file.

Your neighbors have set up some strange channel usage. Wifi is NOT like
television. The band width of each channel is 20 MHz, but the channels are 5 MHz
apart. To get channels that do not interfere with each other, stations should
use channels 1, 6, and 11. Your choice of 11 is pretty good - only the AP on
channel 13 will interfere.; however,m you would get slightly less interference
on channel 1. The interference would be from the weakest station in your list.
Note that the radios on channels 4, 6, and 7 all interfere with each other.

My system is using dhcpcd by default. I changed it to dhclient by giving the value “dhclient” to DHCLIENT_BIN in /etc/sysconfig Editor under YaST. It changes over to dhclient fine, but the net result is the same. My network is still unreachable, and ifstatus wlan1 produces the line “DHCP4 client (dhclient) is running … but is still waiting for data”.

I also changed over to Channel 1 as suggested by you, but the result is still the same. Even if my neighbours’ channels are possibly interfering, note that I am able to work fine with Windows XP.

In my Network Settings, I did not enable IPv6. Still, why does my ifstatus indicates that DHCP6 client (dhcp6c) is running ? Could this be a source of problem ? In the previous 11.1 avtaar of my system, enabling IPv6 used to give me problems, but unchecking the IPv6 option fixed them.

Apparently this thread reached an impasse. While the inability of my netopia wireless usb adapter to get the IP address in OpenSUSE 11.2 (while it worked fine in 11.1 and still works fine in winxp) still intrigues me, I decided not to waste any more time on it. I got myself a D-Link DWL-G122 (version C1) usb adapter and it connected me to the world in a jiffy.

Thanks anyway for the feedback.

I have a Huawei E169 HSDPA USB Stick that have the same problem as you have with “network unreachable” even when the 3G modem and the KNetworkmanager indicates that connection is up. This modem worked under 11.1 so something must have happened in 11.2. I will try to find a solution or contact OpenSuse for help

Regards Villemarsvin