Wireless LED always on

Hi,

i have a Sony Vaio SVS1511V9EB laptop with an Intel(R) Centrino(R) Advanced-N 6235 AGN wireless card. The card is working fine, but the wireless LED is always on. No matter if i disable the card or not.
I disabled the card via the NetworkManager widget of KDE and via “rfkill block all”, but the LED was always on. I dont have a hardware Wifi switch in my laptop.
I tried to use the iwlwifi parameter led_mode=1, but it didnt help. Setting led_mode=2 also didnt make the LED blink, it was just constantly on. Why is the parameter not doing anything?
How can i turn off that LED when i turn off wifi? Or is it maybe that rfkill and the NetworkManager switch dont turn of the wifi completely?
Im using Kernel 3.9.3-10.g06ad9d8-desktop from Tumbleweed on openSuse 12.2 x64.

Heres some dmesg output from the driver:

# dmesg | grep iwl    3.955915] iwlwifi 0000:02:00.0: irq 46 for MSI/MSI-X
    3.965170] iwlwifi 0000:02:00.0: loaded firmware version 18.168.6.1
    3.972206] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUG enabled
    3.972211] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
    3.972213] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
    3.972216] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_DEVICE_TESTMODE disabled
    3.972218] iwlwifi 0000:02:00.0: CONFIG_IWLWIFI_P2P disabled
    3.972221] iwlwifi 0000:02:00.0: Detected Intel(R) Centrino(R) Advanced-N 6235 AGN, REV=0xB0
    3.972302] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
    3.992851] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
    4.977782] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
    4.985059] iwlwifi 0000:02:00.0: Radio type=0x2-0x1-0x0
    5.359698] iwlwifi 0000:02:00.0: L1 Enabled; Disabling L0S
    5.366473] iwlwifi 0000:02:00.0: Radio type=0x2-0x1-0x0

Thanks for any hint.

oopepe

A little more info: Did you unload the module, and reload with the options from a terminal, or add the options to /etc/modprobe.d/50-iwlwifi.conf, or…? If you did it by editing a system file, did you reboot for it to take effect?

Other than that, I guess it could be a quirk of the hardware, and although not a serious issue, I guess you could file a bug report for it.

I edited /etc/modprobe.d/50-iwlwifi.conf and verified the parameter was set to the value i wanted after a reboot with

# cat /sys/module/iwlwifi/parameters/led_mode
1

.

Under windows… there is a Vaio tool with which i can disable wifi and then the LED goes off.

Thanks for the response.