Wireless Keyboard not recognized in First Boot Screen

Hi All,

I have a Microsoft Wireless keyboard / mouse which I use for my Windows world. I have tried booting the OpenSuSE 10.2, 11 DVDs, but none of them recognize the wireless keyboard that I have connected and I am unable to proceed with the installation because, the default selection in OpenSuSE’s first installation screen is Boot from HardDisk

I also tried using the Ubuntu Live CD that I had, the same problem of keyboard not recognized, but the lucky part was, the first screen in the live CD was a language selection and the default language was English and timed out and moved onto booting the Live CD. Once the booting was over, the wireless keyboard and mouse worked like a charm!

the obvious workaround is to use a wired keyboard and circumvent the problem!..but I wanted to know what is the ideal solution for this.

Any pointers, most welcome!

Check in your BIOS there is a setting there related to USB devices that must be set to enabled. I can’t recall the exact terminology now. But I assume there is a USB dongle for the keyboard?


Yes. There is a receiver for the wireless keyboard and mouse, which is connected via USB to the PC.

Thanks for the direction. I will check for the USB related setting in BIOS, but I remember, installing windows with the same wireless keyboard last week on this new PC. Thanks again for the direction.



I think it might go under Legacy Support or something like that. I’d know it if I saw it.

Take care friend:)


I will check today, when I get back home.


I’ve seen the keyboard, it does work on an installed openSUSE. IIRC the phenomenon only exists during install. That’s why I always carry one of them rubber USB keyboards with me. Use a wired keyboard during install, just to be able to make the right choice at boot.
After install, change the keyboards, boot, done.


That worked! Enabling USB Keyboard and USB Mouse items in the Integrated Peripherals section of the BIOS in my Gigabyte G-31 Motherboard has put the issue to rest!

Thanks a ton!

You are welcome friend;)