wireless issues atheros 5001 on hp laptop OpenSuse 11.2

Hi guys,

everything looks good but wirelss.

here’s the info from lspci:
ethernet controller atheros communications AR 5001 wireless network AD (rev 0)

from Yast hardware:

kerner driver: ath5k
device name wlan0

Please tell me what additional info you need. (sorry, just starting out here)

I do iwlist scan (message is scanning not supported)

I scanned from network manager (GUI) -> nothing

I did see the netowrks ones before.

NOTE: The light (wireless light button) stays on. CAN NOT turn it off (by pressing)

that’s all I have really. Again please tell me what other info you need.

This is dual boot with Vista, which obviously works fine with wireless.

Thanks again.

What has been your process to get your wireless to work? Have you checked here:

Getting Your Wireless to Work

I haven’t had to set up my wireless in a while since OpenSuse 11.0. After each upgrade I don’t recall having to do much, but when I did get my wireless going, I had to find out the name of my card, install firmware, and then set up some details in Yast-Network settings.

Also what version of OpenSuse are you running & Gnome or KDE

thanks for the reply.

I did install madwifi, but I’m not sure if I have configured it correctly.

I followed the instruction for atheros madwifi

SDB:Atheros madwifi - openSUSE

Sorry. It is KDE on 11.2

It does look like that atheros 5001 should work out of the box accrding to some info I found, but apparently I am not that lucky.

I believe I need to configure it somehow BEFORE I do the scan for networks. If id does recognize my driver and the card I would think I’m just missing some basic steps in configuring because it was scanning, but not connecting and the light was off. Not the light is on, but no networks.

again, thanks for your help

I know you said you completed this, but just to verify you have done:

Pre-installation

Discover what cards or wireless devices are supported. See this very informative page.
Known your openSUSE version (ie, 11.3). 

In example, if you installing openSUSE 11.3, your openSUSE version would be "11.3" not just "11". 

Known your kernel type. In openSUSE KERNEL_TYPE is one of the following: default, ec2, pae, ppc64, trace, vanilla, or xen. 

$ uname -r

After executing above command it will print out kernel version and kernel type, i.e: 2.6.27.29-0.1-default, 2.6.27.29-0.1 is kernel version and default is kernel type. 

Then:

Using YaST

Add MadWifi repositories.
    Open the YaST Control Center.
    Select Software Repositories.
    Click Add and select Specify URL....
    Enter one of the following into the URL field, depending on your version, 

Version: 11.3http://download.opensuse.org/repositories/driver:/wireless/openSUSE_11.3/
Version: 11.2http://download.opensuse.org/repositories/driver:/wireless/openSUSE_11.2/
Version: 11.1http://madwifi-project.org/suse/11.1

    Click OK, YaST will now download the package information.
    Click Finish, when it's done. 

Install MadWifi program and Kernel Module.
    Select Software Management in the YaST Control Center
    Search for madwifi, and you should see a list of packages appear.
    Install (or update, if necessary) madwifi and madwifi-kmp-<KERNEL_TYPE>. Pick one of the madwifi-kmp-* based on your kernel type.
    Click on Accept and wait for the packages to be downloaded and installed. 

Then:

Loading MadWifi kernel module

Open a terminal window, and execute this command, 

$ sudo /sbin/modprobe ath_pci

Check if your module is loaded, 

$ sudo /sbin/modprobe -l | grep ath

After kernel module is loaded your wireless card should have been detected. Click on the KNetworkManager icon or KInternet in the system tray and configure your wireless network. Assuming that you are running DHCP this should be all you have to do. Some versions of Suse will not have the icon in tray, so do a search “knetworkmanager” or “kinternet” and then open and run this utility and configure your wifi device.

Do not forget to disconnect or disable the wired connection that has been established before or you will have a conflict with DHCP and common network masks.

KInternet

Under Kinternet system tray, right click >> settings >> various, and roll the eth0 to ath0. 

When you are using WEP with kinternet (traditional ifup method), set or add the variable

WIRELESS_AP='off'

in the /etc/sysconfig/network/ifcfg-ath0 file. 

There may be a conflict with built in Atheros module ath5k, which seems is not functional yet, but prevents using madwifi’s driver. Resolution is to add this module, to the blacklist. To do this add the line blacklist ath5k to the file /etc/modprobe.d/blacklist and reboot.
For the ath_pci and ath_hal to work for the AR242x, you must have to reboot.

Also I’m not sure if you have seen openSuse 11.2 has a lifetime to run out in 46 days, which means you will be upgrading sooner than later. Lifetime - openSUSE

Is your network manager installed for KDE?

This may also help if you haven’t done this yet, written by Swendra at Madwifi or Ndiswrapper Wireless Network Drivers - Suse/openSUSE 10, 11.0

More specifically check out
Configure the Wireless Card Using Yast

This gives a tutorial about configuring your wireless card

Thank you for your help. I got it to work.

All I had to do is read carefully at the end of the instructions about blacklisting ath5k.
I did and the wireless is on!.

The light is not on anymore, but the connection is there.

Thanks again, I really appreciate it.

PS All I needed to do is to install madwifi and black list kernel driver. Now seems simple :slight_smile: