wireless is working only when-and-if ethernet is plugged

Strange behavior here, wireless is activated on boot (DHCP conf): in fact within the mode-router’s page I can see the assigned IP to the wireless connection and the MAC of the adapter.

But…

I cannot:

  • ping
  • ssh
  • find it via nmap scanning

All the other wifi devices are pingable and discoverable!

When the Ethernet cable in plugged in, then also the wireless connection become usable.

Totally unknown situation, dunno how to come up with this: can anyone please help me understand what’s happening and why? :sarcastic:

Ask any log you need and tell me how to gather infos.

Thanks to all gekkos there :wink:
http://i59.tinypic.com/1z39bo6.png

  1. openSUSE version?
  2. Network Manager or ifup method being used?

Running 13.1 and using ifup

Anyone here?! :open_mouth:

Any reason for not switching to NetworkManager? This makes it easier to manage wireless connections in particular.

Anyway, I don’t see the behaviour you describe with ifup here. My wireless works fine without an active Ethernet connection even if I switch to ifup.

I can imagine that something is wrong with your /etc/resolv.conf. When you connect Ethernet, it gets recreated according to the Ethernet settings and resolving works.
So can you ping hosts via the IP address when the wireless is not working?
E.g.:

ping 8.8.8.8

If that works, try to run this when wireless is not working:

sudo /sbin/netconfig update -f

That should fix it.

No, your solution doesn’t work. By the way my internet (and also LAN) connection works!

I can access only via ssh, no monitor/GUI here.

When the machine has ethernet cable unplugged, wireless isn’t working (but I can see it on the modem-router in its “connected devices page”): in this stage it’s weird because IP is auto-assigned via DHCP.

As soon as I plug in the cable, both connections come up: eth0 with DHCP (ok) and wlan0 with the static IP I set (ok); at this point eth0 and wlan0 work fine inside my LAN and also on the internet.

What I cannot understand is why wifi depends on ethernet cable connection >:( ****!
Also, I found myself lost with systemd’s networking, I’m new to that: dunno where look for logs and how to get proper infos.

The only thing I understood is to manually create a wlan0 profile:

cat /etc/sysconfig/network/ifcfg-wlan0
STARTMODE='auto'
BOOTPROTO='static'
IPADDR=192.168.178.234/24
NAME='wlan0'
WIRELESS='yes'
WIRELESS_MODE='managed'
WIRELESS_ESSID='abcdefghijklmnopqrstuvwxyz'
WIRELESS_AUTH_MODE='WPA-PSK'
WIRELESS_WPA_PSK='abcdefghijklmnopqrstuvwxyz'
WIRELESS_HIDDEN_SSID='no'
WIRELESS_AP_SCANMODE='1'
WIRELESS_POWER='yes'

So, did the ping work?

I can access only via ssh, no monitor/GUI here.

You can start GUI applications via ssh, and there’s a command line NetworkManager client as well, nmcli.
And a system connection can automatically connect during boot already, not much different than ifup.
But ok, I agree that it might be easier to use ifup in that case. Especially setting up the connection via NetworkManager might prove difficult as nmcli doesn’t support that AFAIK.

When the machine has ethernet cable unplugged, wireless isn’t working (but I can see it on the modem-router in its “connected devices page”): in this stage it’s weird because IP is auto-assigned via DHCP.

Which IP is auto-assigned via DHCP? The wireless one?
As you set a static one in the ifup config, you probably have NetworkManager running as well, which can of course cause all sorts of strange problems (the same interface is managed by two completely different systems at the same time).

What does “systemctl status NetworkManager” say?
If it’s “active (running)”, stop and disable it with:

sudo systemctl stop NetworkManager
sudo systemctl disable NetworkManager

As soon as I plug in the cable, both connections come up: eth0 with DHCP (ok) and wlan0 with the static IP I set (ok); at this point eth0 and wlan0 work fine inside my LAN and also on the internet.

So your wireless has a static IP?
That might point even more to a name resolution problem.
Have you set a DNS server? How does /etc/resolv.conf look like when only wireless is connected (and isn’t working)?

Wouldn’t it be easier to just use DHCP? That would also setup DNS automatically.

What I cannot understand is why wifi depends on ethernet cable connection >:( ****!

Well, as I tried to explain already, the ethernet connection might get the DNS config from your router and set it up accordingly, so it would work even for the wireless connection then.
As you didn’t tell whether the ping by IP address worked, I don’t know if that can be the case or not.

Also, I found myself lost with systemd’s networking, I’m new to that: dunno where look for logs and how to get proper infos.

There is no “systemd’s networking”. You either use ifup (up to 13.1 that is) or NetworkManager.
Both are just different interfaces to the same (kernel) functionality though.

The only thing I understood is to manually create a wlan0 profile:

You can also use YaST (even in text mode) to configure the connection.
As it seems to work when ethernet is connected, I doubt there’s anything wrong with that.

But I notice that I do not have a “WIRELESS=‘yes’” in my (working) config, and it’s spelt “WIRELESS_MODE=‘Managed’” (capital M) here. “WIRELESS_HIDDEN_SSID” is missing here as well. And it’s “WIRELESS_AUTH_MODE=‘psk’” (not ‘WPA-PSK’) here.
I have no idea whether those things could cause the behaviour you describe though.
But try to set “WIRELESS_POWER=‘no’”.

[QUOTE]No, your solution doesn’t work. By the way my internet (and also LAN) connection works!
So, did the ping work?[/QUOTE]Yes: it works on both eth0 and wlan0, but only if the ethernet cable is plugged.

[QUOTE]I can access only via ssh, no monitor/GUI here.
You can start GUI applications via ssh, and there’s a command line NetworkManager client as well, nmcli.
And a system connection can automatically connect during boot already, not much different than ifup.
But ok, I agree that it might be easier to use ifup in that case. Especially setting up the connection via NetworkManager might prove difficult as nmcli doesn’t support that AFAIK.[/QUOTE]Mine is a JeOS version of openSUSE: only CLI.

[QUOTE]When the machine has ethernet cable unplugged, wireless isn’t working (but I can see it on the modem-router in its “connected devices page”): in this stage it’s weird because IP is auto-assigned via DHCP.
Which IP is auto-assigned via DHCP? The wireless one?[/QUOTE]Yes, the wireless.

What does “systemctl status NetworkManager” say?
If it’s “active (running)”, stop and disable it with:

sudo systemctl stop NetworkManager sudo systemctl disable NetworkManager

NM isn’t installed at all:

systemctl status NetworkManager.service 
NetworkManager.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)
zypper se NetworkManager
Lettura dei dati del repository in corso...
Lettura dei pacchetti installati in corso...

S | Nome                             | Sommario                                                                              | Tipo              
--+----------------------------------+---------------------------------------------------------------------------------------+-------------------
  | NetworkManager                   | Gestore dei collegamenti di rete e applicazioni utente                                | pacchetto         
  | NetworkManager                   | Gestore dei collegamenti di rete e applicazioni utente                                | pacchetto sorgente

[QUOTE]As soon as I plug in the cable, both connections come up: eth0 with DHCP (ok) and wlan0 with the static IP I set (ok); at this point eth0 and wlan0 work fine inside my LAN and also on the internet.
So your wireless has a static IP?
That might point even more to a name resolution problem.
Have you set a DNS server? How does /etc/resolv.conf look like when only wireless is connected (and isn’t working)?

Wouldn’t it be easier to just use DHCP? That would also setup DNS automatically.[/QUOTE]
I have no DNS server. The static IP of wifi works fine when eth cable is plugged. When I’ll solve this issue, the eth0 will have also static IP.
I can’t tell you how is the state of /etc/resolv.conf when wireless in on and not-working because the only access to machine is remote.

[QUOTE]What I cannot understand is why wifi depends on ethernet cable connection >:( ****!
Well, as I tried to explain already, the ethernet connection might get the DNS config from your router and set it up accordingly, so it would work even for the wireless connection then.
As you didn’t tell whether the ping by IP address worked, I don’t know if that can be the case or not.[/QUOTE]As you maybe just red on the head of this topic: it works. :wink:

[QUOTE]The only thing I understood is to manually create a wlan0 profile: You can also use YaST (even in text mode) to configure the connection.
As it seems to work when ethernet is connected, I doubt there’s anything wrong with that.

But I notice that I do not have a “WIRELESS=‘yes’” in my (working) config, and it’s spelt “WIRELESS_MODE=‘Managed’” (capital M) here. “WIRELESS_HIDDEN_SSID” is missing here as well. And it’s “WIRELESS_AUTH_MODE=‘psk’” (not ‘WPA-PSK’) here.
I have no idea whether those things could cause the behaviour you describe though.
But try to set “WIRELESS_POWER=‘no’”.[/QUOTE]In fact it works when ethernet is plugged; the syntax is copied from the config file, so I think it’s correct.

But my question was whether it works when eth0 is not connected.
So it doesn’t work then, right?

NM isn’t installed at all:

Hm. No idea where the dynamic IP adress comes from then.
Maybe try to check whether a dhcp client is running on the wireless interface:

ps aux|grep dhc

And a silly question: you don’t have “wicked” installed per chance?

I have no DNS server.

But your system has to contact one if you want name resolution to work.
This is setup in /etc/resolv.conf.

The static IP of wifi works fine when eth cable is plugged. When I’ll solve this issue, the eth0 will have also static IP.
I can’t tell you how is the state of /etc/resolv.conf when wireless in on and not-working because the only access to machine is remote.

Ok. If the ping with IP doesn’t work, the problem cannot be name resolution anyway.

As you maybe just red on the head of this topic: it works. :wink:

Right, but apparently only when eth0 is connected.
Or did I misunderstand?

In fact it works when ethernet is plugged;

Yes, as I wrote, this would suggest that it’s not the config.

the syntax is copied from the *config* file, so I think it's correct.

Hm? config is something completely different, it contains general networking settings.
You rather mean ifcfg-template I suppose?
According to the one I have here, your syntax is _not_correct though.
E.g. mine says:

## Type:        list(open,sharedkey,psk,eap)
## Default:     open
#
# Sets authentication mode. 
...
# every hardware supports WPA. In case you want to use WPA-PSK (WPA preshared
# key authentication, aka WPA "Home"), set this to psk.
...
WIRELESS_AUTH_MODE=''

You should really try to change that to the correct syntax, if only to rule out that as reason.
I haven’t checked the rest that I mentioned.

And to summarize:
The problem is that your wireless interface gets assigned a dynamic IP address via DHCP on boot, even though it is set to static.
If you connect eth0 as well (which is set to DHCP at the moment), the wireless “forgets” its dynamic address, uses the static, configured, one, and works.
Is that right?
And if you disconnect eth0 afterwards, the wireless stops working again?

And another thing I don’t really understand: how do you assess that wireless is working when you connect eth0? Via the router’s status lights?
How do you tell the system to use wireless, not wired?
Maybe you only think wireless is working, but it is in fact using wired?

Hi wolfi323.

But my question was whether it works when eth0 is not connected.
So it doesn’t work then, right?
Yep, you understand: when eth0 is not connected, nothing works; the wireless connection is (non)active, but I see an auto-assigned IP via DHCP in the modem-router’s page.

Hm. No idea where the dynamic IP adress comes from then.
Maybe try to check whether a dhcp client is running on the wireless interface:

ps aux|grep dhc
# ps aux|grep dhc
root      1767  0.0  0.0   1896    84 ?        Ss   09:48   0:00 /sbin/dhcpcd --netconfig -L -E -c /etc/sysconfig/network/scripts/dhcpcd-hook -t 0 -h linux eth0
root      2150  0.0  0.0   4040   868 pts/0    S+   09:49   0:00 grep --color=auto dhc

And a silly question: you don’t have “wicked” installed per chance?
Dunno… How could I check this?!

But your system has to contact one if you want name resolution to work.
This is setup in /etc/resolv.conf.
Never had one… Or maybe there is and I’ve never known! By the way, everything’s always worked fine: here all other devices have their own static IP.
My /etc/resolv.conf:

# cat /etc/resolv.conf

### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but                                                                                                                                                                                                                 
# may get lost when this file contains comments or empty lines                                                                                                                                                                                                                 
# only, the netconfig settings are same with settings in this                                                                                                                                                                                                                  
# file and in case of a "netconfig update -f" call.                                                                                                                                                                                                                            
#                                                                                                                                                                                                                                                                              
### Please remove (at least) this line when you modify the file!                                                                                                                                                                                                               
search fritz.box                                                                                                                                                                                                                                                               
nameserver 192.168.178.1 

Right, but apparently only when eth0 is connected.
Or did I misunderstand?
You’re right

the syntax is copied from the *config* file, so I think it's correct.

Hm? config is something completely different, it contains general networking settings.
You rather mean ifcfg-template I suppose?
According to the one I have here, your syntax is _not_correct though.
E.g. mine says:

## Type:        list(open,sharedkey,psk,eap) ## Default:     open # # Sets authentication mode.  ... # every hardware supports WPA. In case you want to use WPA-PSK (WPA preshared # key authentication, aka WPA "Home"), set this to psk. ... WIRELESS_AUTH_MODE=''

Yep, sorry: the file is /etc/sysconfig/network/ifcfg-wlan0 that I create after reading /etc/sysconfig/network/ifcfg.template. After fixing the syntax nothing changed.

And to summarize:
The problem is that your wireless interface gets assigned a dynamic IP address via DHCP on boot, even though it is set to static.
If you connect eth0 as well (which is set to DHCP at the moment), the wireless “forgets” its dynamic address, uses the static, configured, one, and works.
Is that right?
And if you disconnect eth0 afterwards, the wireless stops working again?
Ok

And another thing I don’t really understand: how do you assess that wireless is working when you connect eth0? Via the router’s status lights?
How do you tell the system to use wireless, not wired?
Maybe you only think wireless is working, but it is in fact using wired?
When I connect eth0, I see both IPs (the one with DHCP of ethernet and the other static of wifi) with respective MAC addresses on modem-router’s page. Also I can ping and ssh both and nmap found them.
One thing I noticed is also weird: the IP auto-assigned to wifi in my modem-router’s page is xxx.xxx.xxx.29, ok? Well… When I plug the eth cable and also wireless is working, I ssh via wifi with its static IP, but in the modem-router’s page the address remains xxx.xxx.xxx.29!
This makes me think that wireless isn’t working at all until I plug the ethernet cable… Could it be possible a sort of “dependecy” between… Dunno… Between interfaces/scripts/connecctions?!

Ok, that’s only the one for eth0.

Dunno... How could I check this?!

“rpm -qa | grep wicked” or similar.
But wicked is not even included in 13.1. It replaces ifup in 13.2 though.

Never had one… Or maybe there is and I’ve never known! By the way, everything’s always worked fine: here all other devices have their own static IP.

Of course you have.

DNS is not about assigning IP addresses.
It’s about resolving host names into IP addresses, i.e. when you type “ping google-public-dns-a.google.com”, the system has to know from somewhere that it should try to access the host with the IP address 8.8.8.8. It asks the DNS server for that.
You can think of that as a phonebook.

That’s independent of using static or dynamic IP addresses in your network.

My /etc/resolv.conf:

# cat /etc/resolv.conf
...                                                                                                                                                                                                               
search fritz.box                                                                                                                                                                                                                                                               
nameserver 192.168.178.1 

So here you have your DNS server, probably your router.

Yep, sorry: the file is /etc/sysconfig/network/ifcfg-wlan0 that I create after reading /etc/sysconfig/network/ifcfg.template. After fixing the syntax nothing changed.

Pity, but it was worth a shot… :wink:

One thing I noticed is also weird: the IP auto-assigned to wifi in my modem-router’s page is xxx.xxx.xxx.29, ok? Well… When I plug the eth cable and also wireless is working, I ssh via wifi with its static IP, but in the modem-router’s page the address remains xxx.xxx.xxx.29!
This makes me think that wireless isn’t working at all until I plug the ethernet cable… Could it be possible a sort of “dependecy” between… Dunno… Between interfaces/scripts/connecctions?!

Well, I’m beginning to run out of ideas what could be happening soon.

One more possibility I could imagine is that you have two configurations for the same network interface, that ifcfg-wlan0 and another one maybe (with the new naming scheme e.g., something like ifcfg-wlp0s3) which might be configured to use DHCP.
So look for that in /etc/sysconfig/network/, or maybe post a directory listing:

ls /etc/sysconfig/network/

And check the initrd as well for that:

lsinitrd /boot/initrd | grep network

(you might have to adapt the initrd filename, but initrd should be a link to the latest one)

“rpm -qa | grep wicked” or similar.
But wicked is not even included in 13.1. It replaces ifup in 13.2 though.
Nothing shows up

One more possibility I could imagine is that you have two configurations for the same network interface, that ifcfg-wlan0 and another one maybe (with the new naming scheme e.g., something like ifcfg-wlp0s3) which might be configured to use DHCP.
So look for that in /etc/sysconfig/network/, or maybe post a directory listing:

ls /etc/sysconfig/network/

And check the initrd as well for that:

lsinitrd /boot/initrd | grep network

(you might have to adapt the initrd filename, but initrd should be a link to the latest one)

ls -al /etc/sysconfig/network/

total 100
drwxr-xr-x 6 root root  4096 ott 27 21:42 .
drwxr-xr-x 5 root root  4096 ott 25 17:14 ..
-rw-r--r-- 1 root root 14080 ott 25 18:58 config
-rw-r--r-- 1 root root 10586 ott 11 19:06 dhcp
-rw------- 1 root root    60 ott 11 19:06 ifcfg-eth0
-rw------- 1 root root   151 apr 10  2014 ifcfg-lo
-rw-r--r-- 1 root root 29387 apr 10  2014 ifcfg.template
-rw-r--r-- 1 root root   272 ott 27 21:42 ifcfg-wlan0
drwxr-xr-x 2 root root  4096 ott 11 19:06 if-down.d
-rw-r--r-- 1 root root   239 apr 10  2014 ifroute-lo
drwxr-xr-x 2 root root  4096 ott 11 19:06 if-up.d
drwx------ 2 root root  4096 ott  8  2013 providers
drwxr-xr-x 2 root root  4096 ott 11 19:06 scripts
ls -al /boot/

total 36011
drwxr-xr-x  5 root root    1024 ott 12 21:08 .
drwxr-xr-x 23 root root    4096 ott 27 21:35 ..
-rw-r--r--  1 root root       0 set 13 06:25 0xd6535a69
lrwxrwxrwx  1 root root       1 ott 10 15:24 boot -> .
-rw-r--r--  1 root root    1484 ott 17  2013 boot.readme
-rw-r--r--  1 root root    2039 ott 11 19:09 boot.scr
-rw-r--r--  1 root root    1967 ott 11 19:09 boot.script
-rw-r--r--  1 root root   79845 lug 22 23:10 config-3.11.10-21-cubox
-rw-r--r--  1 root root  136830 ott  1 18:16 config-3.14.14-cubox-i
-rwxr-xr-x  1 root root   31744 ago 23 14:06 cuboxi-spl.bin
drwxr-xr-x  2 root root    1024 ott 11 19:07 dtb
lrwxrwxrwx  1 root root      23 ott 12 21:06 initrd -> initrd-3.11.10-21-cubox
-rw-------  1 root root 5063451 ott 25 17:15 initrd-3.11.10-21-cubox
-rw-------  1 root root 4930572 ott 25 17:15 initrd-3.14.14-cubox-i
drwx------  2 root root   12288 set 13 06:23 lost+found
-rw-r--r--  1 root root   88450 lug 23 01:42 symvers-3.11.10-21-cubox.gz
-rw-r--r--  1 root root     239 lug 23 01:42 sysctl.conf-3.11.10-21-cubox
-rw-r--r--  1 root root 1820944 lug 23 01:24 System.map-3.11.10-21-cubox
-rw-r--r--  1 root root 2421523 ott  1 18:16 System.map-3.14.14-cubox-i
drwxr-xr-x  3 root root    1024 ott 10 15:24 tmp
-rw-r--r--  1 root root  227332 ago 23 14:06 u-boot.img
lrwxrwxrwx  1 root root      23 ott 12 21:06 uImage -> uImage-3.11.10-21-cubox
-rw-r--r--  1 root root 4214264 lug 23 01:42 uImage-3.11.10-21-cubox
-rw-r--r--  1 root root 5042014 lug 23 01:34 vmlinux-3.11.10-21-cubox.gz
-rw-r--r--  1 root root 6649502 ott  1 18:16 vmlinux-3.14.14-cubox-i.gz
lrwxrwxrwx  1 root root      22 ott 11 19:09 zImage -> zImage-3.14.14-cubox-i
-rw-r--r--  1 root root 5977672 ott  1 18:16 zImage-3.14.14-cubox-i
lsinitrd /boot/initrd-3.11.10-21-cubox | grep -i net

cpio: Malformed number ��s���▒�
cpio: Malformed number �s���▒�}
cpio: Malformed number s���▒�}�

...]

cpio: Malformed number {��W�{��
cpio: Malformed number ��W�{���
cpio: warning: skipped 133541 bytes of junk
cpio: premature end of file
linux:/etc/sysconfig/network # 1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c


:sarcastic::o:?

As expected. As I said, probably a silly question…

ls -al /etc/sysconfig/network/

total 100
drwxr-xr-x 6 root root 4096 ott 27 21:42 .
drwxr-xr-x 5 root root 4096 ott 25 17:14 …
-rw-r–r-- 1 root root 14080 ott 25 18:58 config
-rw-r–r-- 1 root root 10586 ott 11 19:06 dhcp
-rw------- 1 root root 60 ott 11 19:06 ifcfg-eth0
-rw------- 1 root root 151 apr 10 2014 ifcfg-lo
-rw-r–r-- 1 root root 29387 apr 10 2014 ifcfg.template
-rw-r–r-- 1 root root 272 ott 27 21:42 ifcfg-wlan0
drwxr-xr-x 2 root root 4096 ott 11 19:06 if-down.d
-rw-r–r-- 1 root root 239 apr 10 2014 ifroute-lo
drwxr-xr-x 2 root root 4096 ott 11 19:06 if-up.d
drwx------ 2 root root 4096 ott 8 2013 providers

Ok, looks good.

But that gives me another idea.
Are you sure that your devices are really called eth0 and wlan0?
On 13.1 they normally get assigned the new Predictable Network Interface Names.
You would have to have an udev rule or add a kernel boot option to change that, just naming the ifcfg-xxx script accordingly does not suffice.

So please also post the output of:

ifconfig

(I don’t know why I didn’t ask for that yet… :slight_smile:

And maybe this as well, might give a clue anyway:

systemctl status network@wlan0
lsinitrd /boot/initrd-3.11.10-21-cubox | grep -i net

cpio: Malformed number ��s���▒�
cpio: Malformed number �s���▒�}
cpio: Malformed number s���▒�}�

…]

cpio: Malformed number {��W�{��
cpio: Malformed number ��W�{���
cpio: warning: skipped 133541 bytes of junk
cpio: premature end of file
linux:/etc/sysconfig/network # 1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c1;2c

 :sarcastic::O:?

Hm? Why can’t lsinitrd not read your initrd?
Maybe some package is missing, i.e. the archiver that was used to compress it?
I’m not really experienced with JeOS… on standard openSUSE this would be gzip, but from looking at /bin/lsinitrd those are also supported: bzip2, lzma, xz
What does “file /boot/initrd-3.11.10-21-cubox” say?

But that gives me another idea.
Are you sure that your devices are really called eth0 and wlan0?
On 13.1 they normally get assigned the new Predictable Network Interface Names.
You would have to have an udev rule or add a kernel boot option to change that, just naming the ifcfg-xxx script accordingly does not suffice.

So please also post the output of:

ifconfig

(I don’t know why I didn’t ask for that yet… :slight_smile:

# ifconfig

eth0      Link encap:Ethernet  HWaddr D0:63:B4:00:3F:F2  
          inet addr:192.168.178.37  Bcast:192.168.178.255  Mask:255.255.255.0
          inet6 addr: 2a01:2000:2001:56a7:d263:b4ff:fe00:3ff2/64 Scope:Global
          inet6 addr: fe80::d263:b4ff:fe00:3ff2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1407 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1904 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:193349 (188.8 Kb)  TX bytes:258478 (252.4 Kb)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:520 (520.0 b)  TX bytes:520 (520.0 b)

wlan0     Link encap:Ethernet  HWaddr B8:5A:F7:82:71:2E  
          inet addr:192.168.178.234  Bcast:192.168.178.255  Mask:255.255.255.0
          inet6 addr: 2a01:2000:2001:56a7:ba5a:f7ff:fe82:712e/64 Scope:Global
          inet6 addr: fe80::ba5a:f7ff:fe82:712e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:125 errors:0 dropped:26 overruns:0 frame:0
          TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:24017 (23.4 Kb)  TX bytes:1193 (1.1 Kb)

And maybe this as well, might give a clue anyway:

systemctl status network@wlan0
# systemctl status network@wlan0

network@wlan0.service - ifup managed network interface wlan0
   Loaded: loaded (/usr/lib/systemd/system/network@.service; static)
   Active: active (running) since lun 2014-10-06 02:00:25 CEST; 3 weeks 0 days ago
  Process: 1932 ExecStart=/sbin/ifup %i (code=exited, status=0/SUCCESS)
 Main PID: 2010 (wpa_supplicant)
   CGroup: /system.slice/system-network.slice/network@wlan0.service
           └─2010 wpa_supplicant -iwlan0 -c/var/run/wpa_supplicant-wlan0.conf -Dnl80211,wext -P/var/run/wpa_supplicant/wlan0.pid -B

ott 06 02:00:23 linux ifup[1932]: wlan0     name: cbxwifi
ott 06 02:00:23 linux ifup[1932]: wlan0     warning: WPA configured, but is untested
ott 06 02:00:23 linux ifup[1932]: wlan0     warning: with this device
ott 06 02:00:23 linux ifup[1932]: wlan0     starting wpa_supplicant
ott 06 02:00:25 linux systemd[1]: Started ifup managed network interface wlan0.

Hm? Why can’t lsinitrd not read your initrd?
Maybe some package is missing, i.e. the archiver that was used to compress it?
I’m not really experienced with JeOS… on standard openSUSE this would be gzip, but from looking at /bin/lsinitrd those are also supported: bzip2, lzma, xz
What does “file /boot/initrd-3.11.10-21-cubox” say?
No more errors after forcing reinstall, here’s to you the output:

# lsinitrd /boot/initrd-3.14.14-cubox-i | grep -i net

etc/udev/rules.d/70-persistent-net.rules
etc/sysconfig/network
etc/sysconfig/network/scripts
etc/sysconfig/network/scripts/convert_to_netconfig_dns
etc/sysconfig/network/scripts/ifup-autoip
etc/sysconfig/network/scripts/ifstatus-ppp
etc/sysconfig/network/scripts/functions.netconfig
etc/sysconfig/network/scripts/ifup-ppp
etc/sysconfig/network/scripts/link_wait
etc/sysconfig/network/scripts/dhcpcd-hook
etc/sysconfig/network/scripts/ifup-route
etc/sysconfig/network/scripts/ifup-802.1q
etc/sysconfig/network/scripts/ifup-sysctl
etc/sysconfig/network/scripts/functions.common
etc/sysconfig/network/scripts/ifdown-bridge
etc/sysconfig/network/scripts/ifstatus-bonding
etc/sysconfig/network/scripts/ifup-infiniband
etc/sysconfig/network/scripts/ifstatus-route
etc/sysconfig/network/scripts/ifstatus-sysctl
etc/sysconfig/network/scripts/create-ifservices-directory
etc/sysconfig/network/scripts/ifdown-sysctl
etc/sysconfig/network/scripts/ifdown-dummy
etc/sysconfig/network/scripts/ifstatus-802.1q
etc/sysconfig/network/scripts/ifdown-802.1q
etc/sysconfig/network/scripts/ifstatus-bridge
etc/sysconfig/network/scripts/ifstatus-services
etc/sysconfig/network/scripts/extradebug
etc/sysconfig/network/scripts/ifdown-ppp
etc/sysconfig/network/scripts/ifstatus-autoip
etc/sysconfig/network/scripts/functions.rpm-utils
etc/sysconfig/network/scripts/ifdown-route
etc/sysconfig/network/scripts/ifstatus-dummy
etc/sysconfig/network/scripts/if-up.ndp-proxy
etc/sysconfig/network/scripts/ifstatus-wireless
etc/sysconfig/network/scripts/ifstatus-infiniband
etc/sysconfig/network/scripts/move_shm_sysconfig.sh
etc/sysconfig/network/scripts/ifup-dummy
etc/sysconfig/network/scripts/ifstatus-connection
etc/sysconfig/network/scripts/ifdown-tunnel
etc/sysconfig/network/scripts/ifdown-bonding
etc/sysconfig/network/scripts/ifdown-services
etc/sysconfig/network/scripts/ifup-skel
etc/sysconfig/network/scripts/convert_to_netconfig_nis
etc/sysconfig/network/scripts/functions
etc/sysconfig/network/scripts/ifup-bonding
etc/sysconfig/network/scripts/ifdown-autoip
etc/sysconfig/network/scripts/ifup-tunnel
etc/sysconfig/network/scripts/ifup-services
etc/sysconfig/network/scripts/ifdown-wireless
etc/sysconfig/network/scripts/ifstatus-tunnel
etc/sysconfig/network/scripts/ifdown-infiniband
etc/sysconfig/network/scripts/ifplugd-selectif
etc/sysconfig/network/scripts/ifup-bridge
etc/sysconfig/network/scripts/ifup-wireless
etc/sysconfig/network/scripts/ifdown-connection
etc/sysconfig/network/ifcfg-lo
etc/sysconfig/network/ifroute-lo
etc/sysconfig/network/config
etc/sysconfig/network/ifcfg-wlan0
etc/sysconfig/network/ifcfg.template
etc/sysconfig/network/providers
etc/sysconfig/network/dhcp
etc/sysconfig/network/if-up.d
etc/sysconfig/network/if-up.d/ndp-proxy
etc/sysconfig/network/if-down.d
etc/sysconfig/network/if-down.d/ndp-proxy
etc/sysconfig/network/ifcfg-eth0
etc/netconfig
usr/lib/udev/rules.d/75-net-description.rules
usr/lib/udev/rules.d/80-net-name-slot.rules
usr/lib/udev/rules.d/77-network.rules

**[size=3]NOT SOLVED, UNRESOLVABLE?
|
|
V
**WORKAROUND
**[/size]
**
So… The workaround here is:
once getting a HDMI monitor and a USB keyboard, I re-flashed openSUSE JeOS on the microSD card, and done all the operations with never plugging the etherent cable. Wireless connection is setup via ifup configured within YaST. To get the wifi device available, just put the needed rpm on an UBS pen and just after YaST 1st boot is ended, install the drivers with

rpm -ihv /path/to/package/on/mounted/usb/pen

. Also the eth0 entry is deleted from YaST networking menu.
Now wireless is working automatically on boot and you can give your friend back the HDMI monitor and the USB keyboard!!! rotfl!

So it was a driver issue apparently, the proprietary broadcom-wl driver is not a workaround then but a proper fix.:wink:
What wireless chipset do you actually have?

lspci -nnk

or for an usb card:

lsusb

To get the open source b43 driver to work (that’s included in the standard kernel package), you have to download and install the appropriate firmware, it cannot be distributed with openSUSE.
But it doesn’t support all broadcom chips.

So it was a driver issue apparently, the proprietary broadcom-wl driver is not a workaround then but a proper fix.:wink:
Eh… It’s not like you said, unfortunately! :cry:
The proper firmware was however already installed before this workaround. I manually download the rpm simply because I didn’t want eth0 automatically setup during YaST first boot at all.
So I still don’t know what caused my problem.
I never used ethernet connection this time, but exclusively wlan0! So this is why I grab the rpm package and installed from local.

What wireless chipset do you actually have?

lspci -nnk

CuBOX doesn’t have PCI. Like you see in the block diagram it’s a BCM 4329

Are you sure?
What “proper firmware” was already installed exactly?

Still, I wouldn’t call installing a driver that works a “workaround”…

CuBOX doesn’t have PCI. Like you see in the block diagram it’s a BCM 4329

It should have been shown by lspci none-the-less.
I don’t know anything about CuBOX or running openSUSE on it, but en:users:drivers:brcm80211 [Linux Wireless] would indicate that a BCM 4329 is only supported by the brcmsmac driver, but you need additional firmware.

Both brcmsmac and brcmfmac drivers require firmware files that need to be separately downloaded. Firmware is available from the Linux firmware repository at: git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
kernel/git/firmware/linux-firmware.git - Repository of firmware blobs for use with the Linux kernel
kernel/git/firmware/linux-firmware.git - Repository of firmware blobs for use with the Linux kernel

It is contained in openSUSE’s kernel-firmware package though.

Probably there’s a bug in the kernel version that you have installed, or the kernel-firmware doesn’t match your kernel version (after all you have two completely different kernel versions installed, 3.11.10 and 3.14.4)

But if the proprietary broadcom-wl driver works, just use that I’d say.

Yes. Sure because on the first install I installed the same package, with the difference that I grab that via zipper using the already automatically set up eth0 during YaST firstboot.
So, the same package installed in both cases. On CuBOX you only need that rpm

go to network management and try to restart your connection
and select connect automatically