Wireless is not working

hi,
I am regular user of windows, but one week ago I installed ubuntu, it was very cool and then I installed opensuse yesterday because I like its kde desktop. But i have problem with wireless, i can see my home wifi, but it doesnt connect. I have same problem in ubuntu, but it was solved when i change passphrase to 40/128 bt from 128 bt, but in opensuse, all i can see is 128 bt or 64/128 ascii. Also I m unable to play mp3 songs in opensuse. Can anyone help me, please? or I have to switch to ubuntu.
Thanks in advance

Can you please post the result of this from a terminal:

/sbin/lspci -nnk

Multi-media: Multi-media and Restricted Format Installation Guide

Linux@linux-y0d7:~> /sbin/lspci -nnk
00:00.0 RAM memory [0500]: nVidia Corporation C51 Host Bridge [10de:02f0] (rev a2)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
00:00.1 RAM memory [0500]: nVidia Corporation C51 Memory Controller 0 [10de:02fa] (rev a2)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
00:00.2 RAM memory [0500]: nVidia Corporation C51 Memory Controller 1 [10de:02fe] (rev a2)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
00:00.3 RAM memory [0500]: nVidia Corporation C51 Memory Controller 5 [10de:02f8] (rev a2)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
00:00.4 RAM memory [0500]: nVidia Corporation C51 Memory Controller 4 [10de:02f9] (rev a2)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
00:00.5 RAM memory [0500]: nVidia Corporation C51 Host Bridge [10de:02ff] (rev a2)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
00:00.6 RAM memory [0500]: nVidia Corporation C51 Memory Controller 3 [10de:027f] (rev a2)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
00:00.7 RAM memory [0500]: nVidia Corporation C51 Memory Controller 2 [10de:027e] (rev a2)
00:02.0 PCI bridge [0604]: nVidia Corporation C51 PCI Express Bridge [10de:02fc] (rev a1)
Kernel driver in use: pcieport-driver
00:03.0 PCI bridge [0604]: nVidia Corporation C51 PCI Express Bridge [10de:02fd] (rev a1)
Kernel driver in use: pcieport-driver
00:05.0 VGA compatible controller [0300]: nVidia Corporation C51 [Geforce Go 6150] [10de:0244] (rev a2)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
00:09.0 RAM memory [0500]: nVidia Corporation MCP51 Host Bridge [10de:0270] (rev a2)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
00:0a.0 ISA bridge [0601]: nVidia Corporation MCP51 LPC Bridge [10de:0260] (rev a3)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
00:0a.1 SMBus [0c05]: nVidia Corporation MCP51 SMBus [10de:0264] (rev a3)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
Kernel driver in use: nForce2_smbus
00:0a.3 Co-processor [0b40]: nVidia Corporation MCP51 PMU [10de:0271] (rev a3)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
00:0b.0 USB Controller [0c03]: nVidia Corporation MCP51 USB Controller [10de:026d] (rev a3)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
Kernel driver in use: ohci_hcd
00:0b.1 USB Controller [0c03]: nVidia Corporation MCP51 USB Controller [10de:026e] (rev a3)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
Kernel driver in use: ehci_hcd
00:0d.0 IDE interface [0101]: nVidia Corporation MCP51 IDE [10de:0265] (rev f1)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
Kernel driver in use: pata_amd
00:0e.0 IDE interface [0101]: nVidia Corporation MCP51 Serial ATA Controller [10de:0266] (rev f1)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
Kernel driver in use: sata_nv
00:10.0 PCI bridge [0604]: nVidia Corporation MCP51 PCI Bridge [10de:026f] (rev a2)
00:10.1 Audio device [0403]: nVidia Corporation MCP51 High Definition Audio [10de:026c] (rev a2)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
Kernel driver in use: HDA Intel
00:14.0 Bridge [0680]: nVidia Corporation MCP51 Ethernet Controller [10de:0269] (rev a3)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
Kernel driver in use: forcedeth
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
Kernel driver in use: k8temp
03:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 02)
Subsystem: Hewlett-Packard Company BCM4311 802.11b/g Wireless LAN Controller [103c:1374]
Kernel driver in use: b43-pci-bridge
07:05.0 FireWire (IEEE 1394) [0c00]: Ricoh Co Ltd R5C832 IEEE 1394 Controller [1180:0832]
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
Kernel driver in use: ohci1394
07:05.1 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 19)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
Kernel driver in use: sdhci-pci
07:05.2 System peripheral [0880]: Ricoh Co Ltd R5C843 MMC Host Controller [1180:0843] (rev 0a)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
Kernel driver in use: ricoh-mmc
07:05.3 System peripheral [0880]: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter [1180:0592] (rev 05)
Subsystem: Hewlett-Packard Company Presario V6133CL [103c:30b7]
07:05.4 System peripheral [0880]: Ricoh Co Ltd xD-Picture Card Controller [1180:0852] (rev ff)

This is your wireless device

03:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 02)
Subsystem: Hewlett-Packard Company BCM4311 802.11b/g Wireless LAN Controller [103c:1374]
Kernel driver in use: b43-pci-bridge

However, in order to get it working, I need some more info.

  1. Are you able to use a wired connection with this machine in order to download the necessary packages?

  2. Post the result of this: uname -a

  3. Post the result of this: zypper lr -d

  1. yes i have wired connection

  2. result of uname -a
    linux-y0d7:/home/Linux # uname -a
    Linux linux-y0d7 2.6.31.5-0.1-desktop #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 i686 athlon i386 GNU/Linux
    linux-y0d7:/home/Linux #

  3. result of zypper lr -d
    linux-y0d7:/home/Linux # zypper lr -d

| Alias | Name | Enabled | Refresh | Priority | Type | URI | Service

–±----------------±----------------------±--------±--------±---------±-------±----------------------------------------------------------------±-------
1 | openSUSE 11.2-0 | openSUSE 11.2-0 | Yes | No | 99 | yast2 | cd:/// |
2 | repo-debug | openSUSE-11.2-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
3 | repo-non-oss | openSUSE-11.2-Non-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
4 | repo-oss | openSUSE-11.2-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.2/repo/oss |
5 | repo-source | openSUSE-11.2-Source | No | Yes | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
6 | repo-update | openSUSE-11.2-Update | Yes | Yes | 99 | rpm-md | Index of /update/11.2 |
linux-y0d7:/home/Linux #

Just in case you don’t know about su - ( Become su in Terminal - HowTo )

Now do the following:

In a su - terminal (copy and paste using your Mouse)

zypper ar -f http://mirror.geht-schon.de/packman.links2linux.de/suse/11.2/ packman

then

zypper ref

accept key if asked

now do

zypper in broadcom-wl broadcom-wl-kmp-desktop

when it’s done
reboot

Thanks a lot, its working now
n I tried this form for compiz, but When I changed the window manager to compiz, whole desktop went black and then white, there was nothing on the desktop. I waited but nothing chaned and I press Esc and then I cancel this setting.

You will have to explain this again if its a problem you have, because I can’t figure what you are saying.

You should not use Compiz in KDE. Well you can., but it’s just not necessary. Stick with KWIN which is kde’s manager

I installed compiz using yast as described in that from, and after installation when I changed the window manager from default to compiz, the whole screen went black and then white, there was no panel, no desktop and nothing on the screen. Then I press Esc and cancel the new setting and set window manager to default. And I am new to opensuse, so I dont know how to use Kwin or any other program.

kwin should be in use by default
Just try not to fiddle until you know your way around.

See this for multi-meida
Multi-media and Restricted Format Installation Guide

M sorry, bt linux is new thing for me and i dont even know the basics, so I am unable to follow ur instruction in the mulmedia & restricted… form, it was very easy in ubuntu, i just installed the graphic driver and then compiz, bt here i m totaly confused, isnt there an easy way like video or something from where i can get it??

Yes.
11.3 kde: click this: http://opensuse-community.org/codecs-kde.ymp