Wireless is not working - Dell Vostro 1510

First, I verified this page:
HCL/Network Adapters (Wireless) - openSUSE
I use the following model:

lobstermovelos:~ # lspci -nn | grep Broadcom
06:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g **14e4:4315**] (rev 01)

According to the instruction: “Need to install b43 firmware.” I went to the following page:
b43 - Linux Wireless
According to my model:
14e4:4315 supported 2.6.32 and later BCM4312 b/g LP b43
I’ve decided to upgrade my kernel to agree with the information above, so I followed the tutorial below:
How To Compile A Kernel - The SuSE Way | HowtoForge - Linux Howtos and Tutorials

Now my system returns the following:

lobstermovelos:~ # uname -r
2.6.32.8-default

After finally running the firmware upgrade script:

lobstermovelos:~ # /usr/sbin/install_bcm43xx_firmware

A download is performed and the following messages appear:
b43 firmware successfully installed.
b43legacy firmware successfully installed.

But the NetworkManager keeps recognizing only the wired internet (eth0 interface). Does someone have any ideas? I’ve already restarted everything and followed all the steps again, I don’t know what to do, it’s simply not working.

Regards,
Marcelo R.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Have you try the driver inside the
http://download.opensuse.org/repositories/home:/msuman:/priv/openSUSE_11.2
repository for broadcom cards? I used it once and it works


VampirD
No in elenath hîlar nan hâd gîn
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.12 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org/

iEYEARECAAYFAkt8EggACgkQJQ+0ABWtaVndZQCg2KHOQ7PR6R+N32s5aOdYYAaX
T1AAoPcr0pg4ceWNUZJ1gmJTvFI8N6pi
=8s33
-----END PGP SIGNATURE-----

I made it!!! lol! lol! lol!

I will never change my OpenSuse for some mainstream/cliche Ubuntu. To make the wireless drivers work in your OpenSuse 11.2 you just have to follow the steps below.

Verify which drivers are taking control of the device against your will:

# lsmod  | grep "b43\|ssb\|wl"

Even this command does not return anything, insert the lines below to make sure none of them ever bother you and your wireless in the future:

# rmmod b43
# rmmod ssb
# zypper remove b43-fwcutter
# echo "blacklist ssb" >> /etc/modprobe.d/50-blacklist.conf
# echo "blacklist bcm43xx" >> /etc/modprobe.d/50-blacklist.conf
# echo "blacklist b43" >> /etc/modprobe.d/50-blacklist.conf
# echo "blacklist ndiswrapper" >> /etc/modprobe.d/50-blacklist.conf


Install the required packages to use the driver ‘broadcom-wl’:

# zypper in broadcom-wl
# zypper in broadcom-wl-kmp-desktop

Run the following command and finally, your wireless will work (notice the wireless LED of your laptop being activated while the system starts):


# modprobe wl
# reboot

After two days of research, I hope this can stay documented to help others who may face the same problem in the future.

Thanks,
Marcelo R.

This worked for me on a Latitude E6400. :slight_smile: :slight_smile:

You can do the equivalent by using Yast2->Software management

  1. Search for broadcom.

  2. Check the broadcom-wl and broadcom-wl-kmp-desktop packages
    for installation.

  3. Check all other broadcom* packages that are installed for
    removal.

  4. Click accept.

  5. Reboot.

(I have the Packman repository set as the primary repository
many packages.)

jaytreiman,

I have just installed OpenSuse 11.3 in the same laptop, your suggestion worked pretty well, I added the packman repository and downloaded the broadcom packages, after rebooting the machine the wireless worked without problems! :slight_smile:

Thanks!!!