wireless internet connection

I have a Compaq pessario CQ60, a wireless network, and a Atheros AR5001 Wireless Network Adapter and I cant get the wireless internet to connect. the wireless works fine on vista, and I got the internet working via cable, but I need to get it working wirelessly. I am a beginner to linux, but know a little ( nothing in terminal though). I tried to connect using yast network settings, and both conections showed up ( wireless & wired), after trying to get it working ( including downloading + installing madwifi) and i eventually tried to get it working with Knetworkmanager, and it even recognised the wireless network, when I scanned for internet connections, it showed up in the map.
please help me, and I hope that I have given enough information.
please hep. ( opensuse 11.2 64 bit)
thanks aussiemax

Sounds like you have everything except the encryption working. You need to know the name of the wireless network access point (ESSID). This shows up in the list when you scan. You will also need to know what type of encryption and the key or passphrase to connect.

In Knetworkmanager click on “New connection” > “wlan0” to get the list of Access Points. The little blue padlock symbols show which APs have encryption on.

Click on the name of you AP, and clikc the Next button. Knetworkmanager is quite good at identifying which encryption is being used, so you should see something like a button with “WPA Personal” on it and a window below that for the key. Type in the key, and click “Next”.

If you want the network to assign addresses automatically leave the next page as is and click “Next” again. This is one of those “don’t change anything unless you know what you are doing” settings!

On the final page you can leave the name box as is, and check the “Autoconnect” box, then click “Save & connect” and it should all happen.

I have had occasional problems with connect to Linksys Routers using WPA encryption with my Acer laptop, and this seems to be just a couple of models of router. Otherwise I travel round London, and as long as I can get the password I can connect.