Wireless HP Printer Setup

Hello all,

I’m new to OpenSUSE I’ve always gave it a try but my laptop at that time the WiFi will shut off randomly and turn back on. Now this laptop it doesn’t do that. I got a HP Deskjet 2652 and on Ubuntu it’ll automatically detect it and install it to work wireless, on Arch I had to use the CUPS webpage but I got it working on wireless. The reason why I came to OpenSUSE because I’ve seen people using it and I heard a lot of good things about it plus I can see myself being a fan of it.

But for OpenSUSE I tried YaST Control Center and clicked on printer option my printer isn’t detected. So I follow the OpenSUSE wiki and they had me go through the hp-setup. I got the printer installed but it’ll only work if I got it connected the USB. I want to print wireless because this laptop got only 2 USB ports and 1 is used for my wireless keyboard and plus I take this laptop to college with me so I don’t want to keep unplugging it every time. I’m on OpenSUSE Plasma

Thank you :slight_smile:

With a new HP wireless printer, it is normally just a matter of connecting it via USB, installing it and then setting up the wireless. Many years ago I was advised that HP wireless printers prefer a static IP but I recently came across one which seemed to be working without a static IP address.

How do I make it wireless

Do you mean Wi-Fi Direct (host to printer connectivity) or having the printer connected to your wireless LAN? For a printer with no front-panel display, a Windows (or Mac) based utility is usually used to get the printer associated and connected to a wireless network. After that it should be able to be detected by any host on the network. With openSUSE make sure that the firewall is disabled while configuring CUPS, or at the very least the Avahi (mdns port) needs to be allowed for discovery.

I’m not fully sure usually Ubuntu will just detect it when I connect to my wifi. I’m at work right so I’ll try getting it to work when I’m off and I’ll report back

In openSUSE ensure the cups service is running, does the printer require a plugin, if so, as your user run hp-plugin. Then run hp-setup as root user to do final configuration for cups to use it.

As Malcolm suggested, use hp-setup to configure, but also check that the firewall is not blocking discovery. (You can disable it temporarily while configuring if necessary.)

I have a problem that may be related. I came looking for an answer, but my experience with the HP setup may provide an answer here. Recently, my HP networked printer stopped printing. Print jobs go into the queue but never print. The HP device manager locks up when I try to use it to start the printing. Going through yast>hardware>printer, I have to set it up manually, as it is not discovered. I have long had a static ip for the printer and I enter that causing yast to find it instantly and display the correct driver. One of the pages in this process has 3 checkboxes at the bottom. The last of which says “printing enabled”. Each time I run into this problem, I find that box has been unchecked.

I don’t know why or how this happens. I guess it happens either through the frequent updates or the act of rebooting after a zypper dup. Without hijacking this thread, I wonder if this is the same problem as the OP.

Hard to say without them posting again and supplying more definitive information.

I set up a wireless printer in a domestic situation by plugging in the USB, going to YaST>Hardware>Printer and selecting the HP Setup option when it appears. This offers a specific option for setting up a wireless printer. Once I have done the setup, I go into the router control panel and make the selected IP static rather than dynamic.

If you are not using something like a domestic router, you need another option.

Is cups running? Check your printer on localhost:631