Wireless help

Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)

/sbin/lspci -n
09:00.0 0280: 168c:002a (rev 01)

I ran dmesg but couldn’t find anything relating to wlan.

What to do next?



Have you looked at Madwifi
Atheros madwifi - openSUSE

Getting Your Wireless to Work - openSUSE Forums

Wrong driver, this card needs ath9k.

Full ACK here…

What is “ACK” mean?
I tried to follow the instructions from here and got this far.
HD Pavilion dv7 Laptop

YaST => Hardware => Hardware Information. “Wireless LAN”.
Report its presence/absence in your report. Its there.
“kernel driver value”.
I guess this is it. AR928X wireless Network Adapter (PCI Express)

Logs in /var/log/boot.msg I can’t find anything that mentions “firmware”.
From CLI “dmesg | grep firmware” reports nothing.

“Sudo /usr/sbin/iwlist scan”
for Lo, eth0, master0, wlan0 and vbinat0 all report “ Interface doesn’t support scanning”.

Am I doing something wrong or what?


I probably need firmware, huh? where/how do I get one for AR928X Wireless Network Adapter (PCI-Express)


What release of openSuSE are you running? The ath9k doesn’t need any
firmware… I’m using it fine on this machine?

Have you tried as per the output to modprobe the device?

sudo /sbin/modprobe ath9k

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 (i586) Kernel
up 3 days 1:54, 1 user, load average: 0.22, 0.18, 0.14
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME


And as there is still no decent information (see the stickies in this subforum) every further attempt of help would be wild guessing.

sometimes Axel we can blame the people; and sometimes we can find that the trail they are attempting to follow is not marked at every stage, as we might assume it is:

it is said that beginners need to go 1, 2, 3, 4, 5, etc

the expert can go 1,4, 10 or even 7,2,10

if you read this extremely knowledgable post

Getting Your Wireless to Work - openSUSE Forums

it actually does not say; (at any stage that I can see): tell us what version of Suse you are running: or whatever you wish them to tell you); guess what I am thinking can be a hard game for a beginner to play

The script mentioned in the third post does this (and a lot more).

And to be honest, even the “king of all teh N00bz” should get the idea that the version of your OS is an information one should always provide, it is just absolutely obvious.

Got to a Windows forum and open a thread saying

“I am running Windows and have a problem with $FOO …”

Guess what one of the first responses will be …

And the OP is not only missing out the version of openSUSE but nearly all the other information except lspci.

Thanks for your help guys. I apologize for not putting all my info into this post first. I did in a different thread and I guess is just overlooked it here. I’ve been fighting this thing for about 2 weeks and just about at my wits-end. I was going at this thread as if you all knew my OS etc. (sorry), I simply overlooked it. In fact, I was so frustrated last night that when I got up from my desk the power cord caught on my foot, I tripped and fell to the floor. That trip apparently was too much of a strain on the laptop the power quit working. Now I have to get this fixed. At which time I’ll tackle this wireless **** again. See you in a few days.

OK, I’m back now with a new laptop. Just installed Suse 11.1 on a HPdv7-1243cl Entertainment Notebook PC. Processor (CPU): AMD Turion™ X2 Dual-Core Mobile RM-72
Speed: 525.00 MHz
Cores: 2
OS: Linux x86_64
Current user: danorske@linux-l03j
System: openSUSE 11.1 (x86_64)
KDE: 4.1.3 (KDE 4.1.3) “release 4.9”

From Getting Your Wireless to Work Sticky.

II. What device do you have?
Hardware Info:Wireless LAN;
Kernel Driver: ath9k
AR928X Wireless Network Adapter (PCI Express) (wlan0)


III Do you need to install external firmware?
I tried to find the word “frirmware in the gui but couldn’t see it so I tried cli
Typing “dmesg | grep firmware” results in this;
danorske@linux-l03j:~> dmesg | grep firmware

Does this line from /var/log/boot/msg mean anything?
<4>Pre-1.1 PCIe device detected, disable ASPM for 0000:00:06.0. It can be enabled forcedly with ‘pcie_aspm=force’

<6>ath9k: 0.1
<6>vendor=1022 device=9606
<6>ath9k 0000:09:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
<7>ath9k 0000:09:00.0: setting latency timer to 64
<7>phy0: Selected rate control algorithm ‘ath9k_rate_control’
<6>rtc_cmos 00:04: rtc core: registered rtc_cmos as rtc0
<6>phy0: Atheros 9280: mem=0xffffc200020a0000, irq=18
Scanning the file I seen nothing else.

From the command “sudo /usr/sbin/iwlist scan” This is the output.

danorske@linux-l03j:~> sudo /usr/sbin/iwlist scan

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.        
#3) With great power comes great responsibility.

root’s password:
lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

wmaster0 Interface doesn’t support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:1A:70:E7:2E:0D
Frequency:2.437 GHz (Channel 6)
Quality=92/100 Signal level:-36 dBm Noise level=-95 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra: Last beacon: 1128ms ago
Cell 02 - Address: 00:14:C1:0A:C4:BC
Frequency:2.462 GHz (Channel 11)
Quality=14/100 Signal level:-86 dBm Noise level=-95 dBm
Encryption key:on
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra: Last beacon: 884ms ago


I am unable to figure this out. It see’s my router but doesn’t connect to it.

Do I need to try the other Sticky? I don’t know why those smilies are there, I didn’t put them there.


Should I use ifup or Network manager?

That’s what CODE-tags are for.


[/noparse]Console output goes in here[noparse]


Thanks for your reply. I.m using OS11.1 , KDE4 64 bit
It gives no response.