Wireless dropped out, can't get it back...

Hi, being a bit of a noobie with opensuse I’m hoping someone will be able to help.

I have an DSL-504T adsl2+ router wired into a DI-524 wireless router. I can access the internet fine using ethernet though the DI-524, and although I can log into my wireless using wicd, I can’t surf the internet or do anything on-line.

I can access the internet in the same manner using XP (and a previous version of Ubuntu) fine.

I have included some code below which I’m hoping someone will be able to diagnose this problem.

/sbin/lspci

02:00.0 Network controller: RaLink RT2500 802.11g Cardbus/mini-PCI (rev 01)

/usr/sbin/iwconfig

wlan0 IEEE 802.11bg ESSID:“Lowestoft Pl, Palmy”
Mode:Managed Frequency:2.437 GHz Access Point: 00:15:E9:0B:75:BA
Bit Rate=54 Mb/s Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Power Management:off
Link Quality=72/100 Signal level:-43 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sudo /usr/sbin/iwlist scan

wlan0 Scan completed :
Cell 01 - Address: 00:15:E9:0B:75:BA
ESSID:“Lowestoft Pl, Palmy”
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=53/100 Signal level:-40 dBm
Encryption key:on
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=000000110137936d
Extra: Last beacon: 352ms ago

Any help would be greatly appreciated,

Thanks!

In Yast - Network settings, Switch to using networkmanager to manage your connections.

Network manager should have an icon in the panel and you can easily manage and switch connections here.

Hi
I have a cunning plan… :wink: and Hi from an ex-pat kiwi. Looks like
your connecting to your AP ok, what is the output from;


cat /etc/resolv.conf
netstat -ar

You have disabled (or removed the cable) from the ethernet connection?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 3 days 0:20, 2 users, load average: 0.10, 0.06, 0.03
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

Thanks Malcolm.

I’ve tried disconnecting the ethernet lead, but it makes no difference.

Here’s the printout of the code you asked for…

baldrick@linux-d58s:~> cat /etc/resolv.conf

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:

NETCONFIG_DNS_STATIC_SEARCHLIST

NETCONFIG_DNS_STATIC_SERVERS

NETCONFIG_DNS_FORWARDER

or disable DNS configuration updates via netconfig by setting:

NETCONFIG_DNS_POLICY=‘’

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

nameserver 10.1.1.1
nameserver 192.168.0.1
baldrick@linux-d58s:~> netstat -ar
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
10.0.0.0 * 255.0.0.0 U 0 0 0 eth0
loopback * 255.0.0.0 U 0 0 0 lo
default mygateway1.ar7 0.0.0.0 UG 0 0 0 eth0
baldrick@linux-d58s:~>

Hope it helps…

Thanks again. :slight_smile:

Hi
I suggest you follow what caf4926 said about using the NetworkManager,
you route is still bound to eth0 instead of wlan0…


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
up 3 days 7:26, 2 users, load average: 0.19, 0.14, 0.04
GPU GeForce 6600 TE/6200 TE - Driver Version: 180.22

Yes, turns out wicd was the culprit. After a bit of reconfig issues, network manager has done the trick. Thanks to all concerned.:wink: