Wireless download speeds seems to be slow

Hi there all,

I have managed to compile and load the RaLink drivers for my wifi card and get an internet connection.

My problem is that when I do a broadband speed test on using chrome I get about 1.5 Mbs and on my laptop (Windows 7 meh :frowning: ) its closer to 7Mbs. I was wondering if there are any other settings I can modify or tweak that could potentially change to improve this. or maybe a better way to test the through put of my connection?

I downloaded the latest drivers for my device from Ralink and compiled new module, but I get a little confused on what settings to do and where it reads any configuration information from, if any advice can be given on this also would be very much appreciated.

Also this may be off topic or thread, if so I apologise, but I am sure there is a quick answer to this and there is a lot of different information out there on where and how I load my new rt3562sta.ko module into the kernel on start up. As currently I am calling insmod on it manually every time I start up then the Network Manager picks it up and connects.

My details I have

OpenSuse 11.3

uname -a
Linux linux-box #1 SMP PREEMPT 2010-10-25 08:40:12 +0200 x86_64 x86_64 x86_64 GNU/Linux

lspci | grep Ra
04:04.0 Network controller: RaLink Device 3062

ifconfig (I just hashed out values in there)
ra0 Link encap:Ethernet HWaddr #####
inet addr:#### Bcast:### Mask:###
RX packets:25750 errors:0 dropped:0 overruns:0 frame:0
TX packets:6297 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:9373539 (8.9 Mb) TX bytes:1472846 (1.4 Mb)

iwlist scan (again just hashed stuff out)
ra0 Scan completed :
Cell 01 - Address: ####
Frequency:2.412 GHz (Channel 1)
Quality:42/100 Signal level:-73 dBm Noise level:-75 dBm
Encryption key:on
Bit Rates:130 Mb/s
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK


ra0 Ralink STA ESSID:"####" Nickname:“RT3562STA”
Mode:Managed Frequency=2.412 GHz Access Point: ####
Bit Rate=104 Mb/s
RTS thr:off Fragment thr:off
Encryption key:####
Link Quality=92/100 Signal level:-71 dBm Noise level:-79 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Best Regards

I don’t know about the other pieces, but I can help with this.
Edit the file /etc/sysconfig/kernel, and add the module into the MODULES_LOADED_ON_BOOT parameter.
It should end up looking like this…

Also, it looks like the user Akoellh has a package in the build service for the rt3562sta, although I don’t see any binaries there for it. Maybe he’ll chime in here and commment on the status of that build.

Thank you very much for your info there on that MODULES_LOADED_ON_BOOT I had seen that somewhere before, I had set that, but it still didn’t start I am thinking I need to put that rt3562.ko module in a certain path for it to pick this up? I am sorry for my ignorance here a bit I am learning at the moment, always learning.

Lets hope user Akoellh or someone has some info on the other stuff :slight_smile:

thanks for your help on this so far :slight_smile:

Best Regards

IIRC it’s like this:

cd path-to-where-NEWMODULE-is
su -c 'install NEWMODULE.ko /lib/YOURRUNNINGKERNEL/kernel/drivers/net/wireless'
su -c 'modprobe NEWMODULE'

ok I tried that too, still nothing. I am wondering if there is something else I need to do, so now I have the module in the /lib/modules/uname -r/kernel/drivers/net/wireless dir and have set the chmod 644 on it the same as the modules in that directory. Also set MODULES_LOADED_ON_BOOT=“rt3562sta” in the /etc/sysconfig/kernel file.

At the moment I su in the terminal and do everytihing as root. and I still can’t run modprobe rt3562sta as it comes up with the error ‘FATAL: Module rt3563sta not found.’ but if I go to the directory and run insmod rt3562sta.ko that loads the module into the kernel.

Is there something I am doing wrong or conflicting? Thanks loads for the info so far and I am also googleing to see if I can find something too.

Best Regards

ok I somehow fixed my loading of modules problem, but I am unsure how, I followed this guy’s information and it worked fine Setting up a Wireless Network on Linux: Ralink 3062 and Network Manager | K-Squared Ramblings, it now seems to load the module at some point in startup.

I still have the slower download speeds problem at the moment, so still working on that. If I find anything out about it or someone else knows anyway or information about maybe config changes please let me know.

Thanx all so far for your help :slight_smile: