wireless does not work

Model: “Atheros Network controller”
Vendor: pci 0x168c “Atheros Communications Inc.”
Device: pci 0x0041
SubVendor: pci 0x17aa “Lenovo”
SubDevice: pci 0x3545
Revision: 0x20
Memory Range: 0xf0800000-0xf09fffff (rw,non-prefetchable)
Module Alias: “pci:v0000168Cd00000041sv000017AAsd00003545bc02sc80i00”
Driver Info #0:
Driver Status: wl is active
Driver Activation Cmd: “modprobe wl”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #18 (PCI bridge)

36: PCI 200.0: 0200 Ethernet controller

linux-m2d5:/home/gary # dmesg | grep firmware
3.182204] [drm] Found VCE firmware/feedback version 40.2.2 / 15!

linux-m2d5:/home/gary # /usr/sbin/iwlist scan
enp2s0 Interface doesn’t support scanning.

lo Interface doesn’t support scanning.

linux-m2d5:/home/gary #

Does wlan0 exist? Check with

ip link

Is the wlan device soft-blocked perhaps?

rfkill list

If so, unblock with

rfkill unblock wlan

ip link does not show it
rfkill does not work on any of my computers

And the output of the 3 commands are top secret?

openSUSE version?

rfkill does not work on any of my computers

Are you saying the command isn’t present? If, so you need to install the rfkill package first.

zypper in rfkill

Going back to your opening post, I note that you have an Atheros chipset (0x168c,0x0041 ). The’wl’ driver supports particular Broadcom devices. So, that won’t work.

linux-lnh8:/home/gary # ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT group default qlen 1000
link/ether 68:f7:28:cb:1a:40 brd ff:ff:ff:ff:ff:ff
linux-lnh8:/home/gary #

rfkill list
0: ideapad_wlan: Wireless LAN
Soft blocked: no
Hard blocked: no
1: ideapad_bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
2: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
linux-lnh8:/home/gary # rfkill unblock wlan
linux-lnh8:/home/gary #

i was thinking it should be ath9k.

running suse 13.2