Wireless DNS not working

I am trying to connect to my wireless network which I can do but DNS not working. I can ping everything on my network and can access my router, but cannot ping google.com or yahoo.com, however I can ping their IPs. Everything else on my network works fine.

Any Ideas would be great thanks!!

Some more info:

01:06.0 Network controller: RaLink RT2760 Wireless 802.11n 1T/2R Cardbus

/sbin/lspci -n
01:06.0 0280: 1814:0701

lo no wireless extensions.

ra0 RT2860 Wireless ESSID:“Big Kahunas” Nickname:“RT2860STA”
Mode:Managed Frequency=2.462 GHz Access Point: 00:14:6C:66:93:D6
Bit Rate=54 Mb/s
RTS thr:off Fragment thr:off
Encryption key:0A94-40CC-5463-9C62-AEA3-0756-E45B-8590
Link Quality=100/100 Signal level:-50 dBm Noise level:-81 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

Just see the content of your /etc/resolv.conf file. That is where you should see your DNS entries:

cat /etc/resolv.conf

You should get that from the router along with the IP address. If for some reason, you are not getting it, you can even update that manually.
(If you are using the traditional ifup, there is a place in the Yast configuration to specify whether DNS entries from the DHCP service to be accepted or not).

This is usually fixed by adding the IP addresses of the Name Servers provided by your ISP into the config, and the IP address of the gateway.

I have tried setting a static IP with manual Names Servers, the one my router sends (its default gateway) and also, and still no change with either.

When I run cat /etc/resolv.conf, it tells me to remove one line “nameserver” that is an address (not for my network) that was set manually for the ethernet card, not sure if it would effect the wireless (it shouldn’t)?

I am not using ifup because when that is enabled then network manager will not start and I do not know how to connect to wireless networks.

Sorry, Im still new to linux

I just tried a wired connection with the same results…
I tried networkmanager and ifup, DHCP and Static. Still can ping only IPs but no names (dns issue).

Has anyone else run into this issue?

We need more info. Invoke this script. It may detect your problem and give an appropriate error message. Otherwise post the result file somewhere on a public webspace and post it’s link in this thread.