wireless "device not ready"

Network Controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)

/sbin/lspci -n
06:05.0.280 8086:4220 (rev 05)

dmesg | less
[10.540767] ipw2200 Intel (R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kdm prq
[10.540771] ipw2200 Copyright(c) 2003-2006 Intel Corporation

eth1 IEEE 802.11bg ESSID: off/any
Mode:Managed Channel:0 Access Point: Not-Associated

sudo /usr/sbin/iwlist scan
eth1 Scan completed:
Cell 01 - Address: 00:**********:BF
Protocol:IEEE 802.11bg
blablabla blablabla blablabla

Ok, so I had to type all this using my stupid PS3… because I don’t have direct access to modem, so no ethernet. Seems to be a NM problem, but ifup confuses me to the point I want to yank my hair out. I thought the problem may have something to do with the Default Gateway bug…but adding route did not help :frowning: PLEASE HELP!

after running Framps collectNWData, it returned-
CND01203 Network Card has no IP address
CND0330E WLAN credential problems exist on interface eth1
CND0480W No link detected on interface eth1
CND0240E knetwork manager for network configuration enabled but a YAST network card configuration for eth1 ,eth0 exists

I tried to follow the sticky…but apparently I am more NOOB at this than I thought. Also tried to follow Framps instructions but the directories he specifies Network Settings/Network Card doesn’t exist on Yast.

sorry for multiple posts,
I think my problem might be a result of a faulty killswitch. For years I have had to press it over and over during boot to get it to start blinking. It seems this is a problem on 11.3. Is there a way to use terminal command to turn the switch on? It blinks, so it still works, but according to dmesg, “radio killswitch is on, it must be off for wireless to work”

Here’s a thread that talks about using the command line to turn it on and off. You will have to adapt it to your system though. It’s about halfway down.
How I solved the wireless ‘ipw2200 kill switch’ problem

echo 1 > /sys/bus/pci/drivers/rt2800//rf_kill
-bash: /sys/bus/pci/drivers/rt2800/
/rf_kill: No such file or directory

i am also getting “device not ready” with an atheros ar5001 can anyone tell me how to turn it on using terminal