Wireless connects to Access Point, yet it doesn't work

I followed the advice of the stickies, and got the following results. And for those that read it carefully: yes, my AT&T access point really is named ATT666, and I did not give it that name. I swear I am not making this up.


P: /devices/pci0000:00/0000:00:1d.2/usb4/4-2/4-2:1.0
E: DEVPATH=/devices/pci0000:00/0000:00:1d.2/usb4/4-2/4-2:1.0
E: DEVTYPE=usb_interface
E: DRIVER=rt2500usb
E: ID_MODEL_FROM_DATABASE=WUSB54G v4 802.11g Adapter [Ralink RT2500USB]
E: ID_VENDOR_FROM_DATABASE=Linksys
E: INTERFACE=255/255/255
E: MODALIAS=usb:v13B1p000Dd0004dc00dsc00dp00icFFiscFFipFFin00
E: PRODUCT=13b1/d/4
E: SUBSYSTEM=usb
E: TYPE=0/0/0
E: USEC_INITIALIZED=5426131

wlp0s29f2u1 IEEE 802.11bg ESSID:“ATT666”
Mode:Managed Frequency:2.412 GHz Access Point: AC:5D:10:44:57:4A
Bit Rate=24 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=64/70 Signal level=-46 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:68 Missed beacon:0

wlp0s29f2u1 Scan completed :
Cell 01 - Address: AC:5D:10:44:57:4A
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=66/70 Signal level=-44 dBm
Encryption key:on
ESSID:“ATT666”
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
Mode:Master
Extra:tsf=0000000f57d7dd57
Extra: Last beacon: 265ms ago
IE: Unknown: 0006415454363636
IE: Unknown: 010882848B962430486C
IE: Unknown: 030101
IE: Unknown: 0706555320010B1E
IE: Unknown: 2A0100
IE: Unknown: 2F0100
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: Unknown: 32040C121860
IE: Unknown: 2D1A1C181BFFFF000000000000000000000000000000000000000000
IE: Unknown: 3D1601001700000000000000000000000000000000000000
IE: Unknown: DD090010180206F02C0000
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00

paul@linux-p88k:~> ping -c 5 192.168.1.254
PING 192.168.1.254 (192.168.1.254) 56(84) bytes of data.
From 192.168.1.70 icmp_seq=1 Destination Host Unreachable
From 192.168.1.70 icmp_seq=2 Destination Host Unreachable
From 192.168.1.70 icmp_seq=3 Destination Host Unreachable
From 192.168.1.70 icmp_seq=4 Destination Host Unreachable
From 192.168.1.70 icmp_seq=5 Destination Host Unreachable

— 192.168.1.254 ping statistics —
5 packets transmitted, 0 received, +5 errors, 100% packet loss, time 3998ms
pipe 3

— end of output from the three info-requests from the sticky directions —

So as you can see, the wireless device does detect my access point, and when I enter the passkey, everything seems fine. But then I can’t ping it successfully (unless I move the computer close enough to reach the ethernet wire and plug that in: the IP address is correct). It’s a devilish ATT666 problem.

Any help / ideas appreciated.

Okay, being associated and having the right network configuration are two different things. Some more info would be useful

  1. openSUSE version

  2. Are you using Network Manager or wicked,…?

  3. When your wireless is up and connected, note what the following commands report

ip addr
ip route

That will help us determine how the connection has been configured.

have you tried running the commands in the release notes?

1.2. Network After an Update With YaST

this will ensure NetworkManager is correcly activated after any change

Well, Network Manager was sitting there in my bottom right hand tray, but when I opened it “Wireless” page was grayed out. This turns out to be half the key to the solution!

The other half was where keellambert said to read Release Notes on Network After Update with YaST. I found instead, openSUSE Documentation, which said

  •   Run YaST and go to Network Devices › Network Settings.     
    
  •   The Network Settings dialog opens. Go to the      Global Options tab.     
    
  •   To configure and manage your network connections with NetworkManager:
    

[LIST]

  • In the Network Setup Method field, select User Controlled with NetworkManager.
  •   Click OK and close YaST.     
    
  • Configure your network connections with NetworkManager    as described in [Section 25.3, “Configuring Network Connections”](https://activedoc.opensuse.org/book/opensuse-reference/chapter-25-using-networkmanager#sec.nm.configure).   
    

[/LIST]

Thanks folks! That did it; I had Network Manager, but I wasn’t actually using it. Still a Linux newbie, me.

Thanks folks! That did it; I had Network Manager, but I wasn’t actually using it. Still a Linux newbie, me.

I’m glad we could be of help with our prompting. All part of learning and worth the effort! :slight_smile: