Wireless connections always drops after 20 pings, then "sendmsg: No buffer space available"


after overcoming the problem with the disappearing wireless connection (as discussed elsewhere, one has to disable
and then enable wireless again; while whether it is a “system connection” or not does not seem to be relevant — the
whole thing seems a clear regression to me, compared to 11.4, where there wasn’t such problems), still no permament
wireless connection can be established — the connection always aborts after a short time.

Monitoring it with “ping”, I see a clear and reproducible patter:
The wireless-connection stays open for about 20 pings, and then

64 bytes from icmp_seq=58 ttl=44 time=25.0 ms
ping: sendmsg: No buffer space available
ping: sendmsg: No buffer space available

appears — that looks like a clear bug to me?!

I’m having a

   Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

and the driver is

    Driver: b43-pci-bridge
    Kernel Driver: ssb

The software installed from the Suse-repositories is

   b43-firmware - Firmware files for Broadcom bcm43xx series based PCI/PCMCIA cards

|  b43-fwcutter - Tool for extracting firmware from newer Broadcom WLAN drivers

Is there are workaround? Perhaps I need to install the proprietary Broadcom-
driver (with Suse 11.4 I had that installed, and it worked fine)?



As far as I can see, for my
Broadcom Corporation BCM4312 802.11b/g LP-PHY
card I can use either the
b43-firmware, b43-fwcutter
or the
And there is also
so there are possibly three options.

If I want to use broadcom-wl, how would I switch?
Intuitively (naively believing in Yast) I would just deinstall the two
b43-packages, and then install the broadcom-wl package, but
that might not work / not be enough:

As far I can remember, already to get the b43-packages running, I had first to

  • switch in Yast to the traditional method, in order to get access to the configuration
    of the wlan-card,
  • and then, upon entering the edit of the wlan-card, a window popped up, informing
    me about some action regarding these b43-packages.
    (The whole procedure is not user-friendly.)
    So I guess more steps are needed.

Thanks for your consideration.


It seems that
b43 - Linux Wireless
is the decisive source here. So the b43-legacy-package
is not needed here. And apparently I can just additionally
install the broadcom-wl package, and then blacklisting the
one driver which is not to be used (in order to switch between
the b43-driver and the wl-driver).
Is this correct?


I have now installed packages

broadcom-wl - Wireless driver for Broadcom 43xx series of chips
broadcom-wl-kmp-desktop - Wireless driver for Broadcom 43xx series of chips

After rebooting I found that in
> cat /proc/modules
now wl is used (no longer b43; not clear whether this is due to the order of installation,
first the b43-packages, then the wl-packages, or due to a general preference for the

And now the wireless-connection works!

So the b43-driver has a fault.

Remark: One would think that one should install broadcom-wl-kmp-default, since
it says “default”, however this would be false, and a new kernel-version would be installed,
which creates all kind of trouble, since the “default” is “desktop”. Another example for the many
traps awaiting the Suse-user.