wireless connection to internet!! HELP!!

hello, I’m a new SUSE Linux user and just installed Suse 11 on my laptop! I also have a desktop with windows xp on it, connected to internet through a crypto router. I’m having problems with my laptop wireless network card, cause although it’s connected and properly configured, I’m having a message saying that it’s disconnected!!! what can I do about it? I’d also be greatfull if you guys could give me a link to a suse tutorial or something!
thanks in advance!!

You most likely have a driver and/or firmware problem. First of all you need to provide some more information about your wireless chipset. Otherwise helping you isn’t possible. Please post the output of “lspci” (or “lsusb” if you’re using an usb wireless adapter) and “hwinfo --wlan” - run these commands as root. There will be someone out there able to help you with that info.

Can you output message?
Please also summarize your environment (static dhcp).

Hi Lonewolf1311: I just came to the forum to express some ‘problem’ I had, but it may actually address what you are having, perhaps.

My problem was that I was connected to my office network connection, no problem. But when I went home to use my Belkin wireless connection, I was not able to connect, even after putting the right security etc. worse, my windows was working through wireless, but my openSUSE 11 was not.

It turned out that I had to not only use the KNetworkManager to manage my internet connections (which I do, in KDE 3 btw), but I also had to go to YAST to manage my network connection.

There is a setting in YAST for network devices, and then network settings. When I click that… I see my two network devices (wireless and ethernet (LAN).) while my ethernet and wireless were connected, it seems (to a noob like me)… that the Hostname DNS and the Routing are universal settings and need to be set according your specific router/modem.

ie. I changed the DNS and Gateway to my home wireless settings, and it worked. then, when I returned to my office, I had to change my settings back in YAST.

The only difference I can see is that in my case, I was seeing the “connected” sign… though my internet was not working. In your case you are seeing an “unconnected” sign. But perhaps by seeing that I had to double-configure my network, you might gain some insights.

All the best!