Wireless connection time on 11.3 much worse than 11.2

It is taking up to 3 minutes after the desktop has come up (T42 thinkpad with opensuse 11.3 + kde 4.4.4 rel 2) before wifi connection is completed. This is much much slower than 11.2 and kde 3.? or even M$ XP.
The fix suggested in this forum makes no discernible improvement. Does anybody know why this change has been made and when it will be sorted out.

Consistent with this thread, it would be helpful if anyone knows of a tool comparable to ethtool supporting wireless. It looks like the ethtool project at freshmeat hasn’t been updated since 2004.

BTW - Don’t know if this has been tried but it’s always useful to search for latest (maybe even not latest) drivers and not rely entirely on repository updates.


OK. I have tried upgrading to kde 4.5.2 and that was no better and introduced other issues so I have backed to kde 4.4.4. But I still have problems here. On booting the Knetworkmanager M logo sits in the system tray and if I click on it I get a greyed out statement that it is disabled. Whatever I do I cannot advance the startup of this program, I must wait for about two minutes until the M is replaced by a plug & socket logo and then by the wireless logo.

What I want to know is where does this startup instruction reside in the system and why is it not possible to place it first. As it is now, the auto update starts, tries to connect, fails and gives me an error message and still I have to wait. This startup sequence is nonsense and much inferior to that other operating system! Come on Linux experts, please help me sort this out.

Another irritation is that after all my efforts to improve things I have actually made matters worse because now I must open my wallet in order to authorise a wireless connection. How do I prevent this which never used to be required.


I don’t think I’ve heard anyone reporting the same problems with GNOME, and since I really don’t like the new KDE interface I would have no problem recommending that you use GNOME.