Wireless connection says "active" but nothing connects

During the installation of Opensuse 11.2, I tried the wireless internet connection, and it kept coming back failed.
I continued to install the system and when I got on, I entered the SSID (think that’s the right way to say it), and the password.
When showing that ‘map’ or whatever, it showed the SSID in the networkmanager.
It also said “active”.
But when clicking on Mozilla Firefox, nothing happened. It just said the server is down.

I’m on another Linux system now; so I know the wireless works. It worked great on a third one as well.

It is some Atheros Communications, AR5001.

I’m not sure what other information you need. Just let me know and I will do what I can to provide. I don’t have opensuse up at the moment. I screwed up the dual boot. so right now it’s been erased. I’ll ask for help on that in another topic.

Thanks for your help!

Getting Your Wireless to Work

Can you post the information from these commands:
first run command su to become root, then these:

  • iwconfig
  • ifconfig
  • route
  • cat /etc/resolv.conf

I’m guessing the information will be different on some other distro then what it would say on opensuse? If not, here is the info. but assuming it is different, let me know. maybe I can learn how to dual boot again and get opensuse back.

[root@localhost jeremy]# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"KallieSue"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:26:F2:15:52:FC   
          Bit Rate=36 Mb/s   Tx-Power=20 dBm                                   
          Retry  long limit:7   RTS thr:off   Fragment thr:off                 
          Encryption key:BED8-3407-647B-DEC7-EFCE-C812-9C87-B7DD-85E6-C468-4433-E61A-ACDC-AE6C-75C2-88E5 [2]                                                    
          Power Management:off                                                  
          Link Quality=24/70  Signal level=-86 dBm  Noise level=-100 dBm        
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0              
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0              
[root@localhost jeremy]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1F:16:76:53:F1  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1     
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000                        
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)              
          Interrupt:28 Base address:0xe000                    

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host     
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:638 errors:0 dropped:0 overruns:0 frame:0
          TX packets:638 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:93825 (91.6 KiB)  TX bytes:93825 (91.6 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:24:2B:B3:05:09
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::224:2bff:feb3:509/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2907 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2847 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2253223 (2.1 MiB)  TX bytes:628726 (613.9 KiB)

wmaster0  Link encap:UNSPEC  HWaddr 00-24-2B-B3-05-09-B1-16-00-00-00-00-00-00-00-00
          UP RUNNING  MTU:0  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
[root@localhost jeremy]# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     *               255.255.255.0   U     35     0        0 wlan0
link-local      *               255.255.0.0     U     35     0        0 wlan0
loopback        *               255.0.0.0       U     0      0        0 lo
default         192.168.1.1     0.0.0.0         UG    35     0        0 wlan0
[root@localhost jeremy]# cat /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 192.168.1.1
[root@localhost jeremy]#

Hi again, I edited your post to make it more readable by putting “code” tags around your returns.

Here’s what I see:

  • iwconfig
    shows that your wireless device is up and running and linked to your wireless access point and lan called KallieSue
  • ifconfig
    shows the device is receivng an IP address namely 192.168.1.2. Thus is working well.
  • route
    shows that your interface understands the correct location for your router and direction to the internet
  • resolve.conf
    is where the problem lies. The IP addresses of the name servers (provided by your ISP, or by public providers like google) should be coded into your configuration.

You should make sure you have the gateway IP address and the IP addresses of the Name Servers in you NIC config. This is different if you are using the network manager applet in the screen panel --or-- if you are using Yast to config the card.

Are you cool with adding these or do you need help?

This might help although it’s for the option where you config the NIC with Yast (not for config of the other method, the network manager applet): Configure a network card in Suse/openSUSE 11.x for Internet Access & wifi. in particular the section Adding Name Servers and a Gateway to your IP configuration

I tried the network manager to try to connect, Yast I think wasn’t able to make the wireless active.
Any help I can get is appreciated. I am still a noob in the wireless department. I understand some, but not a lot.

Whatever you did, the wireless device is working perfectly. The problem is that the operating system doesn’t know the location of the name servers on the internet that tell the software how to convert names like “www.google.com” into real addresses like “66.102.11.104”. The final adjustment is all that’s required.

Edit the file /etc/resolv.conf with this command run it in a console window:

  • Gnome users run this: gnomesu gedit /etc/resolv.conf
    OR
  • KDE users run this:** kdesu kwrite /etc/resolv.conf**

Then add these two lines into the end of the file and save and exit:

nameserver 8.8.8.8
nameserver 8.8.4.4

try that; might need a reboot, can’t recall, try it without a reboot first

Being I screwed up my dual boot, I had to reinstall opensuse. I don’t know why, but I have the internet on here. I’ll keep that info in case something happens.

Thank you for redoing the code up there to make it easier to see it.

And thanks for your help in everything.

You’re welcome

Lenovo Thinkpad R61i
Opensuse 11.2, KDE 4.4.3

Hey,
I have the same problem. I’m a rather Linux illiterate user and desperately trying to get my internet working. It’s connected, but I cannot access anything. Anyway, these are my outputs (which i cannot post as pretty as most of you).

linux-ekhv:/home/eva # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11abg ESSID:“refsa23”
Mode:Managed Frequency:2.457 GHz Access Point: 00:1F:A4:83:A4:42
Bit Rate=1 Mb/s Tx-Power=15 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:3668-1796-976B-F235-8E4F-8045-9D
Power Management:off
Link Quality=64/70 Signal level=-46 dBm Noise level=-127 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.

linux-ekhv:/home/eva # ifconfig
eth0 Link encap:Ethernet HWaddr 00:0A:E4:C9:49:3F
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:18

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:66942 errors:0 dropped:0 overruns:0 frame:0
TX packets:66942 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1953414 (1.8 Mb) TX bytes:1953414 (1.8 Mb)

wlan0 Link encap:Ethernet HWaddr 00:1C:BF:D5:C7:26
inet addr:192.168.1.7 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::21c:bfff:fed5:c726/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:35 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:6958 (6.7 Kb)

wmaster0 Link encap:UNSPEC HWaddr 00-1C-BF-D5-C7-26-00-00-00-00-00-00-00-00-00-00
UP RUNNING MTU:0 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

linux-ekhv:/home/eva # route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 2 0 0 wlan0
loopback * 255.0.0.0 U 0 0 0 lo

linux-ekhv:/home/eva # cat /etc/resolv.conf

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:

NETCONFIG_DNS_STATIC_SEARCHLIST

NETCONFIG_DNS_STATIC_SERVERS

NETCONFIG_DNS_FORWARDER

or disable DNS configuration updates via netconfig by setting:

NETCONFIG_DNS_POLICY=’’

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

nameserver 8.8.8.8
nameserver 192.162.1.7


Note, the two nameservers in the resolv.conf file where my rather helpless attempt to get something going (keep in mind, im usually a linux illiterate user!). Before there was no nameserver at all.
I hope you can help me as rookie-understandable as possible

thanks

You have exactly the same problem, and the solution is exactly the same. You need to add the IP address of your gateway (probably 192.168.1.1) and the IP addresses of two nameservers also. The way to go about it depends which network manager you’re using, Yast’s or an “Applet”

Are you using a a Network Manager applet in the bottom panel to configure your internet/network settings? Or are you using Yast’s configurator for that? And if it’s the former, are you using Gnome or KDE?

Hi,
I added 192.168.1.1 and 8.8.8.8 as nameservers in the resolv.conf and also added the gateway and DNS server manually in kde-networkmanager which im using. yesterday at least i was able to get a response when i pingged the gateway, now both gateway and 8.8.8.8 are unreachable.
so, what’s correct for the resolv.conf?
nameserver 192.168.1.1
nameserver 8.8.8.8
and?

i just tried the configuration with yast following the manual here Configure a network card in Suse/openSUSE 11.x for Internet Access & wifi. to no avail. in resolv.conf i added my ip adress as a nameserver to find nothing is happening and tried 8.8.4.4 instead, too. still cannot ping anything.
other ideas?
best wishes

Neither the gateway IP (192.168.1.1) nor your machine’s IP address (192.168.1.7) should be in the list of name servers, just the IP addresses of nameservers should be there. Try the name servers supplied by your Internet Service Provider, although Googles 8.8.8.8 and 8.8.4.4 should work.

This is what I use:
nameserver 8.8.8.8
nameserver 8.8.4.4

Did you check the gateway like this Pic: click the link http://opensuse.swerdna.org/nicifup/nic12.png except you use 192.168.1.1

When you finish looking/adjusting, then tell us what do you get now when you run the command su to become root then these commands:

  1. iwconfig
  2. route
  3. ifconfig
  4. cat /etc/resolv.conf

I did check the gateway as in the pic. i did as i was told and here are my outputs. the first nameserver is one of my provider (which is streamyx [Malaysia]).

linux-ekhv:/home/eva # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11abg ESSID:“refsa23”
Mode:Managed Frequency:2.457 GHz Access Point: 00:1F:A4:83:A4:42
Bit Rate=5.5 Mb/s Tx-Power=15 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:3668-1796-976B-F235-8E4F-8045-9D
Power Management:off
Link Quality=70/70 Signal level=-35 dBm Noise level=-127 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.

linux-ekhv:/home/eva # route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 2 0 0 wlan0
loopback * 255.0.0.0 U 0 0 0 lo
default 192.168.1.1 0.0.0.0 UG 0 0 0 wlan0

linux-ekhv:/home/eva # ifconfig
eth0 Link encap:Ethernet HWaddr 00:0A:E4:C9:49:3F
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:18

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:365 errors:0 dropped:0 overruns:0 frame:0
TX packets:365 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:30080 (29.3 Kb) TX bytes:30080 (29.3 Kb)

wlan0 Link encap:Ethernet HWaddr 00:1C:BF:D5:C7:26
inet addr:192.168.1.7 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::21c:bfff:fed5:c726/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:241 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:18997 (18.5 Kb)

wmaster0 Link encap:UNSPEC HWaddr 00-1C-BF-D5-C7-26-00-00-00-00-00-00-00-00-00-00
UP RUNNING MTU:0 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

linux-ekhv:/home/eva # cat /etc/resolv.conf

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:

NETCONFIG_DNS_STATIC_SEARCHLIST

NETCONFIG_DNS_STATIC_SERVERS

NETCONFIG_DNS_FORWARDER

or disable DNS configuration updates via netconfig by setting:

NETCONFIG_DNS_POLICY=’’

See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

nameserver 202.188.0.133
nameserver 8.8.8.8
nameserver 8.8.4.4

Try a suggestion origination from a comment by lwfinger

  • rename the file resolv.conf with this command:
sudo mv /etc/resolv.conf /etc/old.resolv.conf.bak

and then reboot

nothing worked. i could repost the outputs, but they say the same as before except that resolv.conf has a different name now.

thanks anyway

The file resolv.conf should still exist after the reboot. If it doesn’t then you have a serious malfunction of your networking.