Wireless connection not starting automatically


I set up 11.4 in my laptop and, after updating and downloading the proper firmware, everytihing runs great. I already configured the wireless network via the standard NetworkManager but the connection never starts automatically. When I boot up it reports all the wireless connections available and also let me connect to hidden networks (mine is not broadcasting so I have to use this option). I had to reconfigure my network options the first time I selected Hidden Networks but it connects fine. Please note I had already selected the “Automatic connection” option

So the only question is how I configure my equipment so it connects automatically to the already configured network?

Thanks in advance

There is an option in the settings > edit connection
start automatically

are you kde or gnome?

Sorry, you beat me to answer before I could add that. The option is already selected. I’m using Gnome

I’m not sure
I have never worked with hidden connections. Maybe that’s the problem I don’t know.