Wireless connection must be reconfigured after hibernation

I have been running SUSE 11.1 on my HP laptop for over a year. For the most part, I am thrilled with it. However, when I awaken the computer from hibernation mode, I have to go into the Network Settings applet proceed with the wizard in order to get my wireless connection working.

Another irritating aspect is that if I go to a place with a Wireless Hotspot, the computer doesn’t automatically pick it up. Again, I have to go through the Network Settings applet to get it working.

I want this to work as it does on Windows XP/Vista where I can put the computer to sleep and when I awaken it, then the wireless connection is automatically there for me, etc.

I have to think I probably need to tweak a setting somewhere, so if someone can tell me where to do this, great!

I am using an internal wireless card (Atheros AR928X PCI-EXPRESS). If you need additional info, let me know.

What desktop are you using, for me in Gnome, I set the wireless key in
the Network Manager and check the box for all users, coming out of
sleep mode it just kicks into life.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.3 Milestone 3 (i586) Kernel 2.6.33-5-desktop
up 17:47, 2 users, load average: 0.51, 0.44, 0.35
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

I am using Gnome. I am probably not using the Network Manager.

Under Network Settings, I have selected Traditional with ifup.

To achieve this, you have to use the networkmanager, and set networking to use it in Yast. Another solution is installing WICD. See Software.openSUSE.org and search for “wicd”.