Wireless connection dropping at irregular intervals

Hi

I may have posted bits and pieces of this on other threads in response to other users’ problems. However, I am very frustrated now!

In summary, I am using openSUSE 11.2 x64 on an Acer laptop with a wireless AR928X card. I can connect to my WEP-secured network when I boot up. After some time (it might be minutes, it might be hours), I am prompted for my WEP password again. This never works, despite being the one which gets me on-line at start-up!. The only solution is a reboot. The problem is intermittent and doesn’t seem to depend on my on-line activity.

I have tried the following with the same result:

  • KNetworkManager
  • Traditional using IFUP
  • Enabling / disabling IPv6 support

I tried installing the compat-wireless package through YaST and then managed to get no internet connection at all. Went back to KNetworkManager and things “worked” again until I was prompted for the WEP code.

I’m very frustrated with this! I have openSUSE 11.2 x64 working on my office laptop without problem and can connect to my home network without any problem. My issues are with my personal laptop.

As a measure of my frustration, I have reached the stage of booting into Windows 7 as my default option so that I can access the internet reliably.

I’m open to suggestions as to what I can do to diagnose and repair the problem - could it be that the card is going into powersave mode? If so, how do I stop that happening?

I’d prefer to be on openSUSE but need to be able to rely on the internet.

When your connection drops, what is the output at the end of a dmesg listing? Is
a reason code given?

If you get a popup requesting the encryption key, it is not transferred to
NetworkManager. That is a design flaw in NM that will likely be fixed. Just
cancel that popup.

If you click on the applet, can you remake the connection?

You should be able to turn power saving off with the command

sudo /usr/sbin/iwconfig wlan0 power off

In any case, a reboot should not be necessary. If you do

sudo /sbin/modprobe -rv ath9k
sudo /sbin/modprobe -v ath9k

the network should restart.

Finally, the Atheros guys have done a lot of work on the ath9k driver in the
recent past. Have you tried the compat-wireless package? It might help.

Does this occur at a particular time of day?
How close are you to the router?
What is around the router? Speakers? TV’s? Power Supplies? Things that cause electromagnetic interference.

There is another network manager called, wicd. A lot of people like it better than networkmanager. Index of /repositories/system:/wicd/openSUSE_Factory

Also bring up Knemo and watch it for a while.


Thanks - I’ll give it another try with what you’ve suggested. I did try compat-wireless but couldn’t make any sort of connection at all, so removed it.

Re the signal strength etc - I’m in the same room as the wireless router and, in W7, have no problems at all.

One question - how do I make Wicd my default network manager and get it to start automatically on booting up?

I was having the exact same problem and I tried:

sudo /usr/sbin/iwconfig wlan0 power off

as suggested. So far I haven’t had any problems, but since the wireless dropping was always intermittant anyway I’m not really sure this is what fixed it. I’m keeping my fingers crossed though

D

I’ll give it a go - but I am now experiencing the same problem with a different laptop and wireless card, although the OS and desktops are the same.

Seems to have started on the second laptop after the last kernel upgrade, but that may be coincidence.

Just tried the

/usr/sbin/iwconfig wlan0 power off

command but it isn’t supported.

Any other ideas?

i was having intermittent probelms.

Tried switching off powersave through /etc/sysconfig editor but no luck.

Tried

sudo /usr/sbin/iwconfig wlan0 power off

joy! cheers!

every now and again - no pattern to it, could be next reboot, could be several weeks - my wifi outages return. I run ‘sudo /usr/sbin/iwconfig wlan0 power off’ again and all is good again.

Any reason why this would reverse itself?

Any way to set permanently?

On 03/07/2010 02:56 PM, ZootHornRollo wrote:
>
> every now and again - no pattern to it, could be next reboot, could be
> several weeks - my wifi outages return. I run ‘sudo /usr/sbin/iwconfig
> wlan0 power off’ again and all is good again.
>
> Any reason why this would reverse itself?
>
> Any way to set permanently?

Does your AP allow you to turn off power-saving mode? If not create a script
that sleeps for 5 minutes, then issues the power command. Add the script to
boot.local.

Which driver does your card use?

my card is a RaLink RT2561/RT61 802.11g PCI

there is no option for switching power saving on my router settings. (not sure what model it is - standard UK Sky broadband router - newer type)