hopefully somebody can help me on the following:

I installed openSuSE 11.2 onto an HP Pavillion dv5-1040 (openSuSE as only
operating system), first from net and then from CD.
Initial installation took place around 20 December, and is still going on (!).
After much back and forth (installing Atheros 928x drivers etc etc), I was able
to get the wireless network up and running (perfectly).

The PC was set up such that I would be logged directly in at boot. For security
reasons, I wanted to have a login with username and password, and I was able
to get that going (unfortunately). The side-effect was that I am no longer able
to access the network! I have been extensively searching the net find a
solution, but without success. I strongly suspect that the solution is to set one or more parameters in a script, but what parameters in what script? Help on this would be
much appreciated.

Jan Christian

Were you working with root login earlier?

No, logging in as “JCA” with root privileges to be precise).

Jan Christian

It is not a good idea for a user to run with root privileges particularly when accessing the net…

Well, it worked perfectly until I changed to explicit login after boot.

You stated:
<It is not a good idea for a user to run with root privileges particularly when accessing the net.>
Could you enlighten me a little on the subject?

Thanks and Regards,
Jan Christian

A user with root access is more or less the same as root there for if you get attacked and and your user account is compromised then the attack vector has full control of your machine. You should only be root when you modify the system level settings or are installing global programs. This is why Windows, until recently, was so vulnerable to attacks. It is also dangerous to you since as as a user rm -R / will not do anything but as a super user it will erase everything on the machine.

As to your problem an administration account is neither fish nor foul. It is not truly root and it is not truly a user.The auto-login must side step some security. When you tightened security by requiring a login sudden the system sees you as a user not as root. Since you set it up when it thought of you as root it no longer functions as you expect.

And, does you (or anybody else out there) have some suggestions regarding how to get rid of the problem?

Jan Christian

what desktop are you using? Kde, Gnome or etc
are you on a router or directly to a modem
wired or wireless

Hello dale14846,

to your questions:
Desktop is Kde,
I am onto a wireless network via a router (I mentioned
wireless in my original post, but was not specific enough;

My belief is that there must something fundamentally wrong
with my linux installation. Since I am a newbie to Linux,
figuring out how to get things going takes some time, if
you have some hints to how to figure out (and repair!), I
would be most grateful.

Thanks and regards,
Jan Christian

I have no idea how much you messed up already. There should be no need to install Atheros drivers, they are in the kernel, ath5k and ath9k.

I suggest you reinstall, using a cable connection to the router first, update KDE4 to the most recent stable one (search the forums for instructions). That will include a better knetworkmanager, which will no doubt make things easier. Drop in back here right after install, we’ll help you with the wireless.

Hello Knurpht,

you wrote
<I have no idea how much you messed up already.>
The main problem is that I do not know either.:’(

I did an update a few days ago, but will (of course)
follow your suggestion.

Remark: The boot.log file looks OK, with one exception:
Warning: ECC is NOT currently enabled by the BIOS, module will NOT be loaded. Either enable ECC in the BIOS, or …

Best regards,
Jan Christian

FYI- ECC is special error correcting memory that has 9 bits ber byte the extra bit is a check bit and is hardware checked every time the memory is accessed. Since you don’t have ecc memory (most don’t) no need for any special code to recover/alert you to memory errors because you do not hae that type of memory.

I don’t think this is an error itself but a permissions problem because your account is set up with root permissions.

You certainly can setup a admin account but it should only be used for administration. But there is already root which does just that.

Hello gogalthorp,Knurpht,

I have performed a complete update of the installation,
and checked the wireless configuration (essid etc). The
PC shows that there is a connection (blue antenna instead
of red). Stll not able to connect to the net.:frowning:
Further, there is no icon showing signal strength.

I am still open to suggestions!

Best Regards,
Jan Christian

first check your firewall settings yast > security and settings
interfaces and make sure your wireless is sett to external zone
no zone assigned means that your firewall is blocking your wireless

I just reread your last post and saw that you have a blue antenna which means that you should be connected to your router. mouse over the icon and it will tell you
a right click will give a menu at the hover over the top pleas report the ip address it gives and the name of your router.

Hello dale14846,

security settings are to external zone.

The blue antenna is at the PC (indicating that
a wireless network has been found and connected
to). The wireless network settings are OK
(SSID, infrastructure, WPA,WPA2-Personal,

Best Regards,
Jan Christian

Hello again,

I have had a brief look at /etc/sysconfig/network/ifcfg-wlan0, the file contains the following non-blank entries (XYZ=’’):
NAME=‘AR928X Wireless Network Adapter (PCI Express)’

I suppose this is OK?

Best Regards,
Jan Christian

No, not OK. AUTH_MODE cannot be “open” with WPA/WPA2.

Start Yast, Network Devices, Network Settings, tick the wireless, click Delete and confirm that. Now tick it again, and pick Edit. Carefully configure it now, including the security stuff.

To illustate, here is an example of a ifcfg-wlan0 with WPA2/PSK enabled.

NAME=‘AR9285 Wireless Network Adapter (PCI-Express)’

You could just change the YOUR…HERE things in yours.

Hello Knurpht,

I have followed your advise, but no success.>:(

Concerning my setup, please note the following:

  • Network is set up via wpa_supplicant, neither
    Yast2 nor iwconfig will work.
  • I have checked ifcfg-wlan0 two times, it
    appears to be OK now (as per your advice)
  • I have started the system as user, as user
    with root privileges, and as root: No access
    to the net?

Silly question: Is it conceivable that there
is some process or some settings made before
the “disaster” that have survived?

Would you recommend a new installation from

Best Regards,
Jan Christian

If you want to exclude that, yes. Perform a clean install, get back to us when you start configuring the wireless.