Wireless connection active but Firefox refuses to connect

KDE 13.2 and I’ve just changed to the wireless radio and it IS enabled. On the adapter I see the blinking lights and the indicator shows the connection to be active BUT my Firefox browser refuses to connect to any websites. What could possibly be the matter?

Thanks.

You do not of course test those things using an end-user application like Firefox. Go step by step.

Is the wifi device realy up and running:

/sbin/ifconfig -a

Do you have a route to the internet through your router:

netstat -rn

Can you connect to a computer on the Internet

ping -c1 130.57.66.6

Do you have DNS resolution:

host forums.opensuse.org

Do those test in the above sequence. When one test gives you a negative result, it is of no use to go for the next test. Report back here.

ping command failed with ping:bad number of packets to transmit

Please, this is not a good way to show what you get. Copy/paste the prompt, the command, the output and the nerxt prompt in one sweep beteen CODE tags in your post. You get the CODE tags by clicking on the # button in the tool bar.

And we like to see all of what you were asked for, from the beginning until you are stuck. We can not draw any conclusions from things we can not see!

Example: when I want to show what happens with netstat -rn

henk@boven:~> netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         10.0.0.138      0.0.0.0         UG        0 0          0 enp1s8
10.0.0.0        0.0.0.0         255.255.255.0   U         0 0          0 enp1s8
127.0.0.0       0.0.0.0         255.0.0.0       U         0 0          0 lo
henk@boven:~>

Please, over to you, at least the first three (ifconfig, netstat and ping).

Copy/paste the commands exactly as Henk gave them to you. (My guess is that you typed ‘cl’ instead of ‘c1’.)

Aye. I’m working from a windows machine at the moment and it makes things difficult to transfer across commands and then provide feedback from the Linux machine to you here. I’ll need instructions again about how to post these to the website for such purposes manually. Please bear with me as I proceed.

Now I see that with the c1 command, I get a unknown host response. I’ll wait for further instruction.

We realy need the output of the first two commands (and that of the ping command) as you get them. Because you gave no idea if you understood the output of the first two and thus we can only tell you what they say.

You can probably catch the ouput by writing it to an USB memory stick. Maybe it is easyer for you to first write it to some place in your home directory and then move them to an USB stick (with a file manager like Dokphin e.g.). To redirect the output:

/sbin/ifconfig -a >outputofifconfig 2>&1

and

netstat -rn >outputofnetstat 2>&1

Of course you can choose different names for the files, these strange names are only to give you an idea.
Move them to an USB stick, and it must be possible to read them on a MS Windows system (I hope, I do not know much of Windows :() and post from there.

… and where do you keep coming up with all these strange names, Henk???lol!

Well, let’s see what happens with the wireless connection disabled and the wired connection enabled. That is the only way for me to communicate from this Linux box now.

charles@linux-o5eg:~> /sbin/ifconfig -a
enp0s18   Link encap:Ethernet  HWaddr 00:0D:87:3D:2C:5C  
          inet addr:10.0.0.135  Bcast:10.0.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:18301 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12751 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:19821881 (18.9 Mb)  TX bytes:1683131 (1.6 Mb)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wlp0s8    Link encap:Ethernet  HWaddr 00:40:96:B2:58:25  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

charles@linux-o5eg:~> netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         10.0.0.1        0.0.0.0         UG        0 0          0 enp0s18
0.0.0.0         10.0.0.1        0.0.0.0         UG        0 0          0 enp0s18
10.0.0.0        0.0.0.0         255.255.255.0   U         0 0          0 enp0s18


That is nice output, but it hasn’t much to do with your problem imho. We need the same, but then when you try to use the wlp0s8 device.

On 03/05/2015 03:36 PM, chuckenheimer wrote:
>
> hcvv;2697945 Wrote:
>> You do not of course test those things using an end-user application
>> like Firefox. Go step by step.
>>
>> Is the wifi device realy up and running:
>>>
> Code:
> --------------------
> > > /sbin/ifconfig -a
> --------------------

Don’t forget:

Code:

cat /etc/resolv.conf

Ken

Henk,

I’m not sure this output will help considering that I have both the wired and the wireless connections active to be able to post these results, but here goes:

charles@linux-o5eg:~> /sbin/ifconfig -a
enp0s18   Link encap:Ethernet  HWaddr 00:0D:87:3D:2C:5C  
          inet addr:10.0.0.135  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: 2601:e:1780:def::f2af/128 Scope:Global
          inet6 addr: fe80::20d:87ff:fe3d:2c5c/64 Scope:Link
          inet6 addr: 2601:e:1780:def:20d:87ff:fe3d:2c5c/128 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:121706 errors:0 dropped:0 overruns:0 frame:0
          TX packets:81787 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:64464450 (61.4 Mb)  TX bytes:13078206 (12.4 Mb)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wlp0s8    Link encap:Ethernet  HWaddr 00:40:96:B2:58:25  
          inet addr:10.0.0.102  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::240:96ff:feb2:5825/64 Scope:Link
          inet6 addr: 2601:e:1780:def::6940/128 Scope:Global
          inet6 addr: 2601:e:1780:def:240:96ff:feb2:5825/128 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:653 errors:0 dropped:0 overruns:0 frame:0
          TX packets:80 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:84994 (83.0 Kb)  TX bytes:16989 (16.5 Kb)

charles@linux-o5eg:~> netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         10.0.0.1        0.0.0.0         UG        0 0          0 enp0s18
0.0.0.0         10.0.0.1        0.0.0.0         UG        0 0          0 enp0s18
10.0.0.0        0.0.0.0         255.255.255.0   U         0 0          0 enp0s18
10.0.0.0        0.0.0.0         255.255.255.0   U         0 0          0 wlp0s8
charles@linux-o5eg:~> ping -c1 130.57.66.6
PING 130.57.66.6 (130.57.66.6) 56(84) bytes of data.
64 bytes from 130.57.66.6: icmp_seq=1 ttl=52 time=80.8 ms                                                                                                   
                                                                                                                                                            
--- 130.57.66.6 ping statistics ---                                                                                                                         
1 packets transmitted, 1 received, 0% packet loss, time 0ms                                                                                                 
rtt min/avg/max/mdev = 80.894/80.894/80.894/0.000 ms                                                                                                        
charles@linux-o5eg:~> host forums.opensuse.org                                                                                                              
forums.opensuse.org has address 130.57.66.6                                                                                                                 
forums.opensuse.org has IPv6 address 2600:806:310::100                                                                                                      
forums.opensuse.org mail is handled by 42 mx2.suse.de.                  

I suspect that by having the wired connection active at the same time as the wireless one, the results are going to be skewed.

Ken,

charles@linux-o5eg:~> cat /etc/resolv.conf
### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
#     NETCONFIG_DNS_STATIC_SEARCHLIST
#     NETCONFIG_DNS_STATIC_SERVERS
#     NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
#     NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
search hsd1.tx.comcast.net
nameserver 75.75.76.76
nameserver 75.75.75.75


Here you go. Thanks!

Yes, it is a bit a mix now. But we can come to some conclusions (and a few questions).

Conclusions:
Ethernet Up and running with IP address 10.0.0.125 (and IPv6 addresses we will ignore for this case)…
Wifi UP and runningwith IP address 10.0.0.102.

Routing default goes through 10.0.0.1, but in this mixed case go through the cable.
There are two default router lines (that was already the case in youre “cable only” case, I do not understand why. Could be that DHCP asss the same at the start for both devices. But still strange. And do not forget that in the “cable only” case there were also two of them ???
I do miss the route for the local loop (also in the “cable only” case), should be something like:

127.0.0.0       0.0.0.0         255.0.0.0       U         0 0          0 lo

???

Ping to 130.57.66.6 is OK, but that is no wonder becaue ot goes all through the cable.

Host (DNS) works OK and the DNS servers are in your resolv.conf (btw a bit strange search domain there, but that is irrelevant here).

But this again does not tell us much about the Wifi only case. I think you now are used to using these commands enough to repeat them in the Wifi only case and to come to some conclusions yourself. So please repeat the route -rn, the ping, the host and check resolv. conf for yourself and report here if you see strange things.

(You could however copy/paste the output in a text file, then change to cable and copy/paste the contents of the text file into a post, it is not that difficult imho).

I’ve given up for now on trying to get this sorted. When I have a little more idle time, I’ll jump back in and request help on another thread. Thanks all!