Wireless configured fine - no internet connection via DHCP

Greeting,

I need your help desperate. I did brand new openSuse 11.1 install on my laptop with clean install My RTL8187 USB wireless card worked fine when I have 10.1 openSuse. So I used wrapperdisk for 10.1 only Surprising, 11.1 Suse detected my usb wireless card driver fine

NetworkManager detected my router hub via DHCP and show gateway, ip and dns correctly. The strength is 80% strong. Right click to see connection information

Gateway = 192.168.2.1
IP = 192.168.2.10
Primary DNS = 192.168.2.1
submask = 255.255.255.0
Driver = rtl8187
Interface wlan1 = 802.11 Wifi (wlan1)
Default route = 192.168.2.1

Here is information about lsusb, iwlist, ifconfig, nm-tool, route. Please help me.

lspci
Bus 006 Device 003: ID 0bda:8189 Realtek Semiconductor Corp. RTL8187B Wireless 802.11g 54Mbps Network Adapter
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

dmesg

usb 6-3: USB disconnect, address 2
b44: eth0: powering down PHY
input: b43-phy1 as /devices/virtual/input/input10
firmware: requesting b43/ucode5.fw
b43-phy1 ERROR: Firmware file “b43/ucode5.fw” not found
b43-phy1 ERROR: You must go to b43 - Linux Wireless and download the latest firmware (version 4).
input: b43-phy1 as /devices/virtual/input/input11
firmware: requesting b43/ucode5.fw
b43-phy1 ERROR: Firmware file “b43/ucode5.fw” not found
b43-phy1 ERROR: You must go to b43 - Linux Wireless and download the latest firmware (version 4).
usb 6-1: new high speed USB device using ehci_hcd and address 3
usb 6-1: configuration #1 chosen from 1 choice
rtl8187: 8187B chip detected. Support is EXPERIMENTAL, and could damage your
hardware, use at your own risk
phy2: Selected rate control algorithm ‘pid’
phy2: hwaddr 00:14:d1:36:df:97, RTL8187BvD V0 + rtl8225z2
usb 6-1: New USB device found, idVendor=0bda, idProduct=8189
usb 6-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 6-1: Product: RTL8187B_WLAN_Adapte
usb 6-1: Manufacturer: Manufacturer_Realtek
usb 6-1: SerialNumber: 00e04c000001
wlan1: authenticate with AP 00:22:a4:c0:f1:f9
wlan1: authenticated
wlan1: associate with AP 00:22:a4:c0:f1:f9
wlan1: RX AssocResp from 00:22:a4:c0:f1:f9 (capab=0x421 status=0 aid=2)
wlan1: associated

wlan1: authenticate with AP 00:22:a4:c0:f1:f9
wlan1: authenticate with AP 00:22:a4:c0:f1:f9
wlan1: authenticated
wlan1: associate with AP 00:22:a4:c0:f1:f9
wlan1: RX ReassocResp from 00:22:a4:c0:f1:f9 capab=0x421 status=0 aid=2
wlan1: associated

martian source 255.255.255.255 from 192.168.2.1, on dev wlan1
ll header: ff:ff:ff:ff:ff:ff:00:22:a4:c0:f1:f9:08:00
SFW2-INext-DROP-DEFLT IN=wlan1 OUT= MAC= SRC=192.168.2.10 DST=224.0.0.251 LEN=278 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=258
SFW2-INext-DROP-DEFLT IN=wlan1 OUT= MAC= SRC=192.168.2.10 DST=224.0.0.251 LEN=395 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=375
SFW2-INext-DROP-DEFLT IN=wlan1 OUT= MAC= SRC=192.168.2.10 DST=224.0.0.251 LEN=395 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=375
SFW2-INext-DROP-DEFLT IN=wlan1 OUT= MAC= SRC=192.168.2.10 DST=224.0.0.251 LEN=395 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=375
SFW2-INext-DROP-DEFLT IN=wlan1 OUT= MAC= SRC=192.168.2.10 DST=224.0.0.251 LEN=365 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=345
SFW2-INext-DROP-DEFLT IN=wlan1 OUT= MAC= SRC=192.168.2.10 DST=224.0.0.251 LEN=410 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=390
SFW2-INext-DROP-DEFLT IN=wlan1 OUT= MAC= SRC=192.168.2.10 DST=224.0.0.251 LEN=365 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=345

  • Device: wlan1 ----------------------------------------------------------------
    Type: 802.11 WiFi
    Driver: rtl8187
    State: connected
    Default: yes
    HW Address: 00:14:D1:36:DF:97

    Capabilities:
    Supported: yes
    Speed: 54 Mb/s

    Wireless Settings
    WEP Encryption: yes
    WPA Encryption: yes
    WPA2 Encryption: yes

    Wireless Access Points(* = Current AP)
    *JOENKYUNG: Infra, 00:22:A4:C0:F1:F9, Freq 2442 MHz, Rate 54 Mb/s, Strength 48
    linksys: Infra, 00:1D:7E:38:8F:AB, Freq 2432 MHz, Rate 54 Mb/s, Strength 24

    IPv4 Settings:
    Address: 192.168.2.10
    Prefix: 24 (255.255.255.0)
    Gateway: 192.168.2.1

    DNS: 192.168.2.1

%ifconfig
wlan1 Link encap:Ethernet HWaddr 00:14:D1:36:DF:97
inet addr:192.168.2.10 Bcast:192.168.2.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4680 errors:0 dropped:0 overruns:0 frame:0
TX packets:167 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:316820 (309.3 Kb) TX bytes:14658 (14.3 Kb)

%iwlist scan

wlan1 Scan completed :
Cell 01 - Address: 00:22:A4:C0:F1:F9
ESSID JOEJOEROUTER
Mode:Master
Channel:7
Frequency:2.442 GHz (Channel 7)
Quality=56/100 Signal level:-43 dBm
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=0000000000177181
Extra: Last beacon: 464ms ago

%iwconfig

wlan1 IEEE 802.11bg ESSID:“JOEJOERouter”
Mode:Managed Frequency:2.442 GHz Access Point: 00:22:A4:C0:F1:F9
Bit Rate=54 Mb/s Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:off
Power Management:off
Link Quality=64/100 Signal level:-39 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Thank to “Akoellh” I used your solution here:

At my wit’s end: Realtek 8187B, 11.1 - openSUSE Forums

This worked!!

Thank you

Just another question.

Why don’t you use your built in broadcom-card?

input: b43-phy1 as /devices/virtual/input/input10
firmware: requesting b43/ucode5.fw
b43-phy1 ERROR: Firmware file "b43/ucode5.fw" not found
b43-phy1 ERROR: You must go to b43 - Linux Wireless and download the latest firmware (version 4).
input: b43-phy1 as /devices/virtual/input/input11
firmware: requesting b43/ucode5.fw
b43-phy1 ERROR: Firmware file "b43/ucode5.fw" not found
b43-phy1 ERROR: You must go to b43 - Linux Wireless and download the latest firmware (version 4).

I am rather sure that it will give you better results than this USB-dongle.

You are just missing the b43-firmware


su -

install_bcm43xx_firmware

modprobe -rv b43

modprobe -v b43

You’re done.