Wireless cannot connect to acces point

hello,

I am a newbie and I need help with my wireless connection.

My wireless is a libertas 88w8335. Suse 11.4 just installed.

For this one, I need a windows driver with ndiswrapper.

ndiswrapper is installed, and the driver as well.

I can see my networks with iwlist scan
my network is set up in yast with ifup (I can scan the networks and find mine), but I cannot connect to my Acces point : there is no SSID with iwconfig.

need your help, please.

Show us the result of

/sbin/lspci -nnk

Just to be sure exactly what you have. It’s not a USB device is it?

On 07/27/2011 02:56 PM, fracte wrote:
>
> hello,
>
> I am a newbie and I need help with my wireless connection.
>
> My wireless is a libertas 88w8335. Suse 11.4 just installed.
>
> For this one, I need a windows driver with ndiswrapper.
>
> ndiswrapper is installed, and the driver as well.
>
> I can see my networks with iwlist scan
> my network is set up in yast with ifup (I can scan the networks and
> find mine), but I cannot connect to my Acces point : there is no SSID
> with iwconfig.
>
> need your help, please.

Did you get the encryption right? Check the file
/etc/sysconfig/network/ifcfg-wlan0. You will need to be root to access this file.

When you use ifup, there are a lot of things that need to be done.

If you are using WEP encryption, you will need the key, not a passphrase.

Thanks for your help,

First of all, I have no encryption for my network.

here are the logs :

1- when I load ndiswrapper :

linux-xd1b:~ # modprobe ndiswrapper
linux-xd1b:~ # rcnetwork restart
Shutting down network interfaces:
eth0 device: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
No configuration found for eth0
Nevertheless the interface will be shut down.
eth0 done
wlan0 device: Marvell Technology Group Ltd. 88w8335 [Libertas] 802.11b/g Wireless (rev 03)
wlan0 done
Shutting down service network . . . . . . . . . done
Hint: you may set mandatory devices in /etc/sysconfig/network/config
Setting up network interfaces:
eth0 device: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
No configuration found for eth0
eth0 unused
wlan0 device: Marvell Technology Group Ltd. 88w8335 [Libertas] 802.11b/g Wireless (rev 03)
wlan0 starting wpa_supplicant
Line 6: WPA-PSK accepted for key management, but no PSK configured.
Line 6: failed to parse network block.
Failed to read or parse configuration ‘/var/run/wpa_supplicant-wlan0.conf’.
wlan0 Starting DHCP4+DHCP6 client. . . . . . . .
wlan0 DHCP4 continues in background
wlan0 DHCP6 continues in background
wlan0 waiting
Setting up service network . . . . . . . . . . done
SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 …
SuSEfirewall2: using default zone ‘ext’ for interface eth0
SuSEfirewall2: Firewall rules successfully set

2- The lspci -nnk log :

linux-xd1b:~ # /sbin/lspci -nnk
00:00.0 Host bridge [0600]: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller [8086:29c0] (rev 10)
Subsystem: ASRock Incorporation Device [1849:29c0]
00:01.0 PCI bridge [0604]: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port [8086:29c1] (rev 10)
Kernel driver in use: pcieport
00:1b.0 Audio device [0403]: Intel Corporation N10/ICH 7 Family High Definition Audio Controller [8086:27d8] (rev 01)
Subsystem: ASRock Incorporation Device [1849:3662]
Kernel driver in use: HDA Intel
00:1c.0 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 1 [8086:27d0] (rev 01)
Kernel driver in use: pcieport
00:1c.1 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 2 [8086:27d2] (rev 01)
Kernel driver in use: pcieport
00:1d.0 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 [8086:27c8] (rev 01)
Subsystem: ASRock Incorporation Device [1849:27c8]
Kernel driver in use: uhci_hcd
00:1d.1 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 [8086:27c9] (rev 01)
Subsystem: ASRock Incorporation Device [1849:27c9]
Kernel driver in use: uhci_hcd
00:1d.2 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 [8086:27ca] (rev 01)
Subsystem: ASRock Incorporation Device [1849:27ca]
Kernel driver in use: uhci_hcd
00:1d.3 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 [8086:27cb] (rev 01)
Subsystem: ASRock Incorporation Device [1849:27cb]
Kernel driver in use: uhci_hcd
00:1d.7 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller [8086:27cc] (rev 01)
Subsystem: ASRock Incorporation Device [1849:27cc]
Kernel driver in use: ehci_hcd
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev e1)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge [8086:27b8] (rev 01)
Subsystem: ASRock Incorporation Device [1849:27b8]
00:1f.1 IDE interface [0101]: Intel Corporation 82801G (ICH7 Family) IDE Controller [8086:27df] (rev 01)
Subsystem: ASRock Incorporation Device [1849:27df]
Kernel driver in use: ata_piix
00:1f.2 IDE interface [0101]: Intel Corporation N10/ICH7 Family SATA IDE Controller [8086:27c0] (rev 01)
Subsystem: ASRock Incorporation Device [1849:27c0]
Kernel driver in use: ata_piix
00:1f.3 SMBus [0c05]: Intel Corporation N10/ICH 7 Family SMBus Controller [8086:27da] (rev 01)
Subsystem: ASRock Incorporation Device [1849:27da]
Kernel driver in use: i801_smbus
01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 02)
Subsystem: ASRock Incorporation Motherboard (one of many) [1849:8168]
Kernel driver in use: r8169
04:01.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88w8335 [Libertas] 802.11b/g Wireless [11ab:1faa] (rev 03)
Subsystem: Marvell Technology Group Ltd. 88w8335 [Libertas] 802.11b/g Wireless [11ab:1faa]
Kernel driver in use: ndiswrapper
05:00.0 VGA compatible controller [0300]: nVidia Corporation NV44 [GeForce 7100 GS] [10de:016a] (rev a1)
Subsystem: Micro-Star International Co., Ltd. Device [1462:0273]
Kernel driver in use: nouveau

note : The dmesg log tells me :

ADDRCONF (NETDEV_UP) : wlan0 : link is not ready

On 07/27/2011 04:46 PM, fracte wrote:
>
> note : The dmesg log tells me :
>
> ADDRCONF (NETDEV_UP) : wlan0 : link is not ready

Have you done the “ifup” command?

I have done the ifup command but it does not works.

I have found a way to make it work by setting my ssid by hand :

iwconfig wlan0 essid MyAP

But now I have to find a way to make it works at boot time…

On 07/27/2011 05:46 PM, fracte wrote:
>
> I have done the ifup command but it does not works.
>
> I have found a way to make it work by setting my ssid by hand :
>
> iwconfig wlan0 essid MyAP
>
>
> But now I have to find a way to make it works at boot time…

If you need to do that, your ifcfg-wlan0 is wrong.

Ok, all is working well…

I have put “ndiswrapper” in the Yast module name to load it at startup,

and by setting the mode to "“master” instead of “managed”, it connects to my network. All at startup!

thanks for your help.