Wireless almost within reach.. a little help, please? :0)

I’ve just yesterday installed openSuse 11.1 and I have been trying to get it online. I’ve read the stickies in this subforum and executed most of the advice they give.

There are two parts of my getting online (as described in the quotes below). First I have to connect to my router and then I have to connect to a pppoe broadband connection. I have already succeeded in connecting to the internet by connecting to my modem through wired ethernet. The problem now is connecting to my router wirelessly.

Some info on the ISP’s instructions:

I have a wireless DSL router/modem (Siemens Gigaset SX763 WLAN dsl). My ISP has instructed me to connect through some king of bridged pppoe connection. In Windows I do this by setting up my wireless connection to the router, and then by creating a broadband connection with my username and password. Then, when i turn on my computer it connects automatically to my wireless router, but to get on the internet I have to click “Connect” on my broadband/dialup connection.

Btw, I’ve kind of given up on KNetworkManager and am trying to do everything through YaST using the “traditional ifup” setting.

I will just give you some information according to one of the stickies’ (Getting Your Wireless to Work - openSUSE Forums) requests:

Section II. "What device do you have?"
I found an entry named “Wireless LAN” and the value in its “Kernel driver” line is “ssb”.

Section III. "Do you need to install external firmware?"
I found a lot of lines with some kind of problem with the wireless card firmware by executing “dmesg | grep firmware”. I followed the link in those lines (b43 - Linux Wireless), identified my wlan card to be a Broadcom BCM4311 (14e4:4311 rev 1) and installed the firmware by executing “sudo /usr/sbin/install_bcm43xx_firmware” (taken from b43 - Linux Wireless).
Executing “dmesg | grep firmware” now results in these lines:

firmware: requesting b43/ucode5.fw
firmware: requesting b43/pcm5.fw
firmware: requesting b43/b0g0initvals5.fw
firmware: requesting b43/b0g0bsinitvals5.fw
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)

Section IV. "Making a connection"
When I execute “sudo /usr/sbin/iwlist scan” I get “Interface doesn’t support scanning” for lo, eth0, wmaster0 and pan0, but, for wlan0 I get information about six cells. The info on my cell, “hvth”, is:

wlan0 Scan completed :
Cell 01 - Address: 00:01:E3:81:F9:70
Frequency:2.417 GHz (Channel 2)
Quality=93/100 Signal level:-41 dBm
Encryption key:on
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra: Last beacon: 56ms ago

Section VI. "Association and authentication"
Running “/usr/sbin/iwconfig” gives me these lines:

wlan0 IEEE 802.11bg ESSID:"hvth"
Mode:Managed Frequency:2.417 GHz Access Point: 00:01:E3:81:F9:70
Bit Rate=54 Mb/s Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Power Management:off
Link Quality=98/100 Signal level:-36 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Section VII. "Testing"
Executing “/sbin/ifconfig” returns this:

wlan0 Link encap:Ethernet HWaddr 00:16:CF:CB:53:86
inet addr: Bcast: Mask:
RX packets:38355 errors:0 dropped:0 overruns:0 frame:0
TX packets:351 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2690626 (2.5 Mb) TX bytes:64879 (63.3 Kb)

When I try to ping my router with “ping -c 5” I get “Destination Host Unreachable”.

Can someone please help me? Thanks.

Hmm, possibly not associated ? when using ifup, did you fill in the details in YaST - network devices - network settings ?


Thanks for your reply.

Well, yes, i put in all the information about my wireless connection. I might have made a mistake somewhere.
Should I put a tick on "Enable IPv6?
And on “Request Broadcast Response”?
The Firewall Zone is set to External Zone.
“Enable device control for non-root user via internet” is on.
Address is set to Dynamic address with DHCP, DHCP both version 4 and 6.

Operating mode is set to “Managed”.
Network name is set to my router’s SSID.
Authentication mode is set to wpa-psk. Actually my router uses WPA2 personal and not just wpa, but that’s not offered there in the drop-down list.
Key input type is set to “Passphrase” and in the expert settings the Bit rate is set to “Auto”, and power management is ON.

How can I see if I am connected to my wireless router? There isn’t an icon anywhere… Do I have to click something to connect wirelessly to my router?


I’ve succeeded in connecting.
I actually went back to KNetworkManager, set up the connection to my wireless router, connected onto it. And I also had to create a new DSL connection (one using my wireless card) in YaST so KInternet could Dial-In via wireless. Everything working so far :smiley: