Wireless Adapter Not Working In Installer

I tried installing opensuse 13.2, but no matter how many times I reconfigure the wireless connection in the installer, I just could not get it to work. Networking is fine when I install opensuse in a virtual machine using a NAT connection. However, if I bypass the network config and proceed to the install without adding repositories, wireless connection works when I get to the desktop.

I’m not quite sure whether this is a soapbox thread, a query for help or what.

There’s really no need to have a network connection during the installer because you won’t install the updates until the end of it anyway.

But I cannot add the online repositories with networking disabled. I’m not really used to using opensuse so I really have no idea.

That’s no problem - you can add them all later on via YAST -> Software -> Repositories -> Add -> Community Repositories.

You won’t lose anything if you don’t have a network connection during the installation apart from being able to update packages before first boot. It’ll save you one reboot, not much more.

I see. One more thing, when I tried running zypper update, it says it could not find the update servers. I then launch Firefox but I can browse the Internet without problems.

Please post a copy paste of the zypper output here, use code tags to wrap the output ( # in the toolbar )

Like this!

Also while you’re at it, also post the output of: zypper lr -d

I’m not a big expert here, but I think the reason why no wireless for the installer is simple they’re keeping the installer’s kernel as light as possible for both size and speed, it might even be an older kernel.
In general depends on the hardware but if you need a wireless network you can use the live iso’s for install.

Sadly, http://software.opensuse.org/132/en only has DVD.

Click on “Some alternative media (eg. live and rescue systems) are also available, although they are less tested and recommended for only limited use. Click here to display these alternative versions.” to reveal the 1GB ‘Live’ versions.

and you can even get them via torrent, as the speeds today seam to be a bit off
get the full list here

I want to use the Xfce edition. Alternative media only has KDE and Gnome.