Wireless "active" but no network? (fresh install)

I’ve heard great things about OpenSuse KDE, but I’m not feeling it. Not at all.

1.) I can “activate” the wireless network, but I can’t connect. (It worked with the OpenSuse KDE live CD and it works with Ubuntu and Gnome OpenSuse.) I’ve been googling for solutions but I’m getting the impression that this is a known bug? Is there a straightforward solution to this? - besides installing Mint KDE?

2.) When I click on KDE Wallet manager, nothing happens. Having to put in a password each time I want to connect to my home network is a pain in the rear-end. I’d like to disable KWallet but can’t seem to access it?

No help?

Well… I solved it myself.

1.) Right click on Network Icon (Panel)
2.) Choose Manage Connections
3.) Choose Wireless Tab - Then choose relevant Wireless Connection.
4.) Highlight and choose Edit
5.) Choose IP Address Tab
6.) Bottom Right - Choose “Routes” in drop down.
7.) If enabled, then disable “Use only for resources on this connection”.
8.) Apply & Exit.

Then try to reconnect.

This worked for me. It may not work for you. This was using OpenSuse 11.2 with KDE.

Using “Intel Corporation PRO/Wireless 3945ABG”