Wired router, want to transfer files between local computers

Hello List, Moderators,

Should I be able to transfer files between computers wired to the same router?

Is the router bridging function used to transfer data between wired computers?

I just got DSL and I’m new to networking. I have openSuse 11.4 on two computers plugged into a Belkin router. The internet connection to my ISP works from either computer.

If I ping $HOSTNAME from either computer, the hostnames are different, but the IP address is the same which is that of my ISP.

I only have the one router, but it has a bridging option. I don’t know if it can do both bridging and routing simultaneously.

If this post fits the charter here, I would appreciate some guidance on this subject.

As $HOSTAME gives you the name of the system where you execute the command, the result is that you ping to the system itself. That is on systemA you in fact say:

ping systemA

which is probably not what you wat.
On systemA you want to try if you have connection to systemB by doing

ping systemB

When you want to know which IP addresses both systems have, then do

/sbin/ifconfig -a

on each of the systems.

And it is normal that systems can communicate when they are on the same LAN (as your systems seem to be). File transfer can be done then in a myriad of ways.

In a box like that, normally the Ethernet ports are all on the same LAN segment, no different from a switch. The router function only refers to between the Internet and the LAN. If you put it into bridging mode (which you normally wouldn’t) this is between the Internet and one device on the LAN side. So even if the router were unplugged from the phone line, the computers would still be able to communicate with each other. You will normally see that they get addresses in same subnet, e.g. and .3. The computers can then communicate in a number of ways as hcvv said. The traffic doesn’t go through the router function of the hardware; it’s as if they were connected to the same Ethernet switch.

Thanks ken_yap, hew!

Running ifconfig -a on each machine does show it’s IP address assigned by the router. I can ping either address IP address from either computer.

Also I can ping systemB from systemA and viceversa. The ping of systemB from systemA still shows only the ISPs address.

Now that I have the unique IP address of each computer, I will experiment with methods to transfer files. The remote copy (rcp) is gone, but I understand it’s been replace by ssh. Alternately I can set up an ftp server on one machine.


Hello again! I’m replying to myself in hopes of getting some help with a port question.

Ssh looks to be the simplest approach to copy between local machines. It looks to me like the openSuse 11.4 DVD installer loaded the ssh server on both machines. Yast2 doesn’t show any ssh server packages that aren’t installed.

My problem is now with port 22. Do I need to enable this in the router, the firewall, or in some config file?

Running ssh on this computer’s IP address I get this:
ssh: connect to host port 22: Connection refused

Using instead localhost I get this:
ssh localhost
ssh: connect to host localhost port 22: Network is unreachable

Running ssh on the other local computer’s IP address hangs, and viseversa. I’ve tried both as myself and as root. I have an account with the same account name on each computer.

Since the scope of my copying is just these two local machines, it may be more secure to the outside world to use a different port than 22.

If I’m right about that, what would be a good alternative port to use, and what and where is required to open that port? Heboland

It’s nothing to do with the Ethernet switch. Check your firewall settings on the machines, that you have allowed ssh.

@heboland: If you’re using a graphical desktop like Gnome or KDE, why don’t you try using a file manager with ‘sftp://’

sftp://<ip address>/<path>

Dolphin or konqueror (KDE), or Nautilus (Gnome) all have this capability.

Some simple guides for you

Secure File Transfer in Nautilus with SFTP | Tux Tweaks

Concepts networking - openSUSE

Thanks again deano_ferrari, ken_yap,

Deano, yes I have kde/dolphin on one computer and lxde on the other. Both have browsers with networking features. your suggestion is excellent, but I can’t get the beans out of the can!

All three of the dolphin networking icons are empty. I tried adding a network folder which brings up a menu of blanks to be filled in. Here I chose ssh out of four choices. I used the IP address of the other computer as the server. The result is “Unable to connect to the server”

So maybe the default ssh 11.4 installation didn’t install an ssh server. Both of my boxes may be ssh clients only. How would I know if an ssh server was installed?

Setting the ssh port in the firewall is another overwhelming experience. I added ssh service. The advanced button has port settings: TCP, UPC, RPC, and IP Procols. Wow!

So I tried setting a TCP port, the same one on each box. No change in ssh behavior!

The ssh firewall service is allowed, but it doesn’t put a service into the Network Services icon in the Dolphin Network choices. Possibly the magic for this choice is in the yast network services menu.

There’s nothing in that menu I recognize like smb or ssh. Maybe that’s because I don’t actually have an ssh server installed. These choices look like daemons related to networking. There’s a couple dozen to choose from.

It wouldn’t take a guru setting in this seat very long to get all these toys working, but I think the gap is too large for me to get this working on this forum.

Let me snipe away at this at my leisure. Installing an ftp server may shed more light on the subject. At least I’ll know I have a server installed.

Meanwhile there is the “sneaker net”. If that term isn’t in the common vernacular, it’s using tennis shoes to move a thumb drive back and forth between computers!


Go into YaST and check that the ssh server is running. If not start it, and set it to start at boot.

Exdactly the OP never told he started sshd.
Go to YaST > System > System services (runlevel) look for sshd and switch it on. YaST will not only do it, but also configure it to be started on boot (and also configure the Firewall IIRC).

Another Thanks to you guys!

I’m able to transfer files now, but I have a few questions I would appreciate answers to, if they are of general interest.

Yes, the sshd needed to be started on each box. Starting it at boot using “expert” caused the network daemon to be started at boot as a dependency.

After rebooting I looked at sshd in the “simple” display. The simple sshd status showed as no*. Expert showed it running. Before I got an ssh connection, I added levels 2,3, and 5, but these may not be necessary.

Before I used yast to start sshd, I removed the ssh service from the firewall settings to see if yast would enable that. Nothing happened, so I manually readded the allowed firewall ssh service. This time I didn’t add any ports.

Ssh is now using port 22, but I don’t see that open port showing up anywhere. A question related to port visibility, is where would this port 22 status show up?

Another question I have at this stage relates to the firewall setting. What does this do? “Protect firewall from internal zone?” It has a checkbox on ssh Allowed Service. This was not enabled by default, but ssh works with the box checked.

So for the file transfer status, I can run ssh from either box, but neither hostname is recognized. So far ssh only works with the IP address. So another question is how and where to enter these hostnames to be recognized?

The IP addresses are not trusted. Originally A dunning comment essentially asked if I wanted to proceed, because ssh didn’t. When I typed out the full work “yes” it connected.

A qusetion here is how to make the host trusted? There are a number of files related to the ssh, several of which are key files. I’m expecting something has to be added to one or some of these files.

Maybe typing yes to the untrusted prompt makes an addition to one or same of these files.

The LXDE file manager doesn’t yet see the other host. It’s networking seems to be geared toward samba. That’s not a big deal as ssh works on it now. Also scp works on the LXDE box, but so far, only from the ssshell.

Another question I have is should scp work from a terminal? My expectation is that it should if the ssh setup is in place.

Dolphin on the KDE box works easily, but if using the hostname rather than IP, it also gives the response “Unable to connect to server. Please check your settings and try again.”

One problem with having to use IP addresses to connect is that the router assigns these addresses in the order the computers are power up. That makes them dynamic in the last digit.

I can live with this, but getting the connections to work with hostnames would be a bonus.

Other than these lingering details, this thread is solved. I’ll wait to see if I get some suggestions regarding the lingering details before I report it solved.

I will not answer all your questions above (others must also have their day filled with some usefull things :slight_smile: ), but I am getting the idea that you are using network manager on at least one of those systems. Is that correct (IIRC you did not mention that before)? When yes, there will be some problems because sshd is normaly started after the network is up. Which is of course allways the case in a normal environment. But when using network manager, the network is not started at boot, but only when a user logs in, which can be two days later.:wink: . I do not know how then the starting of all sorts of network services/deamons is done. I do not use network manager.

I don’t think that’s true for a wired connection. At least with 11.4, there is a predefined system-wide connection “Auto eth0” which is started by the main NetworkManager daemon, and does not depend on a user being logged in. If using gnome3, then the name is something else but the connection is still started before any user logs in.

With WiFi it is different. If the connection is defined by a user, it is only started when that user is logged in. Even there, if using the gnome nm-applet, if the connection is set to be shared with other users (requires a root password), then it becomes a system wide connection that is established before any user logs in.

All very bewildering and I guess it is very difficult then to know exactly what happens for all the combinations of boot only/one or more loged in users, cable inserted/removed, users using KDE/other users using Gnome/other users using …, wifi point found/not found, etc. Does one then ever know if the SSH deamon is functioning?

hcvv wrote:
> nrickert;2350154 Wrote:
>> With WiFi it is different. If the connection is defined by a user, it
>> is only started when that user is logged in. Even there, if using the
>> gnome nm-applet, if the connection is set to be shared with other users
>> (requires a root password), then it becomes a system wide connection
>> that is established before any user logs in.
> All very bewildering and I guess it is very difficult then to know
> exactly what happens for all the combinations of boot only/one or more
> loged in users, cable inserted/removed, users using KDE/other users
> using Gnome/other users using …, wifi point found/not found, etc. Does
> one then ever know if the SSH deamon is functioning?

Sounds like that might be a case for inetd to start sshd

In any case he OP say he has wired connections. Thus he shouldn’t use networkmanager at all imho. And that would make everything work as intended since the conception of the boot startup sequence with init/init.d/rc.? ages ago.

My desktop (from which I am posting this) has a wired connection. Last week, I switched it to NetworkManager, mostly to see how reliable that is.

With “ifup”, it was completely reliable from install of 11.4 till I switched (and from 2007 with earlier versions).

Thus far, it has been fine with NetworkManager. I guess the real test will come when I reboot my router - will NetworkManager stay connected, or will I lose the connection.

On a slightly different point; I have a usb Wireless adapter, which I only rarely use.

My recollection is that when I first connected the usb adapter, the firewall settings did not recognize the interface. Right now, the firewall settings do recognize the interface, even though the adapter is not plugged in. It is my guess that the firewall settings might be relying on the “ifup” files to decide what interfaces to configure. So it is probably easier to configure the firewall if you are using “ifup”.

On running sshd - It seems to be running by default on systems that I installed from the 32 bit KDE live CD. It seems to have not been running until configured on systems installed from the 64bit NET CD.

I fail to see how you can test the reliability of a networkmanagemer in an environment where there is no need for it: no dynamic switching from cable to Wifi (which btw can be “reliabl” done with “ifup”), no using of different Wifi access points.

IIRC the running/not running of SSH deamon direct from install is offered from the install window where it offers you several things to choose from (there is also a partition offering and a software to install offering and more). I do not know what the default is on that window, but I doubt if taht default is different on 32 and 64 bits systems.

And about the firewall in openSUSE. I do not use it, but I can understand that with a dynamicaly added network interface, the firewall does not know if this is to be handled as an interface to the external or the internal network. Thus it needs human intervention.

hcvv wrote:
> I do not know what the default is on that window, but I doubt if taht
> default is different on 32 and 64 bits systems.

No, but it might be different between a Live CD and a Net CD

My laptop, when at office with a wired connection, would sometimes lose the connection. It claimed to be connected, but couldn’t ping anything. That was with NetworkManager. It might have been a failing router, or it might have been a limitation of NetworkManager. This was running 11.3/KDE 4.4, as I recall. It had worked fine in the same situation with opensuse 11.0, and gnome.

I’m wanting to see if that kind of unreliability occurs. If it does, I will then try the gnome network manager applet to see if that is any better. However, with the current plasmoid applet and KDE, I already see a button I can use to disconnect. So my guess is that if I disconnect and reconnect, that would fix any problems (if problems arise).

Back with that laptop on 11.3, I had to restart the network to restore the connection. However, if WiFi failed in the same way, it was sufficient to disable WiFi, then re-enable it.

Back to the desktop. When on ifup, if I reboot my router, it logs a message about cable disconnected. But, once the router comes up it continues as if there was no interruption. I don’t think it even makes a new DHCP request - it just continues with its existing lease. I want to see what happens under similar circumstances when running under NetworkManager.

I don’t recall seeing that SSH option during install. I wasn’t intending to suggest a 32bit vs. 64bit difference. Rather, I was suggesting a live CD install vs. other method of install difference.

Yes, that was the problem that I was hinting at. The firewall treats it as “other”. But if you are using “ifup”, you can assign the interface to external or internal, and the assignment then seems to stick. I think (but I’m not sure) that it’s the existence of the “ifup” definition file for the interfaces that allows it to be assigned in the firewall.