Wired PC to Router with WiFi on to a WiFi printer

I can’t find much information on doing this sort of thing where the router is being used as an access point to the wifi network for PC’s that are wired to it. Any clues might help.

While playing around a cups printer search now finds 2 addresses for my printer, the one I currently use via a wire to both the router and from the router to the printer and this one


I guess this may be an IPV6 address to it but expected 4 4 digit hex decimal fields.


It’s IPv6 so 6 hexes, separated by a " : ".

Wireless or wired is not what the router is interested in, it’s just serving available IP addresses. Re. the printer: you should be able to configure it as a networkprinter. The system doesn’t care whether that’s wireless or wired, as long as it can be found.
BTW, what printer?

Samsung CLX-3185FW. It was on offer as being superseded when I bought it. The scanning software also finds the 2 addresses. rotfl!I’d guess if I can find yet another that has to be wifi.

:’(Finding it sounds like I will have to spend some time getting into router jargon - again. Not my favourite subject. The printer is running in adhoc mode so that others can use it directly via wifi


You’re not very clear to me. Are the “2 addresses” IPv4 and IPv6? That’s normal. Use the address you use on other machines.

Start Yast - Hardware - Printer - Assistant - TCP port. Fill out the IP address of the printer, select Samsung as the manufacturer.

Yes the 2 addresses are 4 and 6. I have no problems printing from my machine with wire to the router and from the router to the printer.

The router and printer both offer the press a button option to set up wifi. When I do that nothing happens so I suspect that there is something further amiss with the router settings. Allowing the “button” to function is an option on the router - I have set that. On the other hand it’s not clear that the router can be used as an access point in this particular way. D-Link don’t provide a wizard on this model.

Looking at the Samsung wifi set up it can detect my wifi network and offers me WPA2-Personal,Open System,Shared Key or WPA-Personal for authentication. Then TKIP+AES or AES for encryption. It also asks for a network key, Where as the settings for the router wifi is WAPA+WAP2 for security and TKIP+CCMP for encryption and PSK for authentication.

The samsung set up has a wizard that detects my wifi and seems to be happy with it but asks for a WPA shared key. I assume that is the password but when I look at wifi clients on the router there aren’t any. If I use the router to connect using the PIN in the printer it shows connected but doesn’t seem to be.


I have it working now. Cups shows the same connection socket as it did wired.

At the moment I have set a 2nd access point in the router using WEP 128bit encryption that has open.authentication. Not too happy about that. Also the router wont allow WEP in mixed n and g mode so had to set g as my son’s ipad wouldn’t connect in n only.

Some of the more secure settings I tried may have worked. The problem was at the Samsung end. After setting up it shows that the wifi is not connected. For instance when set up via a wired connection this has to be pulled out and the wifi status refreshed. It will show connected then if all is ok.

:’( I assume if I change the wifi setting while in this WEP mode and then change the router settings it will connect again - I hope. Or back to wire. Could be quicker.


Turns out that the 1st method I tried worked. Samsung’s connection wizard even suggested it and proposed protocols. Just the normal default access point along with it’s secure policy. The key Samsung’s software asks for is just the normal network password.

:’(5hr’s on and off messing about because the wifi status display from the printer needed refreshing to show it’s actual state rather than disconnected.

Biggest question now is where to move the printer to. rotfl!That is rather difficult.