wired internet off

Hi there.
I am using a PC doing dual boot with opensuse leap 15 and windows 10.

Yesterday my internet was ok as usual.
Today it is just not working anymore. The only thing a did different was using the Virtualbox to try another operating system. That should not be a problem at all.
I am using wired internet ant it works fine on windows. The problem is onli at opensuse.

Any ideas.

You check from bottom to top:

  1. Is the NIC up with an IP address?
ip addr
  1. Can you connect to another system on your LAN?
ping -c1 <IP-address of your router>

(I hope you know that address)

  1. Do you have a default route to the Internet?
ip route
  1. Can you connect to a system on the internet?
ping -c1
  1. Can you resolve host/domain names?
ping -c1 forums.opensuse.org

Take care. As soon a one step fails, that must be resolved first. It is useless to go to the next step before it is resolved.

So start with 1. and do not hesitate to post the output here to get help on the interpretation.


Is the NIC up with an IP address?Code:

ip addr

davi@linux-43sn:~> ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue stateUNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdiscpfifo_fast state UP group default qlen 1000
    link/ether 40:8d:5c:7e:b5:8f brd ff:ff:ff:ff:ff:ff
    inet brd scope globalnoprefixroute dynamic eth0
       valid_lft 41901sec preferred_lft 41901sec
    inet6 2804:7f5:728d:f78c:70ef:cf4c:f842:2a64/64 scope globaltemporary dynamic 
       valid_lft 43193sec preferred_lft 43193sec
    inet6 2804:7f5:728d:f78c:2cb1:387f:9fa5:4163/64 scope globalmngtmpaddr noprefixroute dynamic 
       valid_lft 43193sec preferred_lft 43193sec
    inet6 fe80::9236:cbde:937a:b4ec/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

I got this so far and I don’t know what it means.
I am trying to figure our the ip address of my router.


Look I will reinstall it and keep the /home.
It might get conflicted between gnome and kde internet managers. I sounds weird I know.
Thanks anyway.

In short it means eth0 has an IP address and netmask (and also IPv6 addresses).
Thus that looks fine.

When you do not know the IP address of your router (you should, is that a home LAN?), you can go for the

ip route

Reinstalling is not a solution. Since it did work, and your eth0 has received an IP through DHCP from the router, I’d say /etc/resolv.conf is somehow incorrect.
Open a terminal window and do

sudo rm /etc/resolv.conf && sudo rcnetwork restart

This will remove resolv.conf, restart networking which will generate a new resolv.conf with proper DNS’s it gets from your router.

Well, that is not what I call searching where the problem is as I tried to do with you until now.

That is just giving up and doing something that may not even repair things. Like dumping your car and buying a new one because the screen wipers do not function.

You two were right.
the ‘resolv.conf and rcnetwork restart’ finished the job.

Thanks on the inspiration on not giving up.

I wonder why that happened.


That is a known Issue and if you have shown the output of the commands in Post #2 fromm hcvv, your problem has been solved earlier…

Thanks for reporting back. Glad it’s working now.
FWIW: This issue seems to be happening more often on dual boot machines, after the machine is rebooted from a Windows session into a linux session. But that is personal experience. I suspect Windows does something to the firmware loaded on the networking device, but I have no proof here ( no Windows since 2001/2002 ). A friend reports that it does not happen on a complete shutdown from Windows, then boot openSUSE, but it does occur occasionally on reboots from Windows to openSUSE or Mint.