wired connection very slow

my wired connection seems could connect but is really sloooooooooow.
googled quite some threads but could not find a solution. e.g. ipv6 already disabled. I am using network manager.
my network card is here
View image: network card

I am using a router. do I need to input default gateway, subnet mask elsewhere? tks

Did you disable ipv6 in browser too ?

Nope, the networkmanager should use DHCP. But, you could test things by creating a static wired connection, giving your machine a valid IP, use the router’s IP as gateway and google’s DNS’s, and see how things work then.

tried both

  1. firefox about:config disable ipv6
  2. change wired connection from dhcp(automatic) to manual and input ip, gateway, subnet mask, dns.
  3. rebboot
    speedtest.net worked fine then.

reverse both

  1. firefox disable ipv6 back to no
  2. wired connection back to dhcp (automatic)
  3. reboot
    surprisingly the wired connection still works fine.

happy with that, though remain puzzled.

Wired or Wireless?
Now I’m confused?

Check your settings to be like this

referring to wired.
tried “both” means “both” suggestions (a) browser disable ipv6 (b) manual connection inputting details.

my network setting doesnt have “change hostname via dhcp”, “assign hotname to loopback ip” checked.

Noticed according to your signature you may be dual-booting between Win and openSUSE.

Recommend you change your MAC address for one of your OS, is easy to do if you’re using NM, in your Connection Properties change the “Cloned MAC Address” value.

Depending on your network security, you would then appear properly different when you’re running one or the other OS.


So did you try it with them checked?

You don’t say which aspect is slow - data transfer or say connecting to a local server. My router also takes rather a long time to log onto the isp but that is probably down to my set up. A ppoe over ethernet router with another box to convert from adsl.

On IPV6. Yesterday I found that my router seems to handle it as my isp doesn’t. So switched to ipv4 only. I also use a free dns service and gave up on using google dns some time ago. Often too slow as is my isp’s.


If you believe you have DNS resolution problems, before changing your DNS servers you should first clear your local DNS cache.

For testing DNS resolution (your network might not be slow, just the name resolution translating to IP addresses), run nslookup followed by a random known good and often used FQDN on the Internet. You can also test less well known destination names, but if the resolution doesn’t exist in the DNS you’re querying then it might take time for a resolution to be found further upstream.


> www.google.com

If the result takes more than a few seconds to resolve Google (a well known and often used destination), then consider clearing your cache, then if that doesn’t improve things, you can then change DNS.

This Forums thread describes various methods to stop/restart the nscd which effectively clears the cache