Wired connection no more working after system update

Hi, I recently did some update to my system Tumbleweed and after reboot my wired connection was gone. When I click on the NetworkManager icon only my wireless connection is listed (and also my two vpn). If I edit the network connections, the wired ethernet connection is there and I can create also a new one but they never shows up in the NM panel.
Inspecting the interfaces with ip command, I get this:

>ip addr show

[FONT=courier new]2: **enp2s0: **<NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state **DOWN **group default qlen 1000
link/ether 20:89:84:2c:7a:c2 brd ff:ff:ff:ff:ff:ff
I tried also adding a new ip address with:

>[FONT=courier new]ip addr add dev enp2s0

and this makes a new wired connection is displayed and Activated in the NetworkManager as I see in the logs:

NetworkManager[757]: <info> [1604222681.8557] device (enp2s0): Activation: successful, device activated.

but the traffic is always zero because the interfaces status is DOWN:

2: **enp2s0: **<NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state **DOWN **group default qlen 1000
link/ether 20:89:84:2c:7a:c2 brd ff:ff:ff:ff:ff:ff
inet scope global enp2s0
valid_lft forever preferred_lft forever

and using ip link up command has no effect.

Is there anybody can give me an hint to make my wired ethernet connection working back again?
Thanks in advance,


Hello and welcome to the opnSUSE forums.

Maybe we should check some things first. You say you “did some update”. Can you explain what that was. Remember that the only way to update a Tumbleweed installation is using

zypper dup

I see you tried to post the computer text by using a fixed font. That is a good idea, but we have something better.
There is an important, but not easy to find feature on the forums.

Please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

An example is here: Using CODE tags Around your paste.


“NO-CARRIER” means physical or driver issue, upload full dmesg output to https://susepaste.org/ and post link here.

Hi, I forgot to mention that I am not really a new user. I am using a brand new user account because my real one (marco.azzalini) simply do not login anymore into the forum (I don’t know why) so I had to register a new one just to post my problem.
Anyway, I wrote ‘some updates’ meaning I issued some ‘zypper refresh/zypper dup’ commands during the past 4/5 days while I was trying to fix the wired connection problem and new updates were arriving
I don’t like very much the CODE tags to wrap commands (mainly because it waste lots of space) but I will use it and follow your suggestions in the future.


That’s because you missed the migration date for old accounts… :wink: We switched to the new login system in June of this year…

Thanks for your help.
Unfortunately susepaste.org give me “404 - page not found” error when I push the create button. Do I need to be logged in to use it?

Anyway, this is an extract of lines containg r8169 if it can help

[FONT=monospace]**lnx-marco:/home/marco #** dmesg | grep r8169

[/FONT]   31.841606] r8169 0000:02:00.0: can't disable ASPM; OS doesn't have ASPM control
   31.844761] libphy: r8169: probed
   31.845155] r8169 0000:02:00.0 eth0: RTL8105e, 20:89:84:2c:7a:c2, XID 40c, IRQ 31
   32.186833] r8169 0000:02:00.0 enp2s0: renamed from eth0
   33.632381] Modules linked in: uvcvideo(+) btrtl iTCO_wdt videobuf2_vmalloc videobuf2_memops ath9k videobuf2_v4l2 videobuf2_common ath9k_common videodev ath9k_hw ath mac80211 btbcm snd_hda_codec_hdmi snd_hda_codec_realtek btintel mc bluetooth rtsx_usb_ms cfg80211 memstick intel_rapl_msr intel_rapl_common snd_hda_codec_generic intel_pmc_bxt ecdh_generic ecc libarc4 x86_pkg_temp_thermal iTCO_vendor_support intel_powerclamp ledtrig_audio coretemp snd_hda_intel r8169 mei_hdcp snd_intel_dspcfg at24 snd_hda_codec kvm_intel snd_hda_core realtek kvm mdio_devres ideapad_laptop snd_hwdep snd_pcm sparse_keymap rfkill libphy snd_timer wmi snd thermal irqbypass soundcore i2c_i801 mei_me mei pcspkr lpc_ich tiny_power_button ac efi_pstore i2c_smbus joydev nls_iso8859_1 nls_cp437 vfat fat fuse bbswitch(O) rtsx_usb_sdmmc mmc_core rtsx_usb hid_generic usbhid i915 i2c_algo_bit drm_kms_helper crct10dif_pclmul crc32_pclmul crc32c_intel ghash_clmulni_intel ehci_pci syscopyarea sysfillrect aesni_intel xhci_pci
   44.642584] RTL8208 Fast Ethernet r8169-200:00: attached PHY driver [RTL8208 Fast Ethernet] (mii_bus:phy_addr=r8169-200:00, irq=IGNORE)
   44.949894] r8169 0000:02:00.0 enp2s0: Link is Down
 2845.475829] r8169 0000:02:00.0 enp2s0: Link is Down


Hi guys, I eventually ‘solved’ the problem… but I can’t be happy for this.
At the end of my investigations I found the guilty: it is the network socket in my laptop. Something inside is broken… :’(

Now it is working again but I have to keep the cable in a specific position, otherwise the link goes down.

Thank to all anyway for the support!