Winhoes no longer likes to boot after fresh install

So you need to repair Vista boot manager with your Vista DVD

I would unplug the hitachi

repair vista so it boots

Plug Hitachi back and set it to boot First

Now it should work

Ok I will try that … and post back here what happens … and go from there …

When you installed openSUSE it saw its drive (the Hitachi) as the first drive (sda) and the Seagate as the second drive. Grub was installed to the openSUSE root partition (sda2) which was marked active and apparently “generic” boot code was written to the sda MBR (you have an MBR on each drive) otherwise openSUSE would not have booted. So . . .

If you change the bios to boot from the Seagate, Vista should start. If it just hangs or you get a bios error message (like “no OS”), the Vista master boot code is damaged and needs to be replaced. If you get “bootmgr is missing . . .” then the Vista master boot code is there but it is the Vista partition boot record (sector) that is damaged; you would also get this latter error message starting Vista from openSUSE as the boot drive.

The Vista automatic repair should fix both, but you want to have the Vista drive configured as first in the bios boot sequence when you do the fix. You can also repair both using the “bootrec” command in the Vista Recovery Environment command line window (shell). You can get help on the bootrec command argument to use with “bootrec /?” or there is a MS support kb article which describes this in detail.

Once repaired, try switching the bios back to booting from the Hitach/openSUSE; Vista should boot from that menu. Alternatively, you can use Vista to control the boot and start openSUSE from there. There is a great little tool called EasyBCD that makes setting this up in Vista quite easy (the MS way is to use the bootedit program, which is quite difficult).

Yes, I do understand this perfectly as far was what is wrong now. I am looking for my Vista disk and will try to repair it. It that hopefully goes ok then I will install BCD … what did I do with that stupid Vista Disk…LOL

I don’t know if it will work, but you can download a recovery disk

Windows Vista Recovery Disc Download — The NeoSmart Files

I’m not sure Mingus was recommending the EasyBCD over Grub? Correct me if I’m wrong Mingus - Note

Alternatively, you can use Vista to control the boot and start openSUSE from there. There is a great little tool called EasyBCD

Having two HD’s as you do is ideal to boot from your Hitachi. Install Grub to it’s MBR, set it as first boot.
You were almost there earlier, all you need to do is repair your Vista boot.

Well when I booted using the Windows Vista Disk with the Hitachi unplugged with just the Seagate Drive plugged in on SATA 1 and Set to Boot first the Recovery Tool didn’t find my Windows OS anymore … So I used the Bootrec.exe to /ScanOs and it found it but when doing a repair /boot it said element not found…So I tried to then rebuild the MBR and it completed successfully but then I tried to reboot and got No boot filename received …

Have a look here Error when you start Windows Vista. I would try Option #2.

Maybe have a look here
Error message when you start Windows Vista: “The Windows Boot Configuration Data file is missing required information”

Recovery Tool didn’t find my Windows OS anymore
Regarding this. Sometimes in BIOS the settings for SATA option: AHCI or Compatibility - can make a difference and as I recall you must have no other devices in the boot sequence of BIOS before the CD/DVD and the HD you intend to use.

Mingus is more the expert here. Wait for a reply.

looks like mingus got there before me
good luck
I have to go out now

Yeah just tried option #2 again and got “Element not found.”

And then when I did this which is the next part of the option I got this …

Bcdedit /export C:\BCD_Backup
ren c:\boot\bcd bcd.old
Bootrec /rebuildbcd

I got Element not found.

Solution here: Repair Vista Boot Loader - Ubuntu Forums. I did notice that the bootable (active) flag had been unset (note your fdisk output), but figured that the repair would re-set it. Apparently, Vista repair chokes if the flag isn’t set in the first place (dumb, really dumb!). Setting the flag can also be done from within openSUSE, but given that it is Vista, best to use the Vista RE.

Oh and I did Microhoes to see if there was a backup for the BCD store because I can navigate to the drive using the command line in Suse and they said no…I would have to reinstall … thats almost a full TB of data gone…

Thanks for the link…I am trying that now and will post back the output…good thing I just didn’t reinstall :open_mouth:

Maybe we should sticky this or I will write it up in another post if this info on the link you posted works …

This is what finally fixed it as far as being able to boot back into Vista (taken from Repair Vista Boot Loader - Ubuntu Forums

The remedy for "Element not Found" is this:

1.Put the Windows Vista installation disc in the disc drive, and then start the computer.
2.Press a key when you are prompted.
3.Select a language, a time, a currency, a keyboard or an input method, and then click Next.
4.Click Repair your computer.
5.Click the operating system that you want to repair, and then click Next. (if no Vista operating system is listed, click Next anyway)
6.In the System Recovery Options dialog box, click Command Prompt.


At the command prompt, type diskpart.
This will get you to the DiskPart prompt, which allows you to use a variety of hard disk partitioning and formatting tools similar to FDISK in older versions of Windows.

At the DiskPart prompt, type select disk # where the # sign is the number of the hard disk drive with Vista installed on it. If your Vista drive is the only hard drive in your computer, it is Disk 0.

Select the partition by typing select partition # where the # sign is the partition that has Vista installed on it.

Type active and press ENTER. The Vista partition is now active. Finally, type 'exit' to close DiskPart. Reboot the computer using the Vista dvd and follow steps 1-6 above. You can now repair the Vista boot:

Fix the Master Boot Record: (commands)

bootrec /fixmbr
bootrec /rebuildbcd
bootrec /fixboot

Then I repooted again and got BOOTMGR is missing but oh WOW it finally recognized my Vista Partition and allowed me to use the recovery tool then automated the recovery of the MBR and the BCD and then it rebooted autmatically and boom Vista back and all 892 GIG of data … Thank you all for your patience and willing to help in getting this fixed … Now I will try to see if I can get back into Suse and dual boot how I wanted too…

All issues resolved!!! Successfull dual boot into OpenSuse as well as Vista … Thank You all for your input and your help in resolving this issue … many thanks goes out to you and the time you spent helping me fix this …

Terrific! Glad to have been of some help. :slight_smile:

Of course it is up to the user, but IMO this is often the safer and easiest approach. The combination of a foreign boot loader in conjunction with Vista’s different partitioning rules is causing a lot of grief; the latter is the underlying cause which can cause the boot loader installation to corrupt or disturb what Vista expects in the partition boot sector, in the bcd store, or in the partition table. It is very unpredictable, and the specifics of the causes in Vista are not well understood (very good info here Dual/Multi Booting With Vista). Fortunately, the corruption does not usually occur; it is much more likely when the machine is a laptop and/or there is a recovery partition.

But unfortunately, when it does happen the fix is far from trivial. A repair requires the user to either trust the Vista RE’s “automatic repair” (which often does not work) or to do the repair manually - a complex task for most users. Furthermore, most users don’t even have Vista RE media, requiring it to be downloaded and burned to CD.

Of course, the vast majority of users installing linux will not do any advance planning. So where there is going to be an issue, it only materializes after the fact, such as in the case of this thread. Once that does happen, and especially if the user has been forced to repair Vista, it seems advisable to not risk repeating the problem - and EasyBCD is an easy way to do that. In the case of this thread, had openSUSE not booted straightaway after having repaired Vista, I would have recommended using EasyBCD instead.

IMO this is often the safer and easiest approach

I have found it ever so easy to use Grub myself. But I agree - there does seem to have been some grief with Grub.
I guess if you know what you are doing in the first place it helps.

I’m going to keep a hold of this thread. I t may come in for helping others.

Of course, with most dual-booting situations, users neither know what they are doing nor is it considered in the first place - only after installation when there is a problem. So while using BCD up front would reduce some of the Vista risk, that’s academic; won’t happen. My main point is in the last paragraph - when Vista has been borked, or there is an unexplainable problem with getting grub working, EasyBCD is a very good fallback and can save a lot of time and frustration.

I would have to say honorably that I agree with both you. However, in regards to the notion that most users don’t take a fair amount of planning into consideration before installing Linux. I have used SUSE Linux since before it was originally OpenSuse and was still its own project under the simple SUSE banner all the way back to SUSE 7.3. And had been required to use Fedora for the last 4 years as that is the distribution that was required for academic classes. My problem was making the assumption that there would be no difference with regards to the use of dual boot with Vista, as said the issues with Vista and a dual boot are not that well studied. Furthermore, perhaps a more thoughtful approach for all linux distributors is to make a “Note:” regarding these types of issues either on the download page or before a user is able to install the distro that they are are at least warned because after all how many people are seriously aware of the changes the Microhoe have made to the OS since the obviously the code isn’t OpenSource. Just seams more proactive and thoughtful on the distro’s part. Not that I have any issue with the problems I had getting it to work correctly as working through an issue to get the problem resolved is part of what makes Linux and all flavors of it fun and an enjoyable task. But that’s just my two cents on it.

My comments were not meant in your direction at all, hope it didn’t come across that way. I certainly agree that with your experience the situation is different. The vast majority of dual-booting issues are with Windows users who not only have no experience with multi-booting, most have also never installed an OS. Consequently it’s almost to be expected that these kinds of problems will arise for them. Also, I agree completely with you that an informational notice of some kind would be good - at the same time, that presents a dilemma in that, without any prior experience, it won’t be well understood and would probably scare off new users. It doesn’t help that MS has dumbed-down users over the years. Thanks for your comment.